Hardware Switch Lite Wifi Issue

nurgle

Member
Newcomer
Joined
Feb 6, 2007
Messages
8
Trophies
0
XP
138
Country
United Kingdom
Hi,

I've got an issue with the wifi on a switch lite. It won't see any wifi networks at all. I've tried the usual turning off and on, factory reset but still nothing. I've got a normal switch that connects fine and can see 10+ networks but the switch lite can't see any. I got the switch lite cheap off ebay knowing about the issue beforehand, i thought it might be something that can be fixed quite easily but I've tried everything I can think of but still no wifi. I've done the usual factory reset etc...

I've got a USB network adapter and that works fine on the switch lite but it's not as convenient as wifi. I got it to install an sx lite for homebrew etc so don't mind taking it apart. I've had the case off and i've checked the connections for the antenna and they look to be fine. Does anyone else have any suggestions what to try to get the wifi working again?

Cheers,

Nurgle
 

nurgle

Member
Newcomer
Joined
Feb 6, 2007
Messages
8
Trophies
0
XP
138
Country
United Kingdom
Today the switch lite was hanging on the boot logo. After doing a bit of reading with the wifi issues and no booting it appears this is down to the wifi chip. With nothing to lose I decided to take the heatgun to the wifi chip to try and reflow it. With gun at 400oC heating the chip for 2 minutes it seems to have fixed it. The switch boots now and it finds wifi networks. I didn't even remove the mainboard out of the switch. Just disconnected the battery, moved any wires out of the way, removed the cover off the wifi chip and heated it.

So if anyone has similar issues with wifi and/or stuck on boot logo try reflowing the wifi chip. It worked for me! :D
 

Site & Scene News

General chit-chat
Help Users
    WiiMiiSwitch @ WiiMiiSwitch: How is everyone?