Supercard DSTWO Plus "Error has occurred"

Discussion in 'NDS - Flashcarts and Accessories' started by Blindfury07-09, Feb 1, 2016.

  1. Blindfury07-09
    OP

    Blindfury07-09 Newbie

    Newcomer
    2
    0
    Jan 28, 2016
    United States
    I recently purchased a supercard dstwo plus and it worked fine for a while but now it won't work on 3ds consoles anymore. I can only get games to load on ds lite console just wondering if anyone knew of a fix for this all files are in the right place 3ds version is compatible and I have tried nearly every method out there to fix the issue but cannot figure it out. does the supercard need to be reset to factory default? thanks for any help
     
  2. sieroi

    sieroi GBAtemp Regular

    Member
    133
    65
    Apr 29, 2015
    The DSTWO's probably running an old firmware version. Check the Supercard subforum for instructions on how to update it.
     
  3. DenTypenKennstDu

    DenTypenKennstDu Newbie

    Newcomer
    1
    1
    Apr 2, 2016
    Gambia, The
    The DSTWO Plus does not have any update at all yet. My DSTWO Plus does not work either I am waiting for an update to come and you should do too.
     
  4. Sendoushi

    Sendoushi Newbie

    Newcomer
    2
    0
    Jun 12, 2017
    I just bought a DS2 Plus, the DSi recognizes it but when I enter the card it gives me the "Error has occurred". Ideas on how to solve?
     
  5. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,068
    633
    Oct 22, 2011
    Gambia, The
    You can try to update the firmware with the update for the original supercard dstwo (but I won't guarantee for anything). My personal experience with the dstwo plus is that it works in ds mode with every 3ds/dsi firmware out of the box.