Starfall + 4.0

Discussion in 'Wii - Hacking' started by Knocks, Mar 25, 2009.

  1. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    If you've installed 4.0, what happened to your Starfall installation? Specifically, it would be good to know if the individual Starfall hacks still work: health warning, background music, update block, etc. Also, is it safe to turn the hacks on and off after installing 4.0?
     


  2. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,025
    7,343
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    As Starfall edited your systemmenu file, by updating you're overwriting it.

    So I'm pretty sure you'll lose all Starfall's functionalities by upgrading.
     
  3. ds22

    ds22 GBAtemp Regular

    Member
    269
    2
    Sep 27, 2008
    Netherlands
    Rotterdam NL
    The starfall hacks will no longer work on 4.0.

    so you will have to wait (4.0 has just been released you know)
     
  4. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Has anyone actually tried?
     
  5. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    Starfall installs hacks. Installing a new system menu, no matter the version, will uninstall the hacks. That's it.

    Besides, I just installed the new system menu since I wanted the run from SD option pretty bad and it got rid of my Starfall, so even if I hadn't been sure I know now. Make sure you have a new cIOS installed first, then you have more of an avenue for hacks.
     
  6. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    There's still a chance it might work with the new menu. The hacks are pretty basic and just make byte-size changes to a text file. If those options are still present after the update, there's no reason they can't be changed again.
     
  7. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,025
    7,343
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    I guess that StarFall checks for a 3.2 SystemMenu before applying the hacks to the respective addresses. There's a serious chance of bricking, by installing StarFall on 4.0.

    If addresses changed between 3.2 and 4.0, and StarFall doesn't come with a protection of some sort, it could end up editing the wrong addresses, potentially bricking your systemmenu.

    Just wait.
     
  8. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    I'm not trying to be a jerk here, but if you know this for fact then why ask us? Anyway, raulpica is right. Best to just wait for now to see what happens. I bet that eventually we'll see (for example) preloader hacks that work with the new menu.
     
  9. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Do you know the difference between "there's a chance" and "know for a fact"?
     
  10. Hells Guardian

    Hells Guardian GBAtemp Maniac

    Member
    1,113
    1
    Dec 25, 2008
    United States
    Ok first off the starfall tool physically will not work on any system menu other then 3.2 It does an internal check and if it's not 3.2 it returns an error. This is a safety measure for it. So in other words it's not going to work. Period. As for the use of the preloader hacks system you have to be able to install preloader to use it. So that's a no. Just wait for awhile and eventually this update will be broken.
     
  11. Minho

    Minho Member

    Newcomer
    19
    0
    Mar 8, 2009
    United States
    Excuse me, but what exactly is Starfall?
     
  12. mrgarrison

    mrgarrison Advanced Member

    Newcomer
    66
    0
    Mar 13, 2009
    Canada
    Kelowna BC
    wow, its like the search button is invisible or something...
     
  13. SyNNeR6x3

    SyNNeR6x3 Member

    Newcomer
    27
    0
    Nov 14, 2008
    United States
    Las Vegas, NV
    Try This:

    [​IMG]
     
  14. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    Oh my, I'm so hurt by the way you try to take my words out of context. [​IMG] Please.
     
  15. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    It's good that you're not hurt, because you also don't know what "taking words out of context" means. I said there's a chance it might work, and you said that I somehow knew this for a fact.
     
  16. jinxvorheeze

    jinxvorheeze GBAtemp Advanced Fan

    Member
    572
    0
    May 13, 2008
    United States
    There is no chance it will work. None at all.

    If you install Starfall then update, the hacks are erased
    If you update then attempt to install the hacks, it will check to see if you are on 3.2 and when it see's you are not, it will return with an error.

    This is not a guess, it is fact.
     
  17. PSeeCO

    PSeeCO Member

    Newcomer
    13
    1
    Feb 24, 2009
    Italy
    Leghorn
    I'm still on 3.2 with starfall, just cause i may need it in case of semi brick...is there any other homebrew that can be used to load games on a semibricked wii?
     
  18. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Scroll up and re-read my post. It was about how the hacks are done. Version check is just a feature of Starfall, not a technical barrier to installing the hacks on other firmware. It IS possible for the same hacks to work on newer firmware, we just don't know because the only software that allowed them has a version check. And as raulpica noted, there is a chance of bricking if the addresses in the new firmware are changed.
     
  19. patz

    patz GBAtemp Regular

    Member
    288
    3
    Nov 6, 2002
    Thailand
    Will we ever get an update version of Starfall?
     
  20. Raziel5000

    Raziel5000 GBAtemp Regular

    Member
    189
    0
    Oct 23, 2008
    United States
    i am not a developer of any kind, but i can assure you that these folks that spend time hacking and cracking are in so deep that they will feel like they have wasted the time they have put into this so far to let an update stop them from progressing. give them time and i am sure there will be a hack of some sort that does what we had before available. i have seen some amazing things come from this forum, and hope to see more in the future!