1. godreborn

    OP godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    17,273
    Country:
    United States
    is there something better than nsp verify? I mean something that will not show errors if a file has been patched to accept lower firmware? I don't have an exploited switch yet, so I've been testing each nsp with nsp verify. however, it appears there's a problem with it. is there any other way to determine if an nsp is good on the pc?
     
  2. Masamune3210

    Masamune3210 GBAtemp Regular
    Member

    Joined:
    Apr 23, 2016
    Messages:
    126
    Country:
    United States
    NSC_BUILDER can verify files, and will usually tell you if things have been modified instead of fully counting the file as corrupt
     
    godreborn likes this.
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,747
    Country:
    Norway
    It's not a problem with nspverify, it's working exactly as intended. Either the patcher is just bad and doesn't update checksums or it's just the patching process itself makes it fail verification. You don't need to patch nsps to work on a lower firmware, NSP installers can already ignore the version requirement. The only time the NSP has to be modified is when it's using newer crypto, and obviously messing with the encryption on the file is gonna make nspverify throw errors.
     
    godreborn likes this.
  4. godreborn

    OP godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    17,273
    Country:
    United States
    I have that app. where is that option?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Something, Replace, Verify