Soft modding very early Wii - help needed please

Discussion in 'Wii - Hacking' started by dantheman_uk, Jul 30, 2015.

  1. dantheman_uk
    OP

    dantheman_uk Newbie

    Newcomer
    3
    0
    Jul 30, 2015
    Hi All

    Firstly, great forum - I've found it really useful in getting started with modding my Wii, which came out of the box for the first time in about 3 years the other week!!

    So, I have a bunch of wbfs game backups which have been loaded onto an external HDD using Wii backup manager. The drive is formatted FAT32 with 32k allocation unit size. The files have all been SHA-1 checked on the drive and appear to be ok. I am plugging the drive into the top USB port (port 0?) with a Y cable, the other cable for power only is in the second port.

    I soft modded my Wii and have both Wiiflow (4.2.1) and USB loader GX (3.0 r1239) installed. I have also done a NAND backup etc just in case!

    I'm currently trying to use Wiiflow. At the moment I can only get 4 or 5 of the 23 games I have on the drive to load. Wiiflow finds all of the games when the drive is mounted, so I can see them in cover flow. The ones that don't load either just drop out to the system menu, or completely hang the Wii, forcing me to do a hard reset. There is a blink on the HDD access LED then it bombs - doesn't get as far as the bar across the bottom of the screen :(

    I have tried changing the video mode (PAL60 seems to be my best option on the games that work - I'm using a component cable if that makes a difference) and forcing different IOS in the settings for each game, which is why I have had some good results, but my lack of success is making me think I've done something stupid. Games that work are a mix of PAL and NTSC. None of them worked with default settings.

    I pointed wiiflow to a game on the SD card, but still no success. I have also updated some of the IOS (246 to 251) from d2x v8 to v10. No joy.

    Syscheck

    Does anyone have any suggestions?

    Any help would be gratefully received :)

    Dan
     
  2. DaMan4169

    DaMan4169 Advanced Member

    Newcomer
    95
    4
    Aug 12, 2009
    United States
    Well your Syscheck looks good, pretty standard config.
    I might try the d2x v10 beta52 cIOSs, before trying a different USB drive.

    IIRC the beta52 is the continuation of the v8 whereas the alt versions are based off some stuff they did in the v9 that fixed some things but made others buggy.

    I haven't had any issues with any Sandisk drive I've used as a Wii drive and they are fairly inexpensive now, even on your side of the pond.

    This Compatibility List is old but check for your drive to see if others had issues or it tested fine.
    I know some drives had sleep issues but I thought usually those presented as a game freezing, usually after about 5-15 min of play. You had to adjust power management options and I think Seagate and WD had specific tools you had to download from them to do it.

    I would stick to games made for your region. While the console can play any region game with a USB loader, the issue is your TV may not be able to display it. Unless you check your TV specs and it can display NTSC, PAL, and SECAM you may just be adding to your headaches while troubleshooting.
     
  3. dantheman_uk
    OP

    dantheman_uk Newbie

    Newcomer
    3
    0
    Jul 30, 2015
    Ok, thanks for the suggestions.

    I ran my config through ModMii last night and updated a few OS:

    1. Your unique list of WADs to install are as follows:
      • IOS11v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS20v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS30v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS40v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS50v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS52v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS60v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS70v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • IOS80v16174(IOS60v6174[FS-ES-NP-VP-DIP])
      • RVL-mios-v10
      • IOS9-64-v1034
      • IOS36-64-v3608

    No joy.

    The TV is a fairly new Samsung and claims to support NTSC and SECAM, but I'll stick to PAL until I (hopefully) get things working.

    The drive enclosure I'm using isn't on the compatibility list, so it may be to blame (I tried USB Loader GX last night and it can't even mount it):
    Vendor 04FC - Sunplus Technology Co., Ltd
    Product 0C15 - SPIF215A SATA bridge

    I have a Sandisk Cruzer Edge 8GB lying around so I'll try that if updating the cIOSs doesn't work.

    Thanks.
     
  4. portugeek

    portugeek GBAtemp Fan

    Member
    375
    67
    Apr 6, 2013
    United States
    USB Port 0 is the bottom port if your Wii is laying down flat. I'm not sure if any of this matters while using a Y cable since I assume you have both ends plugged into your Wii, unless one end of the cable is specifically meant for data, and the other for power. If one side IS specifically designed for data then you want that side plugged into the bottom port (USB Port 0). I'd try plugging in the other side of the Y adapter to another USB port that's not on the Wii and try powering it that way. I don't know how long your Y adapter ends are. You may need a USB extension cable.

    I remember my friend trying to use a Y adapter on his Wii and having issues. Not all USB cables are the same. I ended up having a good single line USB Power & Data cable that I gave him and his Wii started recognizing his harddrive after that.

    Also, there are harddrive settings on USB Loader GX that let you choose which USB Port to use. It even lets you choose "both", but I've never had a lot of success with this setting. Since getting Port 1 to work correctly is completely dependent on which cIOS is being used by your USB Loaders when they boot up.

    Another thing I'd like to mention, because I was confused by it when I first started, and still am sort of. Is how the USB numbering is misleading. For example. USB Port 0 is the bottom port and USB Port 1 is the top port. You want to be using USB Port 0 for data, but when you change your USB paths, the path associated with USB Port 0 is labelled as "usb1:/" I'm sure there's a smart reason for it, but it makes things confusing, and I don't like it.
     
    Last edited by portugeek, Jul 31, 2015
  5. dantheman_uk
    OP

    dantheman_uk Newbie

    Newcomer
    3
    0
    Jul 30, 2015
    Ahaaa!!

    So I was using the wrong USB port, and the Wii wasn't the biggest fan of my drive enclosure.

    SanDisk memory stick in the bottom port and all seems to work.

    Thanks a lot folks :)