Sky3DS vs Sky3DS+ in a quick summary

Discussion in 'NDS - Flashcarts and Accessories' started by TehJim08, Oct 13, 2016.

  1. TehJim08
    OP

    TehJim08 Member

    Newcomer
    17
    1
    Sep 13, 2016
    Quick question about the Sky3DS, when compared to the Sky3DS+ is it just the extra software needed to load games and the lack of another button that is the difference between the two because I don't want to spend another £10 on some features I don't need.
    Just wondering if the extra £10 makes the Sky3DS+ a better buy.

    Many thanks ;)
     
  2. trsoares

    trsoares GBAtemp Regular

    Member
    127
    26
    Nov 23, 2015
    Brazil
    Just a quick question, you want to play new games?
    If yes, then go with a sky3ds+.

    Some new games will not work in the older sky3ds because of a "new ant-cheat".
     
  3. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,589
    2,656
    Oct 28, 2015
    United States
    Wrong section. Also, what firmware are you on? You might not even need a flashcard.
     
  4. iAqua

    iAqua

    Member
    2,842
    2,504
    Dec 7, 2015
    Antarctica
    Sky3ds is the same as Sky3ds+, but without anti-piracy. If you're under firmware 10.7 you can follow this guide and get all those games without paying for a flashcart.
     
  5. Clector

    Clector GBAtemp Advanced Fan

    Member
    969
    234
    Mar 15, 2016
    Bangladesh
    Not here
    With a Sky3DS+ in comparision with a Sky3DS with a Blue or Red button you don"t need to use a template for add games, you have two buttons to make it easier to go trough games than with one button and you can play new games with the AP patch that are basically all new games.
    If you want to play games with the AP (Anti Piracy) patch, you will need a Sky3DS+.
     
    Last edited by Clector, Oct 13, 2016
  6. TehJim08
    OP

    TehJim08 Member

    Newcomer
    17
    1
    Sep 13, 2016
    Im planning on playing pokemon x and y smash bros and zelda mainly. Will sun and moon work on it?
     
  7. iAqua

    iAqua

    Member
    2,842
    2,504
    Dec 7, 2015
    Antarctica
    Absolutely! NOT. You'll need a Sky3ds+, but what firmware is your 3ds on?
     
  8. TehJim08
    OP

    TehJim08 Member

    Newcomer
    17
    1
    Sep 13, 2016
    Im on 11.1 so I basically cannot downgrade without ripping a massive hole in trousers and setting the house on fire
     
    hobbledehoy899 likes this.
  9. iAqua

    iAqua

    Member
    2,842
    2,504
    Dec 7, 2015
    Antarctica
    Well, then you should get the +.
     
  10. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,903
    2,232
    Jan 11, 2016
    Japan
    日本
    Instead of paying for a sky3ds+ just get a hardmod and downgrade to install A9LH? All free apart from the downgrade but worth it than spending money on a flash cart.. @gamesquest1 does hardmods in the UK ^^