Sky3ds+ questions

Discussion in '3DS - Flashcards & Custom Firmwares' started by trav75, Jan 29, 2016.

  1. trav75
    OP

    trav75 Newbie

    Newcomer
    3
    0
    Oct 4, 2007
    United States
    Hi all,

    I just got a Sky3ds+ and I've been reading up on what to do but I'm confused about some things. I have an original 3ds that is on firmware version 5 dot something, and I have an original 3ds XL that is on firmware 7 dot something.

    Do I need to update the firmware to the latest to be able to play newer games? I am hesitant to do this since I have read that they have been blocking off a lot of homebrew exploits in the newest versions. It seems I have read a lot about version 9 fw being a good one to be on. Is that true? If so, do I need to get a game that can upgrade the fw to 9?

    I have also read stuff about applications to spoof the firmware version which will enable you to play newer games on older firmware. Is this a better way to go?

    Thanks in advance for any help. I just want to make sure I know exactly what I'm doing before I update the firmware.
     
  2. kurodax

    kurodax GBAtemp Regular

    Member
    132
    34
    May 29, 2015
    yes you have to update your fw to play new game on sky3ds+