Sky3ds+ not working with Monster Hunter 4 (US)

Discussion in '3DS - Flashcards & Custom Firmwares' started by frenccw, Jan 23, 2016.

  1. frenccw
    OP

    frenccw Newbie

    Newcomer
    1
    Jan 23, 2016
    Hi guys, anyone else having issues with Monster Hunter 4 Ultimate (US) on Sky3ds+? I've updated the game and i can't get pass the Character Creation page. It only worked the first time i played it; subsequently i have never succeeded in continuing the game.

    Any ideas?
     
  2. Ekaitz

    Ekaitz Redhead Believer

    Member
    4
    Jun 13, 2010
    France
    I had the same problem with the EUR version.
    I deleted my character, I recreated it and I accepted the tutorial things when it was asked.
    It worked perfectly for me.
     
  3. Stardotstar

    Stardotstar Member

    Newcomer
    2
    Aug 21, 2008
    Do you have a USA 3DS? The Skycard is region specific (unless you're using Ninjax etc) so if you've not got a USA version perhaps download another. Also have you updated your firmware with the recent change? http://sky3ds.com/download.html
    Good luck.
     
  4. frenccw
    OP

    frenccw Newbie

    Newcomer
    1
    Jan 23, 2016
    It works the first time, and then after i restart the game the same problem persists. I've tried both saying no and yes to the tutorial question. Are you using Sky3ds+ on the latest 110 firmware?

    Yes im using the latest firmware. Region shouldn't be an issue as i can launch the game just fine. In addition i am also using US ROM on a US 3DS. Other ROMs works fine. I've also tried getting the ROM from another source but it still has the same issue
     
    Last edited by frenccw, Jan 23, 2016
  5. chaosrunner

    chaosrunner Substitute Soul Reaper

    Banned
    3
    Sep 27, 2015
    Canada
    Hueco Mundo
    that sucks
     
  6. Ekaitz

    Ekaitz Redhead Believer

    Member
    4
    Jun 13, 2010
    France
    I had the problem on the first firmware. (v100)
    I did not have any issue with the game since this "glitch". I just recreated my hunter and say yes to the tutorial and everything went smoothly then.
     
  7. SomecallmeBerto

    SomecallmeBerto The Anti-Hero

    Member
    5
    Dec 17, 2014
    United States
    USA
    Did you format the sd card? If not format it with sdformatter. Your rip might have also just gone bad. Remove the update and try again without the update.

    See what sticks
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice