Should i get Acecard 2.1?

Discussion in 'Acekard' started by XZShadowZZ, Sep 22, 2009.

Sep 22, 2009

Should i get Acecard 2.1? by XZShadowZZ at 4:47 AM (977 Views / 0 Likes) 5 replies

  1. XZShadowZZ
    OP

    Newcomer XZShadowZZ Member

    Joined:
    Aug 4, 2009
    Messages:
    19
    Country:
    United States
    So i have a dstt but now with mario and luigi bowsers inside story piracy checks and all that, Im afraid ill have to get a better card. So should i get a acecard or a m3 real? They both seem good but i dont know. Im using a cobalt blue ds lite by the way.
     
  2. wolffangalchemist

    Member wolffangalchemist This is bat country!

    Joined:
    Nov 23, 2008
    Messages:
    1,406
    Location:
    middleofnowhere, AL
    Country:
    United States
    i ordered a ak2i cuz of DSTT's lack of support for newer and upcoming games, should be here tomorrow since i ordered from gamebygame.
    so by all means do it akaio 1.5 was just released too so your good to go with M&LBIS.
     
  3. XZShadowZZ
    OP

    Newcomer XZShadowZZ Member

    Joined:
    Aug 4, 2009
    Messages:
    19
    Country:
    United States
    Does the ak2i work with ds lites? I heard it does, but im just checking.
     
  4. omgpwn666

    Member omgpwn666 Guy gamer and proud!

    Joined:
    Jun 14, 2008
    Messages:
    2,535
    Location:
    Florida
    Country:
    United States
    Works with DS/DS lite/DSi
     
  5. tedmg09130913

    Member tedmg09130913 GBAtemp Regular

    Joined:
    Aug 23, 2007
    Messages:
    215
    Country:
    United States
    All of the dsi compatible flashcards work with the ds lite.
     
  6. XZShadowZZ
    OP

    Newcomer XZShadowZZ Member

    Joined:
    Aug 4, 2009
    Messages:
    19
    Country:
    United States
    Ok, thanks for the info!
     

Share This Page