COMPLETED ScummVM

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by cpasjuste, Apr 1, 2018.

  1. RCP90totheface

    RCP90totheface Member

    Newcomer
    2
    Jun 3, 2018
    United States
    Weird, I couldnt get BR to run on the latest daily. Not sure if it's related but I'm again experiencing the issue where to 'add game' I can only pick from the ScummVM folder itself, I can't 'go up' into the rest of the folders where I put my roms. Nevertheless, I grabbed the files from an apparently decent source and picked the ones I needed according to the Wiki, and put the folder inside my ScummVm folder, for now.

    All the files are there (I counted and checked) but I get 'ScummVM Couldn't open the specified directory'.

    Any ideas, anyone? Thanks!

    Screenshot 2019-06-19 at 23.52.06.
     
  2. notimp

    notimp GBAtemp Addict

    Member
    11
    Sep 18, 2007
    There was something with the folderpath for scummvms game folder having to be - somewhere. I forget. Read this thread. ;)

    Try to put the games folder in root. Then try to put it in /switch/scummvm/games/ One of those should work.. ;) My switch currently is off - and I cant look it up. ;)

    If you have bought a fake sdcard, or are using exfat - because you are one of the SX OS drones, that tend to ruin this scene with their not reading, well - I guess the problem lies somewhere between - we dont support filesystem issues, issues that arise from exfat being used, or issues that stem from you buying fake SDcards. How could we. Why should we. ;)

    — Posts automatically merged - Please don't double post! —

    I think I've just remembered, that the filepath issue with scummvm was, that it couldnt navigate to certain folders outside its own folderpath.

    So whatever your issue is - it seems to be different / unrelated.

    If you can navigate into the folder, its in a usable path already. Navigate into the games folder containing the files, then use the confirm/add button (not just with the folder highlighted, but move into the folder). Shouldnt be it - but thats what I did.

    Make sure your game folderpath doesnt include any special characters. Something simple like bladerunner should do.

    Make sure you dont launch hbl and scummvm via album. But via an installed switch game while holding R. And if thats the issue - hey start reading -this thing is littered over this forum 1000 times already. A default changed - we dont launch HBL via album anymore. Because that never gave you full ram access.

    If thats not it - its filesystem/sdcard corruption stuff. Or a broken dev build from the buildbot one day later (which seems unlikely).

    If somone else can confirm the latest build working with it - its user error or dau error.

    — Posts automatically merged - Please don't double post! —

    Ah, and as I see you are on a Mac - run hekates "fix archive bit for every file/folder except the Nintendo folder" once (its somewhere in the hekate tools section afair).

    That could be the issue as well.

    Next time install via ftp, or use a windows, or linux system to avoid this issue. Or remember to do the hekate "fix all files except the Nintendo folder" after you create new folders.

    I bet thats it.
     
  3. RCP90totheface

    RCP90totheface Member

    Newcomer
    2
    Jun 3, 2018
    United States
    Thanks for this Notimp. My SD is good and Fat32 so no issues there.

    Interestingly the issues Soully reports of not being able to run the Discworld games is also replicated here. I always transfer via FTP. Could be related to one of 2 things you mention - either MAC issues (will try the Hekate thing, need to look that up), and also need to look into launching HB not from the album. I've heard something about this but not tried it yet (no real issues using HB via album yet so just havent got around to it), so I'll do some googling. Gives me a couple of things to try.

    I DLd a quick ScummVM for OSX which runs by Blade Runner build, so no issues with that.

    Thanks again,
     
  4. notimp

    notimp GBAtemp Addict

    Member
    11
    Sep 18, 2007
    If you transfer via FTP its not Mac or archive bit related. (If you havent created the games or scummvm folders with Macos.) Now the most likely issue is build issue? Someone else could get this to run with the most current dev build?

    (I'll PN you with a link to my version at the end of the day - if no one responds. (My switch is still turned off, and I dont have the payload injector near by currently).)

    Do other games work fine?

    You are not launching into ScummVM via album, but via an installed game (hold R while launching an installed game (not gamecardslot)), right?
     
    Last edited by notimp, Jun 20, 2019
  5. notimp

    notimp GBAtemp Addict

    Member
    11
    Sep 18, 2007
    @RCP90totheface as promised - here is a known good .nro together with data and doc file folders for troubleshooting.

    https://www31.zippyshare.com/v/WxamuTYu/file.html

    Put a games folder into the scummvm folder. Put a bladerunner folder into the games folder. Put the game files there. Use hekate archivebit except for Nintendo folder (in Hekate tools section afair) once - just to be sure. Then it should work regardless.

    if not. Something is wrong with your SD card or your game files.

    Other people should still download the official builds, I doubt - that its them causing the issue - this package is for troubleshooting only. Rights are held by their respective owners. (Not me. ;) )
     
    Last edited by notimp, Jun 22, 2019
    seanp2500 likes this.
  6. Angelus3K

    Angelus3K Advanced Member

    Newcomer
    5
    Mar 30, 2009
    United States
    Got the latest nightly build but for some reason I’m stuck with half a screen, docked and handheld???

    — Posts automatically merged - Please don't double post! —
     

    Attached Files:

  7. Angelus3K

    Angelus3K Advanced Member

    Newcomer
    5
    Mar 30, 2009
    United States
    Sorted. Was an OpenGL issue.
     
  8. Dichotomy754

    Dichotomy754 GBAtemp Regular

    Member
    4
    Nov 11, 2018
    United States
    I'm running Discworld 2 with no problems, though it did crash on startup when MIDI was set to first available (I Have No Mouth also wouldn't run, complaining about not being able to find something). I'm sure those sound emulations are important for some games but I was just messing with them out of curiosity and haven't run into any crashes since disabling it again.

    I was wondering if there was a forwarder I could use to make NSPs of certain games, like RetroArch has. Discworld won't even let you return to launcher anyways, fewer clicks is always nice.

    Edit: Oh, it would also be great to have the option to switch the A and B buttons for certain games.
     
    Last edited by Dichotomy754, Jun 21, 2019
  9. seanp2500

    seanp2500 GBAtemp Advanced Fan

    Member
    6
    Jun 2, 2010
    United States
    wow at bladerunner

     
    lordelan likes this.
  10. RCP90totheface

    RCP90totheface Member

    Newcomer
    2
    Jun 3, 2018
    United States
    Notimp, thanks for this. Apologies for my lateness in responding, I've actually been on vacation and away from internet access for a few days, and won't get to try out your file until Wednesday evening. Do appreciate your help though!

    I will say though that I have NOT been launching so far via an installed game - I'm just a bit shit at following instructions. Look forward to trying this, and your ScummVM build, Wednesday night when I'm back. Yeah everything apart from Discworld games and this seems to work - will report back later anyway. Love this emu.
     
  11. notimp

    notimp GBAtemp Addict

    Member
    11
    Sep 18, 2007
    No need to install the game on the PC side, just extract the correct data files, and rename the four files listed in on the scummvm wiki, and thats all that is needed. (For clarification.)
     
  12. RCP90totheface

    RCP90totheface Member

    Newcomer
    2
    Jun 3, 2018
    United States
    Cheers for the help. Got it working - used your version of the Emu, reinstalled the game and loaded via HbMenu. Something worked though I dont know what! Discword games still dont work though - maybe there are some bad dumps floating around, weird because I thought I'd tested these ROMs before.

    Couldnt work out Hekate - found it, put it on my Switch, no Nro so nothing to launch...anyway Blade Runner is working now so I'm happy :)
     
  13. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    Anyone trying Hyperspace Delivery Boy, new game added in the latest daily builds? I'm playing the PocketPC version, as it's the only one I've found the full version of so far, but in-game it's funny about whether it registers mouse clicks or not (the Mac daily ScummVM build doesn't seem to have the same issue), I haven't figured out what makes it work or not work yet. They always work for menu stuff.
    Also the game itself has dpad support, IDK if that's something ScummVM can use at all, but would be nice.
     
    Last edited by hippy dave, Sep 5, 2019
  14. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    I don't know if anyone else is interested in this game (it's a retro block-pushing puzzle story game, with optional action mode), but I figured out the problem I was talking about. I found the full Windows version on an abaondonware site, and have just been trying that (it's got full voiceover that's not on the pocket pc version, and less cramped screen), and found the same issue about whether mouse left clicks (simulated via touchscreen or B button) are registered to move your character or not. Normally they are, but after you do the game's action button (right-click, which is A button or two finger touch), the game still registers a left click, for the game interface, but not for character movement. I found a quick fix which is to press R + X, which is the Return key, and then character movement will work again normally.
     
  15. mathew77

    mathew77 GBAtemp Regular

    Member
    3
    Jan 19, 2019
    Norway
    I think, it's abandonware for now, and there's no version with libnx 2.5.0 for FW 9.x.x support?..
     
  16. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    It's not remotely abandoned, it's being built regularly by the official ScummVM buildbot and available from the official website. I haven't actually checked if that's been updated for latest libnx, but I would guess so by this point - if not it'd be worth chasing up.
     
    mathew77 likes this.
  17. MAN-biker

    MAN-biker Newbie

    Newcomer
    1
    Jul 14, 2003
    Serbia, Republic of
    Hi. I'm working on (and support) RUSSIAN translation of Lands of Lore - Throne of Chaos.
    Can anybody recompile SCUMM VM build for Switch WITHOUT CHECKING HASHES for LoL game?
     
  18. rsn8887

    rsn8887 GBAtemp Advanced Fan

    Member
    10
    Oct 8, 2015
    United States
    I just tested Blade Runner using latest Switch build and it works. So you can use the “latest development build” from here if you want: https://buildbot.scummvm.org/builds.html
     
  19. Angelus3K

    Angelus3K Advanced Member

    Newcomer
    5
    Mar 30, 2009
    United States
    Anyone got a ScummVM NSP forwarder please?
     
  20. lisko

    lisko Advanced Member

    Newcomer
    3
    Oct 28, 2018
    Italy
    Blade runner works fine also on latest stable 2.1.0 from scummvm.org for people who like stable setups
     
    hippy dave likes this.
Quick Reply
Draft saved Draft deleted
Loading...