Save file problems for NoCashGBA

Discussion in 'NDS - Emulation and Homebrew' started by KingdomBlade, Sep 8, 2009.

Sep 8, 2009
  1. KingdomBlade
    OP

    Member KingdomBlade Blade v3+ (I R SHMEXY)

    Joined:
    Apr 24, 2009
    Messages:
    2,941
    Location:
    In Vulpes' Fur
    Country:
    Philippines
    Well, I tried searching, but all are the exact opposite of my problem, so here goes.

    I'm trying to play Prof Layton 2, KH 358/2 Days, and HM:IoH on the No$gba because I want to make video reviews of them. I copy over the save files from my Acekard running AKAIO and then I open the games with the latest version. Once that happens, it wouldn't work since it said it was unable to read data. After a bit of searching, I discovered you were to set the save file so I set it to FLASH512KB, then replayed the games, what happened was, suddenly, when I tried, all of them appeared to have lost my save game progress. All said New Game.
     
  2. Golfman560

    Member Golfman560 TheRapist.com

    Joined:
    Dec 29, 2008
    Messages:
    1,099
    Location:
    Living with seals
    Country:
    Antarctica
    Alright first off No$GBA can't see the save files because they are compressed by AKAIO if it set to the defaults. The save files No$GBA needs are about 64KB while an AKAIO save might just be 10KB or so. So by setting AKAIO to read and write the FLASH512KB save files, thats all it will look for while loading saves and all it will create when saving saves.
     
  3. KingdomBlade
    OP

    Member KingdomBlade Blade v3+ (I R SHMEXY)

    Joined:
    Apr 24, 2009
    Messages:
    2,941
    Location:
    In Vulpes' Fur
    Country:
    Philippines
    All of my save files are 512 KB from AKAIO, since I use that. So, what do you suppose I should do?
     
  4. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    First off, use v2.6a so you don't have to select the save type. Secondly, open the no$gba.ini file in Notepad (if you don't have one, open a game and choose Save Settings to create it) and change the "SAV/SNA" setting from "compressed" to "RAW". Then copy your save files into the BATTERY folder and try again.
     

Share This Page