[Research] eSHop access on Firmware Below 10.2

Discussion in '3DS - Nintendo Network' started by MAXLEMPIRA, Nov 16, 2015.

?

Want eShop Access on your OFW?

  1. 4.5-9.2 (YES)

    26.3%
  2. 4.5-9.2 (NO)

    1.3%
  3. 9.2-9.5 (YES)

    26.3%
  4. 9.2-9.5 (NO)

    3.9%
  5. 9.3-10.1 (YES)

    50.0%
  6. 9.3-10.1 (NO)

    0 vote(s)
    0.0%
  7. Does this works for you?

    2.6%
  8. Des this work for you? (NO)

    3.9%
  9. SysNAND

    11.8%
  10. EmuNAND

    22.4%
Multiple votes are allowed.
  1. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    EDIT: SUCCESSFUL!!

    **WARNING: Please Read This Before Attempt to do Anything!!**


    ***WARNING!!!***

    I've updated EmuNAND to 9.6, so this should work for (ANY GW Mode EmuNAND), So, If you are using Gateway, and ONLY Gateway, for EmuNAND, the more easiest way is to follow this guide.

    1.- Installed Nver (FW 10.2) to get "-28" FW part.
    2.- Installed eShop (FW 10.0) to get new URL's.
    3.- Used Free MultiPatcher for FW Spoof.
    4.- Profit!

    NOTE!!: If you have Gateway for EmuNAND, there should be no problem if you install eShop (FW 10.0) and use the guide above.
    If you are using another way to use EmuNAND, DON'T INSTALL eShop (FW 10.0), or it will result on a 3DS Logo Loop!

    User @Aroth used another way make eShop works! So, if you are using another way to launch EmuNAND, you can use this one, and maybe it could work for you on SysNAND.

    1.- Install Nver (FW 10.2) to get "-28" FW part.
    2.- Launch The Homebrew Channel.
    3.- Use eShop Shortcut.
    4.- Profit(?).

    Feel free to use which you consider better, or if one doesn't work for you!
    Worth mentioning that this last guide does not work for me, so I had to use the first solution! This means there is something more about all this problem!


    **You can check for Title, Title ID and Title Versions on this Web**


    So... these are my guessings for access to eShop on 4.5-9.5 SysNAND/EmuNAND... GET eShop FW 10.0 WORKING ON OLD FW's! I guess EmuNAND users on N3DS can make a Cryptofixed eShop and then install it on their EmuNAND, like the new games with Seed Key... (NEVER INSTALL MODIFIED SYSTITLED ON SYSNAND) for SysNAND it doesn't work... so, our last hope is to wait for someone who made a patch for OeShop with these new URL's to let us download Titles... and for SysNAND 9.6-10.1 users, a way to Spoof NVer or that "-28" FW part... and of course, FMP for SysNAND or HANS?.

    Well Temps!! I've made this threat to clarify all this guessing about "HOW TO SPOOF eSHOP ON FW's BELOW 10.2" here is what we need, and, since I'm not a coder or hacker, wait for someone to made this to happen.

    Hope this Research help to resolve this, and good luck!!

    First Old Post!
     
    Last edited by MAXLEMPIRA, Dec 1, 2015
    TR_mahmutpek and Ridge like this.
  2. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Right now I'll try to update an EmuNAND to 9.6 and install NVer and eSHop, and then use eShop HANS and pray for it to work, I'll be Editing the results that I have on my tests!
     
  3. thaikhoa

    thaikhoa GBAtemp Maniac

    Member
    1,146
    331
    Sep 16, 2008
    eShop FW 9.7 is the tiger v18432 and NVer is v448? Thanks.
     
  4. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    For O3DS, Yes, I left an URL in the first post where you can check Titles, their ID and Version!
     
  5. thaikhoa

    thaikhoa GBAtemp Maniac

    Member
    1,146
    331
    Sep 16, 2008
    I'm on N3DS.
     
  6. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Ok, wait, apparently, the last eShop is on 10.0...
    eShop (10.0) is ver. v19465 and NVer is v448, both for N3DS
    I have added the page where you can check in the first post
     
  7. soulskeeper

    soulskeeper GBAtemp Regular

    Member
    193
    18
    Aug 16, 2007
    Iceland
    You have linked this thread in mine for a solution to how to use eshop on N3ds XL 9.5.0 sysNAND and all I saw is that you are saying that it isnt possible on 9.5.0,

    am i right?
     
  8. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Yeah, I linked it. If your on EmuNAND 9.5, it's possible to do it, just downloading eShop, making a Spoofed version and installing it on EmuNAND, otherwise, right now yep... there is no options for us. But the point is to let people know why it's not possible and what is needed
     
    Last edited by MAXLEMPIRA, Nov 16, 2015
  9. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    First off the problem has absolutely nothing to do with the eshop itself. As of last week when you attempt to sign into a NNID, the server requests that the system return the version of the currently installed NVer. If the returned value is lower than the latest one on the CDN, the server returns Error Code 022-2155. Afaik it is currently unknown at this time if the polled value is simply the version number of the installed NVer title or the actual contents of the title (the -## part of the system version). This will happen ANY time the system attempts to sign into a NNID. If no NNID is linked to the system then this will never happen, though you might get a different error code if you access a service that requires a NNID.

    As for resolving the problem, there are three options depending on your system model and firmware.

    If you have an O3DS and the ability to install .cia files (sysnand of 9.2 or lower), just freaking update your emunand to 10.2 or 10.3. There is absolutely NO reason for someone with an O3DS and a sysnand on 9.2 or lower to to not have an emunand set up and no reason for said emunand to not be on 10.3 at this point. Do not mess with installing system titles from newer versions, JUST UPDATE YOUR EMUNAND.

    If you have a N3DS and can install .cia files you simply need to install the latest NVer for the N3DS, which is v448. At this point you can once again use HANS to access online features (including the eShop) with no other issues. If you happen to own a GW cart and use it instead of a CFW, then you can also install the latest version of tiger (the eShop) which is currently v19465 and then you can access the eShop from Gateway Mode while using FreeMultiPatcher. Do NOT install the latest version of tiger unless you use Gateway Mode, and if you do install it then do not attempt to launch it from Classic Mode or from another CFW. It will not fully launch, only stall on the Nintendo 3DS loading screen.

    Under no circumstances should updated system titles be installed directly to your sysnand. If you are not using an emunand and wish to access the eshop, please set up one before attempting these fixes. Attempting to install updated versions of any system title can potentially cause problems with your sysnand no one on this site will be responsible for a bricked system. In neither of these situations is there any need to install updated versions of ANY system title other than NVer and potentially tiger (if you use Gateway Mode).

    If you happen to have a system with a sysnand version of 9.3 or higher, then at this point in time you have no other recourse other than to update to 10.3 using the internet and system settings. If you happen to currently use homebrew and any other access point besides ninjhax, please make sure to update your payload BEFORE updating your system. Keep in mind that most of the *hax that do work on 9.3-9.9 were patched between 10.0 and 10.3.

    tl:dr edit:

    O3DS with .cia installer -> update emunand already ya lazy bum

    N3DS with .cia installer -> install updated NVer (v448) and use HANS

    N3DS with .cia installer and Gateway -> install updated NVer (v448) and tiger (v19465) and use FreeMultiPatcher with Gateway Mode ONLY.

    Any system 9.3+ -> S.O.L. Update to 10.3, sorry.

    ONLY INSTALL TO EMUNAND, NEVER SYSNAND.
    DO NOT INSTALL UPDATED TIGER UNLESS YOU USE GATEWAY.
     
    Last edited by Aroth, Nov 16, 2015
    Mythrandir and MAXLEMPIRA like this.
  10. Jow Banks

    Jow Banks GBAtemp Regular

    Member
    178
    108
    Nov 6, 2015
    Netherlands
    when all of you are sayin you can now use eshop this way - are you saying you can more than just get into eshop?

    can you download game or app updates using any of these ¿¿
    i can get into eshop on my n3ds on 9.0 sysnand and 9.5 emunand with gateway - but i get errors at 99% for updates like youtube

    i change the nver tiger and cver on my 9.5.0-28 emunand using fbi with the ones from 10.3.0-28
    000400DB00017302.cia
    000400DB20016302.cia
    0004001000021900.cia

    i can get into eshop - still i get 007-6106 error when i try update youtube at 99% done :(
     
  11. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    I am currently looking into that error. I got something similar myself when I tried it on my N3DS with gateway, but I had reason to suspect the problem was my internet and I got a different error code than you.

    I can, however, personally confirm that using just the latest NVer and HANS I can access the eshop and download games and updates on my N3DS emunand with rxtools, and others have confirmed that combination works for reinand and GW as well.

    Also, there is no need to install the updated CVer, just NVer and tiger (tiger only if you use gw).

    edit:

    http://www.nintendo.com/consumer/wf...p?error_code=007-6106&system=3DS&locale=en_US

    "An error occurred while attempting to connect to the Nintendo eShop. Please try again later."

    I would suggest trying again later (or on a different network). If it persists you may have to just rely on hans
     
    Last edited by Aroth, Nov 16, 2015
  12. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Ok, yes, I agree with you on almost everything, First, I have games that purchased before I can use CFW, my 1ª 2DS break, and now want to transfer my account to a new 2DS that I've bought, but with all this, now it have been difficult to perform a SysNAND transfer... so, that's why I want eShop on 9.2...
    In the other hand, I don't know if you have tried to download any Title or to watch info or video with just NVer and Spoofing on FW below 9.6 or 10.0, ok, NVer resolved the problem of enter to the eShop, but at least for me on FW 9.2, I can't download titles with just this, I have to install the new eShop from FW 10.0 to download Titles and watch info/videos.
    For the rest, I will add this Warning in big red for everyone
     
  13. urherenow

    urherenow GBAtemp Psycho!

    Member
    3,058
    917
    Mar 8, 2009
    United States
    Japan
    Who said Cver was needed? Since you updated Tiger, you may want to install mint as well 000400300000CE02. Tiger uses mint... and so does other things.
     
    Last edited by urherenow, Nov 16, 2015
  14. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    The only way I could download Titles was with NVer (10.2) and eShop (10.0), so... if you have EmuNAND, I recommend you to download eShop (10.0) and made a Spoofed version of it, I read about this with Zelda TriForce Heroes to run in EmuNAND 9.5, it should work ONLY in EmuNAND, never install a modified SysTitle on SysNAND, and then after install these Titles, reboot your EmuNAND and use FMP, and everything should work.
     
  15. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    When i tried it with GW and updated tiger I also tried mint and got similar results. The only method I can 100% guarantee works is NVer + HANS, nothing else needed.


    I can and have used the eshop to download updates since the 10.3 patch using JUST NVer and HANS on my N3DS with 9.5 emunand. You HAVE to use HANS if you do not install the latest tiger, and installing the latest tiger will not work unless you use GW. No other CFW properly spoofs the FIRM to allow titles signed for higher versions to run.

    — Posts automatically merged - Please don't double post! —

    There is no easy way to make a spoofed version of a system title at this time. It SHOULD be possible but I know the few people who tried had problems.

    As for TriForce Heroes, the problem was with people using the eshop version and now cryptofixing. Games released on the eshop after 9.6 require the new key and if your emunand is 9.5 or lower you will be unable to download them. One more reason to just update to 10.3 for O3DS users.

    Either way please stop blanket telling people to install the latest version of tiger because that will ONLY work for users on 10.0 emunand or higher, or users with Gateway. Any users who uses rxTools, reinand, cakes, etc., will not be able to open the eshop after installing the latest version if they are below 10.0
     
    Last edited by Aroth, Nov 16, 2015
    MAXLEMPIRA likes this.
  16. urherenow

    urherenow GBAtemp Psycho!

    Member
    3,058
    917
    Mar 8, 2009
    United States
    Japan
    Umm... 3dnus itself can spoof that, when it makes the .cia :wink:
     
    Last edited by urherenow, Nov 16, 2015
    MAXLEMPIRA likes this.
  17. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Yep, latest tiger don't work on <FW9.6, a modified version maybe ONLY on EmuNAND, but... I have tried to use just NVer and HANS on SysNAND and it hangs on the very first screen, waited and waited... but never load anything... :/ I'm on a 2DS FW9.2... it should work like other, but no :/. By the way, installing NVer and Spoofing FW, I able to launch SysTranfer until it search for Target System, I'm afraid of try it and lost my purchases
     
  18. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    No. It can spoof the "Version" string of the title. Make a lower version of NVer report to the system and servers as if it is v448. What we need is to make the eshop title run on a lower version of the system firmware.

    — Posts automatically merged - Please don't double post! —

    You won't lose your purchases. At best you will have to redownload them if you dont properly transfer the content from the old SD to the new SD.

    EIther way it sounds like you are working with a weird set up so your situation should not be used as a baseline for the average user.

    — Posts automatically merged - Please don't double post! —

    Just to make sure I understand this, you have a 2DS on 9.2 with CFW set up and you want to transfer it to a new 2DS right?

    If so just set up emunand on the new 2DS and update its emunand to 10.3, then update your existing 2DS's emunand to 10.3, then do the transfer without any stupid special shit.
     
    MAXLEMPIRA likes this.
  19. MAXLEMPIRA
    OP

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    867
    167
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    Ok, look, I upload a clean EmuNAND to 9.6 (The one with Seed Key) then... to prove my theory, I install NVer, witch let us enter to eShop with FW Spoofing, and eShop 10.0, to download Titles and then it works, when before just installing NVer and Spoofing or using HANS I never could download any Title, Error: 007-2404, with NNID linked and everything, or even watch info about Titles. So... for us, who can't access and download titles, this should be the solution.
    So, there is people who use Cryptofix eSHop 10.0 to launch it on EmuNAND 9.5, with that to avoid the 3DS Logo Loop, and installing Nver 10.2, with HANS or FW Spoofing, it should work like a normal eShop. If what you did works for you, what better? I'll add you solution to the first post and tell people to try first that, and too to make a backup or their EmuNAND, and if they will try with their SysNAND, it will be by their own risk!

    — Posts automatically merged - Please don't double post! —

    I've read from many people that doing this made that your account get linked to your EmuNAND, even if they are linked, and that result of having your account only in your SD instead of your System, those people never could access to their account on SysNAND, like I said before, even with Sys and Emu NAND linked. That's why I want to do a SysTransfer, spoofing fw should work.

    By the way! I have tried enter eShop with my 9.6 EmuNAND, with NVer 10.2 and eShop 10.0 with rxMode and spoofing, and it works... I'll upload a video later

    — Posts automatically merged - Please don't double post! —

    if they install eShop 10.0 on EmuNAND 9.5, it will stuck on 3DS Logo Loop, because it has the Seed Key and FMP don't resolve that
     
    Last edited by MAXLEMPIRA, Nov 16, 2015
  20. Jow Banks

    Jow Banks GBAtemp Regular

    Member
    178
    108
    Nov 6, 2015
    Netherlands
    This is making my head spin.
    i thought hans was only good for launching eshop from sysnand ?¿

    is there a link to an explains how to use hans with emunand somewhere?

    i have a n3ds on 9.0 sysnand - a gateway with emunand set to 9.5 - a real CN cart - rxtools works for me - i can use ninjhax 1.3 or 2.5
    all i am trying to do is get youtube to work again - it wont update past 99%