[Request] Nintendo Game Patch Updater?

Discussion in '3DS - Homebrew Development and Emulators' started by Pandaxclone2, Oct 3, 2015.

  1. Pandaxclone2
    OP

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    993
    393
    Aug 17, 2015
    noun; a particular place or position.
    Out of curiosity, I was wondering if it is possible or if there was a homebrew app that can either retrieve, spoof or otherwise install official Nintendo game patches? (e.g. Majora's Mask update, Pokemon XY updates, etc.)

    This would be helpful for those of us (including me) who wish to continue playing on online compatible games that require updates, while keeping the older update that we have. (For me, I'm on O3DS 9.5.0-22E, so this would be a godsend.)

    At the very least, I'm looking for a way to patch my Pokemon XYORAS and Smash Bros 3D without updating.
     
    Last edited by Pandaxclone2, Oct 3, 2015
  2. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    Game updates can only be installed the same way as games I think, so like .cia, which you can't use on sysnand 9.3 or above. Correct me if I'm wrong..
     
    lemanuel likes this.
  3. Cavioe

    Cavioe GBAtemp Fan

    Member
    308
    72
    May 28, 2015
    United States
    I don't think a installer would work as you are on 9.5. But what you might want is to spoof eshop access on your 9.5 so you can download updates for games.
     
    Zidapi likes this.
  4. Pandaxclone2
    OP

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    993
    393
    Aug 17, 2015
    noun; a particular place or position.
    As far as I'm aware, spoofing the eshop on o3DS above 9.2 is not possible. Then again I'm not tech savvy on this stuff so if that is possible that would be amazing.
     
  5. Cavioe

    Cavioe GBAtemp Fan

    Member
    308
    72
    May 28, 2015
    United States
    I just mentioned spoofing eshop as in my view, that seems to be the likely solution as there is no exploits available for 9.3 and above to allow installing game updates.
     
  6. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,092
    Dec 11, 2014
    Portugal
    It might be possible once 9.3+ firmwares becomes exploitable. Or at the very least, if they get ARM11 running.

    But for now, there's no chance. No eshop spoofing or CIA installer.
     
  7. RednaxelaNnamtra

    RednaxelaNnamtra GBAtemp Advanced Fan

    Member
    743
    632
    Dec 8, 2011
    Gambia, The
    maybe it will be possible in future(look at all The thinks r5 will allow you to do), but first someone need to get a way to patch nim on 9.3+ sysnand. But there is no reason to stay on 9.5 from what I know, because the arm9 exploit got patched on 9.5. Only spide could be a reason, but there are new browser exploits available, which could be used.
     
  8. Pandaxclone2
    OP

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    993
    393
    Aug 17, 2015
    noun; a particular place or position.
    Spider is partly why I'm sticking with 9.5. It's not that big of a deal because I have a second O3DS that I update normally, however it is a hassle to switch between them. (Especially when I have the second one on borrow.)
     
  9. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,441
    4,753
    Mar 17, 2010
    Norway
    Alola
    There is a spider version of the eShop spoofer, but I don't think it works on 9.5, and CIA installation isn't possible above 9.2.
    There may be some way to exploit the system to get write access to the nim module, without needing ARM11 kernel, someone skilled would have to look into this (maybe smea or yellows8)