R4i-SDHC error!

Discussion in '3DS - Console, Accessories and Hardware' started by VilcsiTH, Apr 26, 2013.

  1. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    Alright, so I updated my R4i-SDHC 3DS to the new version, and it worked like a charm, but after a day of playing, I turned it off. I turned it back on the next day, and it gave me the error "An error has occurred." with a blackscreen.
    I think the problem is that I didn't upgrade using the "upgrade" function from the options menu, but now I'm stuck. I can downgrade my card, but because I already updated my 3DS, it won't work. I have a DS Lite, but the card reader is broken.
    So what can I do? I was thinking about formatting but I would lose all my Mii's, my streetpass(and it's pretty hard to get friends for streetpass since where I live 3DS doesn't have a big fame), my play coins, and everything.
    Is there a way to fix this without having to reformat or I'm screwed?
     
  2. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You can't downgrade the 3DS, period. Formatting won't do it.

    You need to fix the issue with the MicroSD/R4.
     
  3. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    I tought if I format the 3DS it will bring it back to 1.0.0.

    And how could I fix this? Am I screwed?
     
  4. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,933
    Sep 8, 2009
    One's inner self
    lol downgrading a 3DS your funny

    buy a better card or buy a old DS, why even use it on a 3DS, you get 0 extra from a card running on a 3DS compared to a DS Phat or even a Lite
     
  5. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    No, the 3DS can't currently be downgraded at all.

    You need to run the update on your R4, which means a working MicroSD reader and junk.
     
  6. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    I have a MicroSD reader but it what to do with it?

    No, I won't buy anything. I'm poor as f*** since my tablet broke, so no. And I think this thread is about me asking for help and what can I do, not a "What's your opinion on 3DS flashcards?" thread.(Sorry if I sound like a douche, but that's the truth.)
     
  7. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,933
    Sep 8, 2009
    One's inner self
    well you know what you did, you failed to update the flashcard first. you have to do this (if it is possible as alot of flashcards where blocked with 4.5.0-10, people have had to buy new ones the only way is to work out if your flashcard can update, then find a way of applying it if it cant update and you dont have a console it will work on, then you can no longer use that card and need a new one simple, GAMING IS A LUXURY, NOT A NECESSITY
     
  8. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
  9. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
  10. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You need to download the firmware update from the site on the cart and run it.
     
  11. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    http://www.r4i-sdhc.com/downloade.asp
    I have an r4i-sdhc for the 3ds, I already updated it, put it on my microSD, didn't do anything. Still getting the error.
     
  12. ViviOrnitier

    ViviOrnitier Member

    Newcomer
    34
    0
    Oct 18, 2008
    Netherlands
    Amersfoort, The Netherlands
    You will have to wait for a new kernel that supports v1.4.5, just like me. This might take ages so you might wanna buy a different card like they say on the site.
     
  13. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    How did you update it?
     
  14. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    Um, I have a 3DS, not a DSi.
     
  15. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    I downloaded the English zip, extracted the 4 files from it, deleted the previous update's files from the SD card then copied the new ones to the SD card. Not sure if I'm supposed to delete this .dll thing, it doesn't come with the zip and it's been standing there since last update. But oddly, the card worked for a day, then stopped working next day. WTF?
     
  16. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You need to actually RUN the update function/file to apply firmware updates. Game updates work by just copying the files, but firmware updates need them to be run.
     
  17. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    So, my 3DS banned it from existence? Because I can't run it anymore. Or what do I do now? I launch the card, error has occurred, I downgrade the card, error has occurred, and I can't downgrade my 3DS.
     
  18. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You need to update the firmware by running the update.

    If you cannot run it on that 3DS right now, then you will need to run it on something else.

    http://gbatemp.net/threads/flash-carts-and-dsi-3ds-updates.315784/
    This thread has all the info you need.
     
  19. VilcsiTH
    OP

    VilcsiTH Member

    Newcomer
    15
    0
    Apr 26, 2013
    Hungary
    Oroszlány
    *Sigh* So it seems I am screwed after all. My DS Lite broke, my 3DS won't read it, there's no such thing as a 3DS emulator that supports online... So there's nothing I can do? I'm out? Done?
    (Also, sorry for my English, it's getting night here and my brain doesn't function properly.)
    I have a Wii but dam, that won't help here either, will it?
     
  20. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    If the 3DS updated and blocked the flash cart, it's not going to work until the cart gets updated or replaced.

    Also there's no 3DS emulators, period.