[Q] rxTools autoboot missing code.bin

Discussion in '3DS - Homebrew Development and Emulators' started by The9thBit, Jan 2, 2016.

  1. The9thBit
    OP

    The9thBit Advanced Member

    Newcomer
    81
    39
    Mar 25, 2015
    United States
    I followed hackinformer's guide (http://hackinformer.com/2015/10/08/3ds-cfw-autoboot-homemenuhax-ctrbootmanager/) on setting up an autoboot for rxTools, but for the life of me I just can't make it work. It keeps returning:

    "An error occured while loading the payload.
    Make sure your launcher is located at:
    /rxTools/sys/code.bin

    Press any key to continue"

    The thing is, I haven't the slightest idea where to get this mythical code.bin from. I've been using rxtools on MSET 4.2 for a good while now, without ever having a code.bin. The official releases don't contain any. I can't find links to a code.bin file anywhere, or at least none that work. I've tried the one from the 3.0 release on Github, but it returned the exact same error; most likely because I'm on rxTools.dat version 2.6. Is 3.0 more stable than the release notes imply, or am I just doing something wrong?
     
  2. samiam144

    samiam144 RĂ©gulier

    Member
    2,869
    935
    Aug 19, 2007
    Canada
    Get this stable build

    The code.bin is in the rxtools/sys/ folder. Follow any rxtools tutorial for how to set it up. You need to run the CDN_firm.py file to get the firm folder and place it in the rxtools/ folder on your SD card.
     
  3. The9thBit
    OP

    The9thBit Advanced Member

    Newcomer
    81
    39
    Mar 25, 2015
    United States
    Well, it's at least booting now, but CDN_firm.py just generates a single firmware.bin file. Placing it on the root or in /rxTools doesn't work; both return "Failed to load NATIVE_FIRM: 4." I've also tried manually creating a firm folder in /rxtools and placing the firmware.bin there, but it still returns the same error.

    EDIT: Figured out that firmware.bin is supposed to go in the /rxTools/sys folder. Works fine now :)

    EDIT 2: And sure enough, installation data suite freezes EVERY SINGLE TIME. I'm starting to get really frustrated here.

    EDIT 3: Finally got it working. I just followed most of the instructions from the guide at http://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/ , but instead of using CTRBootManager, I edited themehax's payload to load rxtools.3dsx.
     
    Last edited by The9thBit, Jan 2, 2016
    samiam144 likes this.
  4. gallymimu

    gallymimu EE Expert

    Member
    297
    113
    Mar 15, 2009
    United States
    glad it's working. the tutorial you mentioned on this forum is pretty solid and others should really start there rather than struggling. Sorry you had a hard time with it.
     
    The9thBit and samiam144 like this.