psp Help needed

Discussion in 'PSP - Hacking & Homebrew' started by des13, Aug 1, 2015.

  1. des13
    OP

    des13 Newbie

    Newcomer
    2
    0
    Aug 1, 2015
    Hello there I just started playing on my psp 2000 (2004) again and I want to play final fantasy type-0 and yugioh arc v. My psp has 5.00 m33-6 right now and I am not sure if I should upgrade it or need patches. So could you please help me and guide me.

    Thanks in advance for any help/guidance :)
     
  2. Nick3252

    Nick3252 Member

    Newcomer
    24
    2
    Jul 19, 2015
    Canada
    Try 5.50 GEN D3
     
  3. WiiCube_2013

    WiiCube_2013 GBAtemp Guru

    Member
    5,943
    1,337
    Oct 19, 2013
    Gaza Strip
  4. des13
    OP

    des13 Newbie

    Newcomer
    2
    0
    Aug 1, 2015
    thanks for the advice about the psp could you please answer one of my questions.

    Can I have ME and PRO on the same consol? like have ME as permanent cfw and then use fast recovery to use PRO if needed?

    Edit: or does that restrict some of the functions on both cfws? :/