PSP 2000?

Discussion in 'PSP - Games & Content' started by serg0, Jul 30, 2009.

  1. serg0
    OP

    serg0 GBAtemp Regular

    Member
    129
    0
    Jan 5, 2007
    United States
    From my understanding all the white and silver PSP 2000s are hackable. Can you still flash them if they have the latest firmware?
     
  2. Spawk

    Spawk Member

    Newcomer
    34
    1
    Jul 19, 2006
    Canada
    well, I don't think CFWE or ChickHEN will run on the latest FW but you should still be able to use pandora to flash... unless the newest FW has the pre IPL patched but I think the new PSP's do that through hardware.
     
  3. Spartan117H3

    Spartan117H3 GBAtemp Regular

    Member
    209
    0
    Feb 23, 2009
    United States
    Maryland
    The new PSP's do that through the motherboard. The color of the PSP 2000 should not distinguish weather or not it is hackable. You need to make sure you don't have the T-088v3 mobo. Once you get past this, you just need FW 5.03 or a Pandora.
     
  4. PettingZoo

    PettingZoo yesss

    Member
    1,711
    1
    Oct 5, 2008
    in the trap
    I'm not sure you can hack it if it's the latest firmware, though you can try [​IMG]
     
  5. delta123

    delta123 GBAtemp Advanced Fan

    Member
    570
    11
    Jul 18, 2005
    Hyougo, Japan
    chickhen you will need 5.03 installed if you dont want to use the pandora battery. but other than that 2000 models it deosnt matter what firmware you are on, as long as you have the battery you should be able to get firmware on it.

    i installed custom firmware on my cousins 2001 psp. scared me for a while, but in the end it worked. that is the last time i travel without my pandora battery.
     
  6. Spartan117H3

    Spartan117H3 GBAtemp Regular

    Member
    209
    0
    Feb 23, 2009
    United States
    Maryland
    It does matter. If the 2000 is a T-088v3, it is not hackable even with the battery, just like how the 3000 isn't hackable with a battery. Firmware doesn't matter if you use the Pandora battery on OLDER PSP 2000 models or 1000 models.