prometheus v2 and v4

Discussion in 'PSP - Games & Content' started by anthony001, Sep 7, 2010.

Sep 7, 2010

prometheus v2 and v4 by anthony001 at 3:05 PM (1,146 Views / 0 Likes) 6 replies

  1. anthony001
    OP

    Member anthony001 GBAtemp Regular

    Joined:
    Oct 19, 2007
    Messages:
    278
    Country:
    Philippines
    whats the difference?
     
  2. Razor1993

    Member Razor1993 GBAtemp Regular

    Joined:
    Mar 20, 2010
    Messages:
    122
    Country:
    Turkey
    there is something wrong!
    there is a old v2 and a new v2!
    the New v2 can be called v5 but i dont know why to Fu.. they call it v2!
    the difference ist the NEW v2 can play 6.30 Games and the old v4 can just play 6.20 games!
    here is an download of the New v2 version! : http://dl.qj.net/psp/homebrew-applications...ometheus50.html
     
  3. anthony001
    OP

    Member anthony001 GBAtemp Regular

    Joined:
    Oct 19, 2007
    Messages:
    278
    Country:
    Philippines
    so is it safe to use it?
     
  4. Razor1993

    Member Razor1993 GBAtemp Regular

    Joined:
    Mar 20, 2010
    Messages:
    122
    Country:
    Turkey
    sure!!!
    but u musst first install CFW 5.50 Gen D3! then install this one!
     
  5. thedicemaster

    Member thedicemaster GBAtemp Addict

    Joined:
    Apr 26, 2008
    Messages:
    2,412
    Country:
    Netherlands
    the prometheus firmwares often called v1, v2, v3, and v4 are actually not numbered.
    there never was a prometheus version released as v3 or v4, news/release sites just added that to keep track of the different releases themselves.

    the new v2 is actually the first time the creator of the firmwares added a version number.

    EDIT: Razor1993:GEN D3 is NOT recommended.
    it's better to update from D2, because using D3 may cause corruption with some game saves.
     
  6. anthony001
    OP

    Member anthony001 GBAtemp Regular

    Joined:
    Oct 19, 2007
    Messages:
    278
    Country:
    Philippines
    so its not safe for a 5.03 user to use this new v2?
     
  7. thedicemaster

    Member thedicemaster GBAtemp Addict

    Joined:
    Apr 26, 2008
    Messages:
    2,412
    Country:
    Netherlands
    if you use a HEN-based CFW you need to use the 5.03 version of prometheus CFW.
    GEN fully installable 5.50 CFW can be used for the 5.50 prometheus CFW.
    m33 fully installable 5.03 CFW users need to switch to 5.50 GEN D2 or 3 first(D2 being a better option because it doesn't have save issues)
     

Share This Page