Problems with Dios Mios/CFG USB Loader

Discussion in 'Wii - Backup Loaders' started by Mr White, Feb 2, 2014.

  1. Mr White
    OP

    Mr White Newbie

    Newcomer
    8
    0
    Sep 4, 2013
    It's probably the umpteenth time someone's had problems with Dios Mios, but I had to ask somewhere.

    I've been using Dios Mios with CFG for a few weeks. At first, I used a microSD reader because I didn't have a spare HDD to use. I recently bought a Hitachi Touro 1TB portable drive to use as a backup for my laptop, so I decided to use my old external drive for the Wii.

    Now, Dios Mios worked perfectly with the micro SD, so I assumed it was set up properly. Anyway, I checked the external drive to make sure it had 512kb sectors, formatted it FAT32 with a 32kb cluster size, copied everything off the micro SD reader and..........it didn't work. CFG USB can read what's on the hard drive and it can see the games, but when I tried to load them, it just went black, with no splash screen.

    The drive itself is an old Western Digital drive in a cheap Yum Cha enclosure. I thought that the enclosure could be the problem so I tried using the Hitachi portable HDD I bought recently. I wasn't planning on using it with the Wii, but I checked the Device Compatibility List in the Wiki on here before I bought it and it said that it worked with CFG USB Loader, so I thought it would be a good Plan B to use if I couldn't get my external drive working.

    Anyway, I checked to make sure it had a 512b sector size, formatted it FAT32 with 32kb clusters, copied everything across and........no good. I still have the same problem I had with the other drive. CFG USB will see the games, but it will go black as soon as I try to play them.

    I did adjust some settings when I was trying to get the hard drives to work, so I thought that that might be the problem, so I checked the micro sd reader to see if it still worked and (surprise, surprise) it worked perfectly. While I was looking I found an old 512mb USB stick and just for good measure, I decided to throw a gamecube game on it and sure enough, it worked as well.

    Anyway I thought, if the HDD's are having problems with gamecube games, they might have problems with wii games as well. I formatted both HDD's as WBFS, used WBFS Manager to copy some wii games onto them and they worked perfectly. Then I thought it might have something to do with formatting, so I formatted both drives as FAT32 and used Wii Backup Manager to copy some Wii games onto them and they both worked. At this point, I thought it wouldn't hurt to try Dios Mios again, so I copied some gamecube games onto the drives and......same problems again :(

    In short (for those too lazy to read):
    Both HDD's work with Wii games on a WBFS partition
    Both HDD's work with Wii games on a FAT32 partition
    Neither hard drive will work with Dios Mios, but both the micro SD reader and the USB stick I used work perfectly.

    Anyone got any ideas? I'm using the latest versions of Dios Mios and CFG USB Loader and I'm using CIOS 249.
     
  2. pBullet

    pBullet SHSL Idol

    Member
    172
    24
    May 8, 2012
    United States
    Rhode Island
    DIOS MIOS looks to the primary partition only, so make sure that it is the FAT32 one you are putting all your gamecube games on. If the cluster size was the problem, you'd be getting "Fatal error app_main:dst not in MEM1!", with the splash screen loading beforehand.

    Since the splash screen did not come up at all with CFG- the assumption is that either your drive is not supported, or the loader is outdated and does not send the proper configuration.

    For drive compatibility for DIOS-MIOS, this thread exists. For alternative loaders, try WiiFlow or GX (to see if your drive works, better than not working at all I suppose).
     
  3. Mr White
    OP

    Mr White Newbie

    Newcomer
    8
    0
    Sep 4, 2013
    Interesting.

    Someone with the same Hitachi drive I have got Dios Mios to work using Wiiflow. I'll try using the same configuration they used.

    Edit: and nope, failed again :(
    Tried running Wiiflow v4.1.1 with Dios Mios v2.9 and yet again, I get the black screen when I try to run the game.