Problem with Pokemon games on R4ds SDHC

Discussion in 'NDS - Console and Game Discussions' started by Gergo, Aug 1, 2014.

  1. Gergo
    OP

    Gergo Newbie

    Newcomer
    5
    0
    Aug 1, 2014
    Hungary
    Hi!
    Last week I got my flashcard, put some games on it,everything ran fine,until I started playing with the pokemon games.
    (This is the card)(I'm using the kernel from here)

    When I exit a menu,get out of a battle,move to a new location,It Loads for about 2-4 seconds(1-2 seconds on platinum&Soul silver ;3-4 seconds on Black&Black2).

    So for instance in Black every time I finish a battle,move to a nev location,etc.. I have to watch a black screen for about 4 seconds,which is quite annoying.

    I already tried reformatting the sdhc card,and although it made the card load faster ,it did not help with this problem at all.

    Sorry if this does not belong here,I'm new to this forum.

    Edit:I'm using a ds lite.
     
  2. Kouen Hasuki

    Kouen Hasuki Kouen the Cyber Husky

    Member
    1,388
    337
    Jan 9, 2013
    Norway
    Gaming Bunker
    Sounds like a very slow MicroSD to me, try a higher class one Class 4 or 6 is normally enough
     
  3. Gergo
    OP

    Gergo Newbie

    Newcomer
    5
    0
    Aug 1, 2014
    Hungary
    I am using a class 4 tdk sdhc card at the moment,but I will the class 10 one that I had laying around.Thanks for your help!
     
  4. Kouen Hasuki

    Kouen Hasuki Kouen the Cyber Husky

    Member
    1,388
    337
    Jan 9, 2013
    Norway
    Gaming Bunker

    No Problem it just sounds like it cant read the data fast enough, let me know how it goes
     
  5. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,633
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    where did you get your micro sd card?are you sure is not counterfeit?
     
  6. Gergo
    OP

    Gergo Newbie

    Newcomer
    5
    0
    Aug 1, 2014
    Hungary
    I tried the other, class 10 micro sd card that I had but all it did was made the problem smaller,the loading times are still around 3 seconds with this one also :(
     
  7. Kouen Hasuki

    Kouen Hasuki Kouen the Cyber Husky

    Member
    1,388
    337
    Jan 9, 2013
    Norway
    Gaming Bunker
    Do you have DMA enabled?
     
  8. Gergo
    OP

    Gergo Newbie

    Newcomer
    5
    0
    Aug 1, 2014
    Hungary
    No,I don't.Is that the problem?

    Edit:Turning it on didn't help :( I still have 2-3 sec black screens after battles.
     
  9. Kouen Hasuki

    Kouen Hasuki Kouen the Cyber Husky

    Member
    1,388
    337
    Jan 9, 2013
    Norway
    Gaming Bunker

    You sure its not natural? Though really 2 or 3 seconds is not a whole lot...

    (Prepare for old man mode)

    Back in my day we loaded of audio tape and it would take anywhere between 5 to 30 minutes to load the level and some of them would force you to do the whole load again if you lost... and not forgetting the load fails...

    That aside is 2 seconds that bad?
     
  10. Gergo
    OP

    Gergo Newbie

    Newcomer
    5
    0
    Aug 1, 2014
    Hungary
    If I remember correctly, on the original card it was around 1 seconds,so I don't think it is natural.

    Nevertheless, have a point,I guess 2 seconds really aren't much.I think I will get used to it eventually.


    Thank you for your time and kind answers!