Priiloader Public BETA

Discussion in 'Wii - Hacking' started by Daco, Oct 26, 2009.

  1. XFlak

    XFlak Wiitired but still kicking

    Member
    9
    Sep 12, 2009
    Canada
    Ontario
    i remember u saying it worked on rev 41, but i tried it and it didn't work on rev 41 or rev 46

    also, rev 41 had a bug that wouldn't allow it to launch the system menu ios, HBC, or bootmii from priiloader (so terrible brick protection for those without bootmii as boot2)
     
  2. laurozza

    laurozza GBAtemp Fan

    Member
    1
    Sep 17, 2008
    Italy
    Really weird...i have tried rev41 and NForwarder on 2 Wii and both worked perfectly...
     
  3. Daco
    OP

    Daco Banned

    Banned
    1
    Oct 15, 2007
    Belgium
    earth
    what?
    no it would allow it perfectly well, just not from the priiloader menu cause of libogc's usbstorage closing (fucking idiots)
     
  4. celeb23

    celeb23 Member

    Newcomer
    1
    Dec 15, 2009
    United States
    I am still running Priiloader r15 because "USBLoaderCFG_NForwarder" by Narolez autoboots Configurable USB Loader perfectly. I noticed that the "simplisticmod" guide is now packing a newer Priiloader version r43 or r46 even. I would love to go to the newer version of Priiloader if I knew it would autoboot Configurable USB Loader correctly, all I get is a black screen.

    I can stay on r15, but I really want the feature of autobooting the systemmenu if a Wiimote cannot be found. This prevents from having to have a gamecube controller around and makes it even more "Kid Safe" in combination with a "Kid Safe" configuration of Configurable USB Loader.

    Just curious if I missed something along the way? Otherwise, I will be patient and watch for a solution with Priiloader or a new NForwarder, not sure where the problem is.

    Thanks for excellent work!

    EDIT: I did get advice from another thread that you could replace the target path of NForwarder with TinyLoad if your WiiMote isn't synced, boot an original title from disc and re-sync from there. Once you have your Wiimote synced, replace TinyLoad with the original target path of NForwarder, in this case, Configurable USB Loader and you are back in business without requiring a GC controller.
     
  5. Daco
    OP

    Daco Banned

    Banned
    1
    Oct 15, 2007
    Belgium
    earth
  6. bula

    bula GBAtemp Advanced Fan

    Member
    1
    Feb 4, 2009
    United States
  7. XFlak

    XFlak Wiitired but still kicking

    Member
    9
    Sep 12, 2009
    Canada
    Ontario
    I upgraded a friends wii to your new rev (after 46) and everything worked fine! There was a stack dump when I tried to launch the magicword.dol the first time directly after install, but other than that it worked fine
     
  8. Daco
    OP

    Daco Banned

    Banned
    1
    Oct 15, 2007
    Belgium
    earth
    thats detail [​IMG]
    if the installer & priiloader work flawlessly then thats good [​IMG]
     
  9. laurozza

    laurozza GBAtemp Fan

    Member
    1
    Sep 17, 2008
    Italy
  10. Daco
    OP

    Daco Banned

    Banned
    1
    Oct 15, 2007
    Belgium
    earth
  11. Oxybelis

    Oxybelis GBAtemp Fan

    Member
    4
    Jan 10, 2010
    I have same problem. NForwarder does not work in priiloader R46, but it loads if launched from Homebrew channel.
     
  12. Blue-K

    Blue-K No right of appeal.

    Member
    2
    Jun 21, 2008
    Swaziland
    Helvetica
    Try the Priiloader-Beta from the Post above you [​IMG] . It has some changes which aren't on the Googlecode-Page yet, maybe it will fix it. I would love to try, but I haven't my Wii back yet [​IMG]
     
  13. TutenStain

    TutenStain Newbie

    Newcomer
    2
    Jan 10, 2010
    United States
    I updated from r32 to r46 from SVN. Everything went fine except that it code dumped on the first reboot. But been working since that w/o any code dumps. Running on black Wii with 4.2E.

    Great program, Thanks!
     
  14. laurozza

    laurozza GBAtemp Fan

    Member
    1
    Sep 17, 2008
    Italy
    Thanks. ^^
     
  15. Roobitz

    Roobitz Member

    Newcomer
    1
    Jul 27, 2009
    Canada
    Hey DacoT,

    Priiloader is looking great so far. I think I may have a bug report for you. I installed a compiled version of r46, and have had no issues or code dumps so far. What isn't working is booting into priiloader by holding the Reset button on my Wii. I've tried timing it differently, but it just seems to go straight to the Health Screen after Bootmii. I am unsure of how to access priiloader's settings now, as I have it set to Autoboot the System Menu.

    Here are some specs on my Wii if that is helpful:
    Running 4.1U with Bootmii as boot2, using r46 of priiloader beta.
     
  16. Daco
    OP

    Daco Banned

    Banned
    1
    Oct 15, 2007
    Belgium
    earth
    odd, holding reset works just fine here
    tried holding reset and then pressing power while holding reset?

    if that fails, uninstall and install rev46

    if you had a usbgecko it would be nice to know the output but i guess you dont have one >_>

    EDIT: and please check for the priiloader installation using some explorer like ftpii before uninstalling priiloader...

    EDIT: and what are your wii settings?

    @TutenStain on first reboot? as in HBC -> reset ? :/ or installer -> HBC ?
     
  17. XFlak

    XFlak Wiitired but still kicking

    Member
    9
    Sep 12, 2009
    Canada
    Ontario
    u can always use the magicword.dol to launch priiloader (or use the channel from my signature)
     
  18. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    @Roobitz: Is that the 0.3 beta from rapidshare you're using? Thanks.
     
  19. Taleweaver

    Taleweaver Storywriter

    Member
    13
    Dec 23, 2009
    Belgium
    Belgium
    I also did some quick tests with the 0.3 beta version. All in all, the program is pretty stable. Very rarely, when trying to boot into HBC from the console results in a rather...flaky screen (sometimes garbled, sometimes the screen is split into two triangles). It doesn't happen often, and I'm unable to reproduce the error (in other words: when I try the very same thing a few seconds later, it works fine).

    Booting into bootmii (even though I've only got it as boot2) works fine. [​IMG]

    As laurozza mentions, configurable USB loader's NForwarder still doesn't work. I think that it's the forwarder's issue, as I'm currently using USB loader GX's forwarder, and that one works fine*. [​IMG]


    And I'm probably missing things, but what does the option "shutdown to ...priiloader" 's supposed to do exactly? No matter where I press either the console's off-button or the wiimote's off-button, the thing always shuts down normally.

    Still...other than that, it's all as good and stable as it can get. Hacks work okay, the other options do what they're supposed to and I couldn't make the program do anything that it wasn't supposed to do in the first place (well...the priiloader.dol file doesn't exactly load priiloader, but loads priiloader's functionality...so when it's configured to boot HBC, starting the priiloader dol will load HBC. But I guess this is just how it's supposed to be [​IMG] ).


    Anything particular you want tested out, Daco? [​IMG]




    Oh, and of course: Thanks a lot for all the effort, man! It's much appreciated here. [​IMG]



    *I simply switched the paths: my configurable usb loader folder is located in SD:\apps\USBLoader_gx\
     
  20. Roobitz

    Roobitz Member

    Newcomer
    1
    Jul 27, 2009
    Canada
    I'm using the r46 one from a few pages back in this thread, I think it said it was compiled by 'bula'. For some reason it displays "r32" on the priiloader menu of another wii I installed it on.
     
Loading...