1. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Unfortunately I wasn't able to write to the FAT partition! Not on my HD and not on several SD-cards.
    So here I go with some screengraps.....
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      575 KB
      Views:
      22
    • 5.jpg
      5.jpg
      File size:
      592.6 KB
      Views:
      15
    • 4.jpg
      4.jpg
      File size:
      691 KB
      Views:
      14
    • 3.jpg
      3.jpg
      File size:
      598.7 KB
      Views:
      17
    • 2.jpg
      2.jpg
      File size:
      573.2 KB
      Views:
      16
  2. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    ye, priiloader is refusing to install on the modded system menu.
    you need to install a good, vanilla system menu to install priiloader.
     
    Last edited by DacoTaco, Oct 18, 2020
    alexander1970 likes this.
  3. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,684
    Country:
    Canada
    Or maybe another possibility is an older version of the HBC that doesn't support ahbprot?

    Edit: nvm, didn't see the above post. I note that the version of the HBC isn't the latest, but it should still be new enough for it to not be the issue (I think)
     
    Last edited by XFlak, Oct 18, 2020
  4. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    nah.

    upload_2020-10-18_13-47-54.png
     
    alexander1970 and XFlak like this.
  5. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    OK I see.
    I'm not sure if I know howto do that so maybe I'll have to stick with PriiLoader v0.60. :wink:
    Thanx for your prompt reply!
     
  6. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,684
    Country:
    Canada
    Use ModMii, tell it your wii is a virgin even if it isn't. Tell it you are on 4.0E, then choose to upgrade go 4.1 (or 4.2 or 4.3). Follow the guide, but instead of installing the version of priiloader that comes with modmii currently, use this one (modmii to updated soon-ish to be include priiloader v0.9 and some other things).... or do as u suggested (I. E. Maintain your status quo)
     
    Last edited by XFlak, Oct 18, 2020
    FrenezyFr likes this.
  7. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Thank you very much for explaining. I was already looking at your tool. With your explanation I'll give it a try.
     
    Last edited by cartler, Oct 18, 2020
    alexander1970 likes this.
  8. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    I managed to downgrade/reinstall my Wii. After that I was able to install PriiLoader v0.9. Only now I get an Exception (DSI) occurred! whenever I select the System Menu Hacks. I tried reinstalling PriiLoader, with connected HD (FAT32 partition), with inserted SD but to no avail!
    When I don't connect the HD or insert a the SD I get (ofcourse) "Failed to mount FAT device, Can't find hacks_hash.ini on NAND".
    What am I doing wrong now?
     
  9. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    can you show me your hacks file that you have on the usb (or sd card) ?
     
    alexander1970 likes this.
  10. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Here you go. This is the one in USB:/apps/priiloader/
     

    Attached Files:

  11. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    that hacks file looks off...
    can you try and remove the [Wiimmfi Patch v2 - hidden MASTER] hack (everything from [Wiimmfi Patch v2 - hidden MASTER] untill [Wiimmfi Patch v2 for 4.3E] and try again?

    EDIT : what you can also do is enable debug dumping in the settings, go to the hacks menu and give me the prii.log that will have been created on the usb drive (if not sd is inserted).
    DISABLE THE SETTING AFTER THE CRASH.
     
    Last edited by DacoTaco, Oct 19, 2020
    alexander1970 likes this.
  12. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Removing "Wiimmfi Patch v2 - hidden MASTER" Fixed it! Thank you very much!
    Mind you though it is the hacks_hash.ini I downloaded from here https://github.com/DacoTaco/priiloader/releases/tag/0.9.
    I just redownloaded and rechecked and it's in there.
     
  13. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    ye, i noticed.
    mind doing the dump debug thing and making it crash again?
    i want to know where it crashes. the line looks weird but if it crashes priiloader i wonder why it hasn't crashed for others yet.
    i'll need to investigate...
     
    alexander1970 likes this.
  14. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Sure thing! Here you go......
     

    Attached Files:

  15. DacoTaco

    OP DacoTaco GBAtemp Regular
    Member

    Joined:
    Oct 8, 2017
    Messages:
    129
    Country:
    Antarctica
    i thought you said it crashed on the hacks menu?
    your log only shows it booting system menu, shutting down and powering back up and doing autoboot

    i was also unable to reproduce the issue in dolphin or on my own wii with an SD card or usb stick
     
  16. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    I wil try again tonight. If you can't reproduce then it is probably something on my Wii.
     
  17. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    I tried again. Redownloaded the hacks_hash.ini from https://github.com/DacoTaco/priiloader/releases/tag/0.9. Copied it to USB:/Apps/priiloader/. Went into priiloader and enabled debuglogging. When I then select the System Menu Hacks. I get a crash.
    The only entry in prii.log is:

    21:15:14 : USB: Mounted
    When I remove "Wiimmfi Patch v2 - hidden MASTER" all is ok!
     
  18. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,684
    Country:
    Canada
    Same result if u use an SD card?
     
  19. cartler

    cartler Member
    Newcomer

    Joined:
    Jan 8, 2011
    Messages:
    22
    Country:
    Netherlands
    Just tried with no HD connected and SDcard inserted and then it does not crash!
    prii.log is much more descriptive now also! Maybe some incompatibility with my HD?
    Will try if it helps when I reformat the FAT-partition.
    Or do you want me to test something else?
     

    Attached Files:

    Last edited by cartler, Oct 22, 2020
  20. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,684
    Country:
    Canada
    I just had the idea to test with sd instead of USB, but that's where my trouble shooting knowledge on this issue ends, so I will defer your other questions to the reigning expert, Daco :)

    Edit: to be clear, you tried it with an SD card AND the wiimmfi patch v2 added back so it now successfully appears in your list of priiloader hacks?
     
    Last edited by XFlak, Oct 22, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Priiloader, Released,