Pokemon Crystal Sav issue

Discussion in 'NDS - Emulation and Homebrew' started by Xarsah16, Dec 8, 2009.

  1. Xarsah16
    OP

    Xarsah16 GBATemp's Official Village Dingus/Idiot

    Member
    722
    188
    Oct 6, 2007
    Hyrule
    So, I am confused, I don't know if there is a bug in my file.

    I'm currently playing Pokemon Crystal using LameboyDS, (latest .12) and AKAIO firmware on my acekard, but that has nothing to do with the issue I'm facing.

    I wanted to hack into my Crystal with the Gameshark function in VisualBoyAdvance on my computer. Here's what happened:

    I physically saved ingame while in the third town (Azalea Town.) I backed up my sav file with a save state, just to make sure nothing happened.

    I stuck my microSD into my computer, ran VisualBoyAdvance. Copied both the game sav (not state) and the rom to my computer. I loaded up the game, and when I loaded up my sav file, it was back at the point where I saved before the first gym leader in the second town.

    I took out my microSD from the computer, stuck it back in the Acekard, and loaded the game. It was right in Azalea, like where I saved. (I made sure it wasn't loading the save state, I reset and selected the sav from the game menu.)

    I'm puzzled. Can anyone tell me why this happened? [​IMG] Also, is there any way I can fix this or prevent it from happening? I really want a Celebi and I don't want to lose my current position in the game.

    EDIT: I have now beaten the seventh gym leader, and it loads perfectly fine in the DS, but the sav when accessed through the computer seems to be loading from the fifth town. In other words, I'm having the same issue, just a little updated. I hope there is a solution!
     
  2. Xarsah16
    OP

    Xarsah16 GBATemp's Official Village Dingus/Idiot

    Member
    722
    188
    Oct 6, 2007
    Hyrule