please help, technical problems

Discussion in 'CycloDS' started by Blaze163, Dec 16, 2009.

Dec 16, 2009
  1. Blaze163
    OP

    Member Blaze163 The White Phoenix's purifying flame.

    Joined:
    Nov 19, 2008
    Messages:
    3,767
    Location:
    Coventry, UK
    Country:
    United Kingdom
    My Cyclo Firmware 1.56 Beta 3 seems to be having a few technical difficulties at the moment. My Zelda Spirit Tracks game has gone horribly wrong, and certain files aren't responding as well as they should.

    - Zelda, I'm up to the ocean realm using the RTS feature and I got up to the point where I have to get the attention of the Locowhatever guy floating with the birds by playing the song on the rock. My microphone somehow became under the delusion that I was always blowing into it when I wasn't and wouldn't allow me to play any song aside from Awakening. So I saved my game and reloaded. Now the screen is all but completely black, nothing reacts at all, and the sound is messed up. Please tell me there's a way of recovering my data as I really cannot be bothered to start again. The microphone issue doesn't seem to affect any other games, so I think it might be an AP check for Zelda.

    - Some of my videos are not working properly in Moonshell. I use MS 1.71 as I dislike the interface for Moonshell 2. Most of the videos work fine. If I select some, they freeze while loading. If I select one that works then press the R trigger to cycle through until I hit the problematic files, they work fine. So it's hardly a major issue. The last time this happened was with my music folder. It was something about the folder pathway. I created a new folder named 'music 2' and transferred all my files in there and it works fine now. I assume the same technique will work with the video problem, but if it doesn't, is there anything else I could try?

    - Moonshell's soft reset isn't exactly responsive. Half the time it responds, half the time it doesn't. How do I fix it?

    EDIT: forgot to mention my firmware settings. Thought it might be important.

    - A lot of my technical issues seem to be unique to my primary 8GB MSD card. It's a Kingston SDHC I got second hand. I've already had to purge and refill it once after all my data went screwy, and I quite often get file problems like the video issue above. Is there a way to repair the card or should I just replace it? I've already reformatted the card a few times, it's only ever a temporary solution to the problem.

    Thanks in advance for any assistance.
     
  2. Blaze163
    OP

    Member Blaze163 The White Phoenix's purifying flame.

    Joined:
    Nov 19, 2008
    Messages:
    3,767
    Location:
    Coventry, UK
    Country:
    United Kingdom
    Seriously though. Help please?
     
  3. Chrono_Tata

    Member Chrono_Tata GBAtemp Advanced Fan

    Joined:
    Jan 26, 2008
    Messages:
    851
    Country:
    Thailand
    Don't really know what to help with the Zelda problem. With the video problem you could try reconverting with a different programme or with different settings. For the SD card try using the Panasonic SD Formatter.
     
  4. GH0ST

    Member GH0ST Your Hero is a Ghost

    Joined:
    Dec 17, 2006
    Messages:
    924
    Location:
    I was here... before...
    Country:
    France
    Not for 8 Go card.

    Try a chkdsk /F or even /R to correct possible fat corruptions.

    Delete/Backup all files and Try a new firmware upgrade after removing the whole cyclods folder ( or even on an empty card ).
     
  5. altorn

    Member altorn GBAtemp Advanced Fan

    Joined:
    Jul 15, 2007
    Messages:
    600
    Location:
    Toronto, Ontario
    Country:
    Canada
    if your DS hardware is being screwed up, it doesn't necessarily mean your microSD card being 8GB is the problem, but it could be a factor. Its somewhere in the software (either the patched zelda rom or your firmware altogether).

    one suggestion i could offer is acquiring a save file and save with RTS / acquire an RTS stream, then acquiring the infamous PREMADE ZELDA SPIRIT TRACKS save file which fixes the saving in CycloDS. I tried this save file with a new game, then loading my RTS(which was 1/4 through the game), and RTS and normal save works perfectly without starting all over again.

    as much as possible, limit using RTS, especially on zelda + 8gb microSD because file writing on these cards could seriously cause fragmentation, write errors, etc, which mean screwed up loading save states.
    Basically RTS takes some sort of image of the current frame, but when loading, re-rendering that frame, along with the sound, ON A SLOW CARD, is a big problem.
     

Share This Page