1. Ericthegreat

    OP Ericthegreat Not New Member
    Member

    Joined:
    Nov 8, 2008
    Messages:
    3,395
    Country:
    United States
    I think im on 5.05, is there a new mod, or a way to play newer games yet?
     
  2. Zyvyn

    Zyvyn GBAtemp Addict
    Member

    Joined:
    Aug 9, 2017
    Messages:
    2,048
    Country:
    United States
    No and there most likely will never be until the system stops being updated and is modded on the latest version
     
    Ericthegreat likes this.
  3. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,793
    Country:
    United States
    No , Hen has nothing to do what firmware games are allowed to played on, some 5.05 games can be played on 4.55 I believe, but nothing 5.50 and above can be played on 5.05 as far as I know.
     
  4. Ericthegreat

    OP Ericthegreat Not New Member
    Member

    Joined:
    Nov 8, 2008
    Messages:
    3,395
    Country:
    United States
    What firmware version is guacamelee 2?
     
  5. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,793
    Country:
    United States
    Ain't gonna be 5.05, probably 5.55
     
    KiiWii and Ericthegreat like this.
  6. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,565
    Country:
    United Kingdom
    Could theoretically play 5.50 games on 5.05...:

    1, IF someone with private 5.50 kex dumps and leaks a 5.50 game.
    2, IF 5.05 SDK leaks.
    3, IF said dump had same modules 5.05 has.
    4, IF those modules can be swapped out with the ones in 5.05 SDK and successfully FPKGd.
    5, IF that PKG works fully on 5.05.

    Gulp.

    For a start:

    1, Ain’t going to happen any time soon.
    2, Ain’t going to happen any time soon.
    So I guess my point is moot :P

    Again it’s theoretically based on what happened with 5.05. The 5.50 private circle is tight AF.

    :P
     
    Last edited by KiiWii, Sep 2, 2018
    GaaraPrime and Hayato213 like this.
  7. Tomassi

    Tomassi Advanced Member
    Newcomer

    Joined:
    Dec 19, 2017
    Messages:
    94
    Country:
    United Kingdom
    I'm not jumping on the 'release 5.55 already' bandwagon, but why would you say it will likely never get released. I mean, we've had 5.05 released to date, why would anyone wait to release 5.55 whilst the console is still being updated? Surely it would be released when Sony update to 6.0 firmware, wouldn't it?
     
  8. Jokiz

    Jokiz GBAtemp Regular
    Member

    Joined:
    Jun 13, 2007
    Messages:
    178
    Country:
    Norway
    I'm guessing they'll only release the 5.55 exploit when Sony patches it. So if the exploit remains unpatched on 6.0 they'll probably not release it.
     
  9. smf

    smf GBAtemp Guru
    Member

    Joined:
    Feb 23, 2009
    Messages:
    5,042
    Country:
    United Kingdom
    Or if the game was developed with <= 5.05 SDK but was signed with 5.50 keys so that it can't be pirated.

    Games being signed with higher keys than they required happened a lot on the PS3 for the same reason.

    I think it's more complicated than that.

    1. people have other things going on in their lives.

    2. often they only find the exploit when sony patches it. They have an unburned kernel exploit that allows them to dump the kernel, then they look for where sony have made fixes & then they look for ways to exploit the old code.
     
    Last edited by smf, Sep 4, 2018
    KiiWii likes this.
  10. Tomassi

    Tomassi Advanced Member
    Newcomer

    Joined:
    Dec 19, 2017
    Messages:
    94
    Country:
    United Kingdom
    So, essentially, there is no reason for Sony to patch the exploit? Presumably Sony actually read all these forums etc so they may as well leave it unpatched if that is going to stop people exploiting it. Shame :-(
     
  11. MasterJ360

    MasterJ360 GBAtemp Addict
    Member

    Joined:
    Jan 10, 2016
    Messages:
    2,275
    Country:
    United States
    Im sure Sony knew about the 5.55 exploit months ago b/c of a dev blabbing about it to their faces. Its these kind of actions that will hurt us in the long run. 5.50 owners are still screwed despite being down 3 OFW's
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, Playing, higher