Photofast CR-5400 - won't format!

Discussion in 'PSP - Games & Content' started by manobon, Sep 28, 2008.

Sep 28, 2008
  1. manobon
    OP

    Member manobon GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    175
    Country:
    United States
    I posted this on a more psp-specific board/site, but if anyone here has any help/suggestions to give, I'm all for them.

    I recently bought the Photofast CR-5400 microsdhc to pro duo adapter (from shopdigi.com). The only reason I bought it was because I was having trouble with formatting issues with previous adapters (like the one from dealextreme, or ebay ones).

    Anyway- I have an A-Data 8GB Class 6 microsdhc card, and a Sandisk 8GB Calss 4 microsdhc card. At first, the microsd cards in the adapter...then placed in a memory stick Duo adapater would be read by my pc (15GB! Hooray!).

    But then, when I try to format it on the psp (slim, purchased before the new-board-models, and 4.01 M33-2), either it won't read the card at all, the memory stick light will just keep blinking (not Fast blinking like when it's reading the card), and/or! when I try to format from the psp, it'll give me the 80020321 error ("There was an internal error" or whatever), or just say that there isn't a memory stick at all.

    I'm not sure what else to do. It Sometimes will read from the psp-usb connection, but recently (as of last night and this morning) it's not even doing that anymore. Suggestions? Help?
     


  2. Whizz

    Member Whizz When things don't go right, go left.

    Joined:
    Nov 20, 2007
    Messages:
    628
    Location:
    Turn around...
    Country:
    Netherlands
    Maybe just one of the cards is causing problems, try taking one out and if that doesn't work take that one out and put the other one back in.
     
  3. Raki

    Member Raki GBAtemp Advanced Fan

    Joined:
    Jul 16, 2008
    Messages:
    554
    Country:
    Germany
    wait....you put 2 MicroSDHC cards into this adapter? oO
    If so...maybe the speed difference produces the problems?
     
  4. Tikker

    Member Tikker GBAtemp Advanced Fan

    Joined:
    Apr 8, 2007
    Messages:
    653
    Country:
    Canada
    i would kind of think that you'd need to put identical cards in, but that's just a guess from other items I've used
     
  5. Tikker

    Member Tikker GBAtemp Advanced Fan

    Joined:
    Apr 8, 2007
    Messages:
    653
    Country:
    Canada
    hrm, sounds good actually

    try it one memstick at a time and see if you can figure out which card is flaking
     
  6. manobon
    OP

    Member manobon GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    175
    Country:
    United States
    thanks for all the responses and suggestions- I've tried using both cards individually (after being formatted on the pc, they both read off of the one-microsd-card to pro duo adapter), but Neither of them show up when using the photofast cr-5400.

    As for the one-card adapter, that won't psp-format still, but after I pc-format it (even if I just quick Fat32 format), everything runs fine on the psp.

    Uhy, I know this product is Supposed to work- anyone have any more suggestions? Or do I possibly have a faulty cr-5400?
     
  7. Raki

    Member Raki GBAtemp Advanced Fan

    Joined:
    Jul 16, 2008
    Messages:
    554
    Country:
    Germany
    have you tried both slots? maybe one of those slots is faulty
     
  8. manobon
    OP

    Member manobon GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    175
    Country:
    United States
    Yeah, I tried both slots- still didn't work. =^\ Also, according to reviews and such, I'm supposed to only use the first slot anyhow, if just using one card.

    "*sigh, and that youtube video showed me such promise!"
     
  9. g4med4d

    Member g4med4d GBAtemp Regular

    Joined:
    Sep 7, 2007
    Messages:
    149
    Country:
    United States
    Have you tried contact Photofast's support?

    I was just looking at it and it seems good. I would think formatting on the PSP would not work as the PSP will most likely format a MS Duo that is a Magic Gate.
     
  10. crazylegs

    Newcomer crazylegs Newbie

    Joined:
    Sep 29, 2008
    Messages:
    5
    Country:
    United States
    The same thing happen to me with the CR-5400 and PSP 4.01M33-2..


    I just received on my CR-5400 last friday. i'm using it in conjunction with a Transcend 4gig class 6 with an 8gig class 6 A-DATA...


    It worked beautifully for 1 day. Formatted both cards together and the PSP saw 11.2gigs. I noticed that next day the PSP was locking up when attempting to start ISO games. The memory light began blinking and nothing was happening. So i tried formatting the cards again. Every time i formated the cards it started getting progressively worse with the lock ups. My psp doesn't read the cards now using the CR-5400. it actually will not boot unless i remove the CR-5400. When ever i use my other DUO adapter my psp works fine..


    My PC has no problem reading/writing/formating the CR-5400.

    I'm beggining to wonder if there is bug in the product as we both seemed to be having similar issues.

    any suggestions..?
     
  11. Tikker

    Member Tikker GBAtemp Advanced Fan

    Joined:
    Apr 8, 2007
    Messages:
    653
    Country:
    Canada
    will they work inside a PC?

    I mean, if you slot both microSDHC cards into the adapter, then plug the adapter into the PC, it works there fine?
     
  12. crazylegs

    Newcomer crazylegs Newbie

    Joined:
    Sep 29, 2008
    Messages:
    5
    Country:
    United States
    Tikker...

    Yes it works fine on the PC.. It formats and sees everything i throw at it. I got it working again last night until i attempted to open up another ISO game. The PSP locked up on me again and lost the ability to read the card. I'm going to go ahead and RMA the card. Hopefully i just got bad one and not something that is buggy..
     
  13. manobon
    OP

    Member manobon GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    175
    Country:
    United States
    I think this is the first time I've started a thread and received helpful/informed responses (or ANy responses for that matter), so thanks for making me feel less lame!

    Also, yeah- I just received the RMA # for mine, and I'm going to -hopefully- be sent a working one. The support staff from shopdigi.com told me to just try formatting it with the cards via the psp...even though that's the first thing that Didn't work.

    I'm guessing along with the others, I'll update on whether or not the 'new' adapter works.
     
  14. techno7

    Newcomer techno7 Newbie

    Joined:
    Sep 30, 2008
    Messages:
    1
    Country:
    United States
    I have exactly the same problem with the CR-5400. I used it with two 8GB Sandisk MicroSD. It seems to work the first day I received it. I could even run games on it. Then the PSP started having problem powering up. The LED keeps blinking endlessly.

    When it did boot up, I reformated the cards with no problem but that did not fix it.

    I also got my CR-5400 from Shopdigi. I wonder if they got a bad batch of CR-5400. I found out that Photofast had to recall the first batch of CR-5400 because they didn't work.
     
  15. Tikker

    Member Tikker GBAtemp Advanced Fan

    Joined:
    Apr 8, 2007
    Messages:
    653
    Country:
    Canada
    hrm

    well, if your RMA"s come back and you end up with working ones keep us updated

    I'm pretty interested in adding a bit of capacity to my PSP and this would be slick
     
  16. crazylegs

    Newcomer crazylegs Newbie

    Joined:
    Sep 29, 2008
    Messages:
    5
    Country:
    United States
    Hey guys... here is my update.... I RMAed my bad CR-5400 to shopdigi. They sent me a new one yesterday. When i opened the box i notice a labeled stating that it was tested prior to shipping with a PSP slim.

    The new one also failed on me with the same exact way as the first one did. I'm wondering if there is a defect in production or if there is a compatibility issue with my PSP 1001 vs the Slims.. I sent them and email and responded right away. They even called me on the phone to try more troubleshooting procedures.. Shopdigi has great customer service btw...! I'm glad they are helping me

    I forwarded them a video of my problem so now i'm waiting on their response from it. I will keep everyone posted.
     
  17. Tikker

    Member Tikker GBAtemp Advanced Fan

    Joined:
    Apr 8, 2007
    Messages:
    653
    Country:
    Canada
    that'd kinda suck if they only work in the slims
     
  18. ackers

    Member ackers GBAtemp Advanced Fan

    Joined:
    Jul 17, 2007
    Messages:
    990
    Country:
    United Kingdom
    I was looking at buying one of these till I saw this thread... can anyone recommend me a microSDHC > MS Pro Duo adapter which actually works in the PSP please? I've tried Google but all it brings up is microSD only OR microSDHC to memory stick adapters which comes with a microSDHC card. I want just the adapter as I already have the card.
     
  19. manobon
    OP

    Member manobon GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    175
    Country:
    United States
    okay- Just received the RMA-returned CR-5400 today and...holy crap it works! =^D 15GB to use (well, 11GB now, but still).

    Mine was tested by shopdigi with a kingston 8GB and 1GB (1GB?) in conjunction...I'm using the same cards as before. We'll see if my system continues to recognize the space when I add new games, turn on the system after a while, etc. but I'm hoping there are no future problems.

    I think what might've been the issue was that...the CR-5400 Is as fragile as the packaging says it is...meaning, Always handle it by the edges (like holding a photo, instead of getting thumbprints/smudges onto it).

    As far as a reliable microsdhc ->pro duo adapter... the thing I got from newegg.com or mobymemory (As aforementioned) works like a charm with my 8GB class 6 A-DATA card and anything/everything else. Anyway, I have to get back to apartment hunting and other stuff (like adding isos/csos of games i've been missing out on!).

    I'll post again after a few days/removals of the card to verify if it still reads well, and whatnot. Laters!
     
  20. ackers

    Member ackers GBAtemp Advanced Fan

    Joined:
    Jul 17, 2007
    Messages:
    990
    Country:
    United Kingdom
    cool glad it works. i'll wait to see what you say about it in a few days before i buy one.
     

Share This Page