PCSX2: Weird graphical issues in KH2 FM

Discussion in 'Computer Software and Operating Systems' started by Thanatos Telos, Feb 2, 2014.

  1. Thanatos Telos
    OP

    Thanatos Telos random stuff

    Member
    842
    187
    Sep 13, 2009
    United States
    Yeah, so here's the graphical glitch (Outlined in red)
    And here's my configuration.
    And my specs are as follows:
    FX-8320@Stock
    16GB RAM
    GTX 760

    So, this glitch stays on the screen constantly, moving over the terrain with the character. This occurs on my completed save in all worlds as well, but doesn't do it during the Xemnas boss battle, oddly enough. So, could anyone please help?

    Thanks.

    EDIT: Also, I tried it without Alpha on too. No improvements.
    EDIT2: Tried it with DX9 (Hardware). The issue became worse.
     
  2. trumpet-205

    trumpet-205 Embrace the darkness within

    Member
    4,363
    542
    Jan 14, 2009
    United States
    Have you tried PS2 native resolution and software mode (SSSE3)?

    Technically anything other than PS2 native resolution or hardware plugin is considered a hack.
     
  3. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,170
    10,062
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Though some games look pretty horrible in native/software rendered resolution :P Many games will look a lot better with high internal resolution, which is what PCSX2 was meant for, I think.
     
  4. Thanatos Telos
    OP

    Thanatos Telos random stuff

    Member
    842
    187
    Sep 13, 2009
    United States

    I have, but it yields lower performance, looks like shite, and it still keeps the issue. Thanks, though.
     
  5. kristianity77

    kristianity77 GBATemp old fogey

    Member
    1,423
    377
    Jul 10, 2003
    Bewdley, UK
    Which version you using, i notice 1.2.0 has just been released have you tried that?
     
  6. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,170
    10,062
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Didn't even that release lol. I knew it was soon, but a nice surprise!
     
  7. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,548
    10,480
    Jul 11, 2009
    United States
    I forgot
    Trying changing MSAA to 0 in the hacks config.
     
  8. Celice

    Celice GBAtemp Advanced Maniac

    Member
    1,916
    354
    Jan 1, 2008
    United States
    Have you tried a different rendering plugin? Checked the emulator's wiki page and forums for compatibility?

    Emulation accuracy has kind of been shafted in the past few generations of emulators for the sake of greater playability. Sometimes this means legitimate games are unable to be finished due to hacky emulation. More often, you might be left with wonky effects like what you're seeing here :/
     
  9. Thanatos Telos
    OP

    Thanatos Telos random stuff

    Member
    842
    187
    Sep 13, 2009
    United States
    Celice likes this.
  10. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,548
    10,480
    Jul 11, 2009
    United States
    I forgot
    As Celice said, you should check the compatibility wiki more often. While Final Mix didn't have any info on this bug, the original Kingdom Hearts 2 did. ;)
     
  11. SoupaFace

    SoupaFace Advanced Member

    Newcomer
    54
    11
    Jan 22, 2013
    United States
    It mostly depends on which speed hacks you're using. I had more graphical issues with mVU flag hack on actually and I believe just setting EE cycle rate to 2 instead of 3 as well as turning the 3-core enabling speedhack off caused the weird texture glitching at far distances (specifically during cutscenes) to go away. Since doing all that i haven't noticed any glitching.

    It should also be noted that I received my pre-patched iso from a very popular torrent site which should be very easy to find if it's the disk image itself thats causing the issue. I believe my image has the latest patch even tho it was uploaded a few years ago and everything was translated except for a huge percentage of the mini game prompts and the last little bit of story dialogue in disneys castle.

    So if that sounds similar to what you experienced in terms of wat wasn't translated then u shouldn't need to worry about save corruption.

    Also good luck on getting that gold crown because holy CHEESE is that hard to get on critical mode

    EDIT: ooooooh he already got it resolved...