O3DS on 4.x Emunand Profile Exploit Upgrade

Discussion in '3DS - Flashcards & Custom Firmwares' started by wiiando, Jul 5, 2016.

  1. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    Not been keeping up with anything 3ds since around October last year after using crtbootmanager on my 3ds xl last year to boot rxtools.

    I have another O3DS that boots emunand via the profile exploit (4.x), which I use a flashcard with too, using the flashcard breaks the profile exploit and i'm getting pretty fed up reinstalling from the flashcard and I want to autoboot to cfw.

    I'm not asking so much to be spoon fed but what's the best option to go with as there seems to be that many exploits and cfw around I don't know the best option to go for.
     
  2. wormdood

    wormdood pirate booty inspector

    Member
    3,113
    1,285
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    your best option is this guide
    https://github.com/Plailect/Guide/wiki

    you should read up on a9lh (a9lh is the goal of the guide) if you want that then follow the guide
    however if you decide you dont want a9lh then

    using the same guide do the 9.2 update (listed after part 5) (also linked in the post below this one)
    then do parts 1 and 3
     
    Last edited by wormdood, Jul 5, 2016
  3. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,507
    492
    Mar 20, 2010
    United States
  4. Deck of Noobs

    Deck of Noobs Politically Incorrect

    Member
    765
    1,103
    Apr 9, 2016
    United States
    3ds.guide
    ninja'd
     
  5. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    Thanks for the direction, seems i'll need a good few hours to set all this up. Only really glanced through it atm but am I correct in thinking all of my titles in my current emunand will be still available once i've completed the guide?
     
  6. wormdood

    wormdood pirate booty inspector

    Member
    3,113
    1,285
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    if you wanted to use menuhax then yes
    if you have decided to go a9lh all the titles in your emunand will be moved to sysnand and you will no longer need/use emunand
     
    wiiando likes this.
  7. buda81

    buda81 GBAtemp Regular

    Member
    188
    59
    Sep 13, 2009
    United States
    I've just did the guide over the weekend on my o3ds 4.x. I did run in to a few issues, but resolved them with some research. I used a new sd card and left my emunand on the side while creating a new emunand for the guide. When I was finished, I move all relevant/necessary files to my original sdcard.

    If your flashcart was a gateway, read this first.

    https://github.com/AuroraWright/Luma3DS/wiki/FAQ-and-Troubleshooting
     
  8. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    Right, spent many hours on this now, got to part 5 and realised I didn't do a backup of my Rednand

    here
    Section II - NAND Backups


    1. Get into the Homebrew Launcher on SysNAND through the entrypoint of your choice
    2. Open OTPHelper (this can take a few tries in some situations)
    3. Go to "NAND Backup & Restore"
    4. Backup EmuNAND to emuNAND_original.bin (you can use Up and Down / Left and Right to change the name)
    But I did do all the rest of the steps, so I have a backup of my formatted red/emunand. I need a emu/rednand in the final steps is it ok to use the emuNAND_formatted.bin or should I go back and update and backup again, as currently in process of going to 2.1
     
    Last edited by wiiando, Jul 6, 2016
  9. Dorimori

    Dorimori professional lurker

    Member
    409
    1,090
    Mar 17, 2016
    United States
    possibly in your closet
    Go back, and get the backup.
     
  10. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States

    OK, so i'm best restoring my emuNAND_formatted.bin as I can't boot cfw in 2.1 to be able to use sysupdater
     
  11. Dorimori

    Dorimori professional lurker

    Member
    409
    1,090
    Mar 17, 2016
    United States
    possibly in your closet
    Your emuNAND_formatted should be fine.

    edit: Actually, later on in the guide you restore from EmuNAND_original. So, you won't be fine.
     
    Last edited by Dorimori, Jul 6, 2016
  12. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    So i'd need to make a new rednand from scratch Part 3

    My own fault for doing it so late, hours have just passed by, so many steps and backups :(
     
    Last edited by wiiando, Jul 6, 2016
  13. zezzo

    zezzo The "Black Ace"

    Member
    479
    170
    Sep 14, 2015
    United States
    If you are tired, take a break
     
  14. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States

    Ye off to bed now, had enough, nvm back to it tomorrow
     
  15. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    OK, i'm now stuck, getting the NFIRM error in PlaiSysUpdater due to the rednand being 11.0 , tried with luma 5.2 and can't get luma 5.5 to boot at all no matter how many times I try
     
  16. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    No offence to the guy who made all this possible but isn't the guide setting people up to fail?

    Can't downgrade 11.0 yet the guide tells you to update rednand, seems it's best to remain on a 9.2 rednand and downgrade?

    Seems i'm overlooking things or it's not clear i'm not sure, placed firmware.bin from NTR into the luma folder and luma 5.5 now boots, trying to downgrade again
     
    Last edited by wiiando, Jul 6, 2016
  17. opa334

    opa334 Advanced Member

    Newcomer
    52
    24
    Nov 3, 2015
    Gambia, The
    You need to put a 10.2 firmware.bin into your luma folder, you can get it from the guide I think.
    EDIT: Get it here from where it says "Get the NTR FIRMs package from here", I have no idea why this is not mentioned in the guide

    — Posts automatically merged - Please don't double post! —

    Seems like I have overlooked this... If you have downgraded via gateway before: https://github.com/AuroraWright/Lum...-downgraded-from-the-gateway-menu-in-the-past
     
    Last edited by opa334, Jul 6, 2016
    wiiando likes this.
  18. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States

    ye I figured that out after some googling, the guide just presumes you know how luma3ds works and how to set it up, which I don't, downgraded no issues this time round
     
  19. wiiando
    OP

    wiiando GBAtemp Regular

    Member
    119
    32
    Dec 28, 2008
    United States
    All went well, except I can't get my flashcart to boot, just black screens :(

    NVM, google to the rescue again :P

    Anyone encountering the same issue install either of these depending on your system via FBI

    0004013800000102 v8817 for o3DS/2DS
    0004013820000102 v9936 for New 3DS

    All works fine now, never got a prompt to overwrite so can only assume it was missing.
     
    Last edited by wiiando, Jul 6, 2016