NOGC

by Amino Sep 3, 2018 at 4:18 PM 4,682 Views 20 replies
  1. Amino
    OP

    Amino Advanced Member

    Newcomer
    2
    Feb 10, 2016
    Gambia, The
    Update 3.0.0 to 5.1.0 with Choi...
    I forget to add kip1patch=nogc
    I use Hekate and tomsgerm sd files..
    So if I restore to 3.0.0 my Gamecard slot don't work anymore ?
     
    Last edited by Amino, Sep 3, 2018
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Correct however CTCaer teased a way of being able to undo the gamecard slot update. There is no ETA on when such a function will be available though.
     
    LeMageFro, 877 and Lacius like this.
  3. Creatable

    Creatable GBAtemp Advanced Fan

    Member
    8
    Jul 10, 2017
    United States
    (insert wacky and amusing place here)
    What if you nand restore to a previous version?
     
  4. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    The GC slot has its own chip meaning it has its own firmware so a NAND restore won't reverse the update; it would need to be done with a tool that can manipulate the chip the GC slot uses.
     
    NoNAND likes this.
  5. Creatable

    Creatable GBAtemp Advanced Fan

    Member
    8
    Jul 10, 2017
    United States
    (insert wacky and amusing place here)
    Well shit... I updated to 6.0.0 and didn't use nogc...
     
  6. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Don't fret. I asked CTCaer about this when he initially teased a way to reverse the update and this was his response:
     
  7. nero99

    nero99 GBAtemp Addict

    Member
    10
    Sep 18, 2014
    United States
    What exactly is the poIsn’t in the nogc patches if one isn’t “downgrading” their system?
     
  8. Amino
    OP

    Amino Advanced Member

    Newcomer
    2
    Feb 10, 2016
    Gambia, The
    Hmm ok...But if I Restore to 3.0.0 to use hopefully Cooldboot someday...Emunand on higher firmware + Atmosphere still fix my problem ?
     
  9. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    1. We already have coldboot via Fusee Gelee. If you are referring to untethered coldboot, it is only theoretically possible however no one is working on such an exploit.
    2. As long as you don't have more than 4 burnt fuses (the theoretical untethered coldboot works up to 3.0.1), then you will be able to downgrade to any of those exploitable firmwares in the future. However you will not be able to use your gamecart slot on any firmware below 4.0 for now so if the coldboot exploit makes use of a gamecart, you will have been waiting for nothing
     
  10. Amino
    OP

    Amino Advanced Member

    Newcomer
    2
    Feb 10, 2016
    Gambia, The
    @tomGER please add kip1patch=nogc in your files

    — Posts automatically merged - Please don't double post! —

    3.0.0 sysnad slot don't work !
    5.0.1 Emunand and the slot works again ?
     
    NoNAND likes this.
  11. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    When the GC slot gets updated on a firmware of 4.0 and above, it renders it broken on firmwares below 4.0. However, this allows it to be used on firmwares 4.0 and above so the slot will work on 5.0.1 and all of those other firmwares. I'd also like to add that EmuNAND cannot protect this update for people who haven't updated their gc slot yet so those people would need to use the nogc patch as well, EmuNAND or otherwise.
     
  12. Amino
    OP

    Amino Advanced Member

    Newcomer
    2
    Feb 10, 2016
    Gambia, The
    Ok I still use nsp for now. I never use game cards on my switch...
    Did the nsp Games update the slot ?
     
  13. Meriadoc

    Meriadoc GBAtemp Regular

    Member
    2
    May 14, 2016
    Italy

    Imho with pegaswitch as entry point I think that is unlikely that we will need a gamecart to a coldboot exploit, with probability we will need only the browser.
     
  14. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Your question makes no sense; .NSP games are basically dumps of eShop games. The only thing that updates the slot is running a firmware of 4.0 or higher without the nogc patch.
    PegaSwitch is most likely needed for the warmboot exploit known as Deja Vu. If you read about the theoretical untethered coldboot, it has nothing to do with web access but save data.
     
  15. tomGER

    tomGER GBAtemp Fan

    Member
    7
    Feb 6, 2017
    Germany
    No, there is no reason to - People that down-/upgraded need to edit their hekate_ipl.ini either way and those who didn't don't need to disable their gc - That patch *Only* disables your game card slot
     
    ShonenJump likes this.
  16. Meriadoc

    Meriadoc GBAtemp Regular

    Member
    2
    May 14, 2016
    Italy
    Thanks for the clarification. I hope than if and when will be a coldboot we will be able to downgrade the firmware of the GC.
     
  17. panni

    panni Member

    Newcomer
    2
    Jan 8, 2015
    Gambia, The
    I think I accidentally booted 5.1.0 without NOGC while upgrading my SD files.

    Is there a way to check the gamecard controller firmware?
     
  18. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    The only way to check is by trying to use a retail cartridge on the Switch.
     
  19. panni

    panni Member

    Newcomer
    2
    Jan 8, 2015
    Gambia, The
    Thank you. How would that help me in this case, though? The gamecard firmware is updated, not bricked, so without NOGC the cartridge will work, with NOGC it won't.

    I guess I could downgrade to 3.0.2 and see if a gamecard works, yeah.

    I should've been more specific: How can I verify the gamecard slot controller firmware version?
     
  20. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    You kinda just answered your own question; you check by trying to load a retail cartridge on a firmware lower than 4.0. There is no tool to display the current firmware of that slot.
     
    panni likes this.