"no DS card inserted" error...

Discussion in 'M3 Adapter' started by martinlee, Nov 11, 2009.

  1. martinlee
    OP

    martinlee Newbie

    Newcomer
    5
    0
    Nov 11, 2009
    United States
    I read and searched so many post I don't know what to do next!
    Maybe someone can help me solve this riddle?!?

    Scenario:
    - NDS lite
    - Brand new M3i card
    - Brand new 4GB SDHC Kingston card (perfectly working on PC, formatted with SD formatting program)

    - Copied on the SD card the "M3_Sakura_1.43X_4.5X" as "system" folder
    - Copied on the SD card the "F_core1.4" as "f_core.dat" in the root

    - Inserted the SD card inside the M3i zero
    - Plugged the USB Firmware updater, the M3i card blinks intermittently for about 30 seconds and then stops (seems fine!)

    But when I insert the M3i in the DS I always get the "There is no DS card inserted" message!
    I tried many times, with the following changes:
    - formatting the SD card with Windows / formatting with SD utility
    - using latest sakura (1.43x) / using older versions (1.41also with older system software, but always the same result
    - using a different DS lite (both DS lite work perfectly with an old DSX card and games)

    Don't know what to think... The M3i zero seems to work fine and performs the firmware flashing blinks, but is never recognised by the DS!

    What can I try next?? [​IMG]
     
  2. Densetsu

    Densetsu Pubic Ninja

    Former Staff
    3,435
    2,865
    Feb 2, 2008
    United States
    Wouldn't YOU like to know?
    First of all, if you're using a DS Lite (and not a DSi), then the whole flashing step with the fcore.dat is unnecessary. All you need to do for a DS Lite is copy the entire SYSTEM folder to the root of your MicroSD card, and nothing else.
     
  3. g6team

    g6team GBAtemp Advanced Fan

    Member
    545
    0
    Aug 30, 2007
    Hong Kong
    Actually the M3i Zero must be flashed first for it to be functional. Please try using another Microsd as well there are cases where the Microsd itself was the issue.
     
  4. martinlee
    OP

    martinlee Newbie

    Newcomer
    5
    0
    Nov 11, 2009
    United States

    ok, I'm trying that, even if the SD works fine with my Pc.

    but what should happen when inserting the M3i zero in the DS lite WITHOUT the SD card? should the DS recognise the M3i as well?
    ...this does not happen to me, the slot remains "empty"
     
  5. martinlee
    OP

    martinlee Newbie

    Newcomer
    5
    0
    Nov 11, 2009
    United States
    I have flashed the M3i with latest f_core.dat v1.4 and it's not working, should I use an older version since I have a DS lite and not a DSi ?

    (In order to isolate possible problems, my first goal will be to get the M3i recognised by the NDS lite, without the SD card inserted!)

    thank you
     
  6. CannonFoddr

    CannonFoddr Regular GBATemp Lurker

    Member
    4,115
    68
    Sep 23, 2006
    Sitting by computer
    Not sure if this will be relevant, but had a similar problem with another flashcard (AK2i)

    Apparently DSlites have shorter card contact points inside & this can cause flashcards not to make the contacts correctly - thus giving a 'no card found'

    Many people claim placing a thin piece of cardboard behind the (Sticker side of) flashcard help push it against the DSite contacts & in turn getting it to show
    Other stae a peice of card behind just the contact part of the card does the job as well (but it means opening the AK2 card up)

    Oh - for your information - you should still see the 'Danny Phantom' icon, regardless of whether there's a SD card in it or not
     
  7. martinlee
    OP

    martinlee Newbie

    Newcomer
    5
    0
    Nov 11, 2009
    United States
    thanks, already tried both the "paper trick" and the "blow everywhere" trick, no results...

    what makes me crazy is the fact that the flashing process looks fine as described in the manual (about 30 seconds of red light blinking on the card, and then stops) so the card does not seem broken...

    but then 2 different DS lite do not recognise the M3i ! [​IMG]
     
  8. Densetsu

    Densetsu Pubic Ninja

    Former Staff
    3,435
    2,865
    Feb 2, 2008
    United States
    Wouldn't YOU like to know?
    Oh I see. I thought it was just to bypass the DSi update that blocks flashcarts. Thanks for clearing that up for me [​IMG]

    *EDIT*
    martinlee, did you try a different MicroSD card? Any luck yet?
     
  9. martinlee
    OP

    martinlee Newbie

    Newcomer
    5
    0
    Nov 11, 2009
    United States
    Finally solved it!

    This combination worked:

    - same SD card
    - "paper trick"
    - f_core.dat ONLY (no "system")

    this way I got the DS lite "see" the M3i
    then added the new 4.6 beta "system"

    thanks to everybody!
     
  10. Hadou

    Hadou Newbie

    Newcomer
    5
    0
    Oct 12, 2009
    Thank CannonFoddr - I did not know that. I always wondered why sometimes it fails to recognise it. I will be trying to paper trick soon.