New kernel help?

Discussion in 'R4 DS' started by jx_ds, Aug 13, 2007.

  1. jx_ds
    OP

    jx_ds Newbie

    Newcomer
    3
    0
    Aug 13, 2007
    Canada
    I downloaded the new kernel for R4, v1.11, I copied the system, moonshell, ds menu dat, and ds mshl to the micro sd card, then when i tried to open the r4 a message popped up saying

    "!!!" and some chinese (I can't read it)... Help? Does anyone know whats wrong?

    (My r4 is the chinese version...)
     
  2. thomasroberts6

    thomasroberts6 GBAtemp Fan

    Member
    496
    0
    Aug 13, 2007
    Why do you have a chinese r4?

    And if you could translate it ou may know.
    *BABELFISH!!!!*

    Try it again.
     
  3. jx_ds
    OP

    jx_ds Newbie

    Newcomer
    3
    0
    Aug 13, 2007
    Canada
    I can't exactly translate it because I dont know how to type in the chinese onto the translater...

    (I have the chinese version cause i got it from china....)
     
  4. mikeyt1998

    mikeyt1998 YouTube Glitcher

    Member
    1,398
    63
    Aug 11, 2007
    Dalton-in-furness, north west
    if you got the Chinese R4 then you need to patch the '_DS_MENU.DAT' with a language patcher which you can find somewhere on the net, i just got sent one in an email from the guy who sent me my R4 and now 1.11 works in English.

    however i dont know where you get the patcher coz i was searchin for like 3 hours last night and couldnt find it. besides when i have 1.11 installed when i try to load games they just crash at the game loading part...

    i'm sticking with 1.10 for a while.
     
  5. jx_ds
    OP

    jx_ds Newbie

    Newcomer
    3
    0
    Aug 13, 2007
    Canada
    Hmmm....I guess i'll just go with the older version too....
     
  6. Lost Racer

    Lost Racer Member

    Newcomer
    37
    0
    Jan 3, 2007
    United States
    Did you download the chinese upate or the english one for it?
     
  7. dbgtdob

    dbgtdob GBAtemp Advanced Fan

    Member
    588
    0
    Feb 14, 2007
    United States
    sounds like they found out about the hack to change the language and are now blockign it thats what i think anyway, keep using the older version although some of the nwer games probably wont work.
     
  8. Dylaan

    Dylaan GBAtemp Fan

    Member
    384
    0
    Jul 5, 2007
    I'm pretty sure this is what you are looking for --> Click Here

    Hope that helps!
     
  9. cory1492

    cory1492 GBAtemp Maniac

    Member
    1,489
    19
    Jun 23, 2005
    Canada
    Home, WhereElse?
    The hack still works, you realize when you recompile a piece of code with changes, chances are the final binary will not have the stuff the language hack changes in the exact same location right? It's no uber-l337 language blocking or anything else, just a different binary from the one the change worked on previously.

    IIRC you can find it or what to do to the last version in the release thread for the current firmware, and probably other places here if you look.

    Took me about 2 minutes to find it in the 1.11 thread
    http://gbatemp.net/index.php?showtopic=564...39&#entry722139
    by iq_132, hopefully it works with your version too.

    It's in the download section, with a link to the latest one in the comments too (the actual download there is for 1.10 release)... it's popping up everywhere now that I found it.
    "R4 firmware to M3 DS patcher"
    http://gbatemp.net/index.php?download=681