Need Some Help Deciding

Discussion in 'NDS - Flashcarts and Accessories' started by Sandman00009, Feb 24, 2009.

Feb 24, 2009
  1. Sandman00009
    OP

    Member Sandman00009 GBAtemp Regular

    Joined:
    Mar 2, 2008
    Messages:
    255
    Country:
    United States
    i want to get a dsi and be able to run flash cards which flashcard would be good and someone told me that nintendo can fix the dsi so it wont play flashcards with a firmware update is this true????
     
  2. wchill

    Member wchill Resident chillxpert

    Joined:
    Jun 12, 2008
    Messages:
    1,407
    Country:
    United States
    Slow down there!
    The DSi will not run conventional DS flashcards, you will require one that is DSi compatible.
    Currently, I'd get the AK2i. Only if I really had to.
    And yes, the DSi can block flashcards with firmware updates (in theory). We haven't actually had such an update so far, but that might change on April 5.
     
  3. Sandman00009
    OP

    Member Sandman00009 GBAtemp Regular

    Joined:
    Mar 2, 2008
    Messages:
    255
    Country:
    United States
    is there any way to keep on a certain firmware like the wii???
     
  4. Nathan-NL

    Member Nathan-NL GBAtemp Fan

    Joined:
    Jan 15, 2008
    Messages:
    399
    Location:
    The Netherlands
    Country:
    Netherlands
    Yes, Nintendo can block DSi flashcarts using a firmware update.
    The Acekard 2i is a good option and if you don't go online (or block the update server in your router) you should be save.
     
  5. Ryukouki

    Member Ryukouki See you later, guys.

    Joined:
    Jan 31, 2008
    Messages:
    4,949
    Country:
    United States
    so wait on april 5 the acekard 2i will not work on a us or japanese dsi? shit better cancel my acekard 2i from dx!
     
  6. dinofan01

    Member dinofan01 Misses the old days...

    Joined:
    Jul 4, 2008
    Messages:
    2,842
    Country:
    United States
    No body said that. Hes just saying the DSi will launch on April 5 in America and it's possible it could come with a new firmware that could potential block the flash cart. In my opinion its possible just not plausible. Chances are there wont be much difference from the existing firmware.
     
  7. Ryukouki

    Member Ryukouki See you later, guys.

    Joined:
    Jan 31, 2008
    Messages:
    4,949
    Country:
    United States
    ok thanks now i can breathe again. [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
     

Share This Page