Need Help with Mplayer/Samba

Discussion in 'Wii - Hacking' started by jeffc313, Mar 8, 2009.

  1. jeffc313
    OP

    jeffc313 Advanced Member

    Newcomer
    87
    0
    Aug 7, 2007
    United States
    I am running ubuntu 8.10 with samba server installed. I have my videos folder at
    smb://opteron/videos
    I try to connect from mplayer, my wii gives its ip address on the screen (192.168.1.70) then i get booted back to the main mplayer screen. i can connect from other comupters on my network, but can't read from my wii. any tips/guides would be helpful, I've read DyDynamite's but it is for windows only.
    thanks
    Jeff
     
  2. kylsav

    kylsav GBAtemp Regular

    Member
    116
    0
    Feb 26, 2009
    United States
    Earth
    Mplayer CE?

    worked fine for me. maybe try this.


    #Samba share1 (smb1:/)
    ip1=192.168.1.70
    share1=opteron/videos
    user1="enter name here"
    pass1="enter password here"

    if a password or username isn't required leave them blank.

    if that doesn't work which it should try:

    #Samba share1 (smb1:/)
    ip1=192.168.1.70
    share1=videos
    user1="enter name here"
    pass1="enter password here"

    if u have any encryption it may not work try turning it off and see.
     
  3. jeffc313
    OP

    jeffc313 Advanced Member

    Newcomer
    87
    0
    Aug 7, 2007
    United States
    thanks, mplayerCE worked, regular Mplayer did not.
     
  4. jeffc313
    OP

    jeffc313 Advanced Member

    Newcomer
    87
    0
    Aug 7, 2007
    United States
    new problem. WHen streaming a video (a movie encoded in XviD) to MplayerCE after like 10 min or so it cuts back to main menu of mplayerce and I have to reload it. this happens every time.
    thanks again in advance
    Jeff
     
  5. kylsav

    kylsav GBAtemp Regular

    Member
    116
    0
    Feb 26, 2009
    United States
    Earth
    EDIT: seems like there is an issue with XviD files at this time hopefully it will be fixed in a update. But if your having issues with other video files ending too soon try the method below. I list of problem and fixes for Mplayer CE can be found HERE

    Hi sorry for the long wait. I had the same issues with video files. your samba server is timing out thinking the host has left even though it hasn't. what fixed it for me was to go into your samba server and open up smb.conf. in the config type "keepalive = 0" without quotes to turn them off. this should prevent videos from timing out.

    Also the wii's wireless is very sensitive to interference make sure u don't got anything that would be running under the same wireless channel.
     
  6. jeffc313
    OP

    jeffc313 Advanced Member

    Newcomer
    87
    0
    Aug 7, 2007
    United States
    Thanks.

    I'll test it out changing my smb.conf file. If that doesnt fix, I eagerly await the fix.

    Also I have a suggestion about sharing a dvd drive from a PC, which I may try to implement, who should I contact about this. I'm like 80% done with my work on it.
     
  7. kylsav

    kylsav GBAtemp Regular

    Member
    116
    0
    Feb 26, 2009
    United States
    Earth
    I hope it works for ya, haven't tested any XviD files but avi, mp4 and flv files work fine for me.

    and do u mean that u made a program that lets u share a DVD drive? or do have a suggestion about it? I would guess whatever the source program was post a topic there. Like if you used the source from Mplayer CE then post it something about it on the link above. if i made it from scratch that would be up to you.

    May wanna post a separate topic about that question if none answers. Because i have no idea sorry [​IMG]
     
  8. capsgram

    capsgram Newbie

    Newcomer
    1
    0
    Apr 21, 2009
    Canada
    Is there like a total noob instructions for this? like smb to wii? i havent found a thing yet, i got my other PC hooked up through a cat5 cable but i do have a router with a internet connection, but i would really like to smb my wii to my pc.

    thx fur sure