Need help with installing GBA Virtual Console Games

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by JokeTriple, Jan 21, 2016.

  1. JokeTriple
    OP

    JokeTriple Advanced Member

    Newcomer
    71
    4
    Oct 19, 2015
    United States
    I have installed the GBA patch on both my emuNAND and sysNAND and have installed GBA games and Four Swords Anniversary on my SD in emunand and sysnand. After installing both, it still won't launch with games and goes to a black screen. I've uninstalled and reinstalled them numerous times (except for the patch because I don't know how to uninstall that),

    Anybody know what I'm doing wrong? My emuNAND is on 10.4 if that means anything.
     
    Last edited by JokeTriple, Jan 21, 2016
  2. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    4,126
    1,181
    Jan 2, 2009
    Gambia, The
    when you say you put the patch on emunand and sysnand, did you install it to destination nand in both cases?
    and where you really in sysnand? (meaning, did you use fbi through the health and safety app?)
    also, did you install the gba games from sysnand with destination SD and on emunand with destination SD?

    i'm asking because many think, switching destination to nand (in emunand) installs to sysnand, when thats not the case.
     
  3. JokeTriple
    OP

    JokeTriple Advanced Member

    Newcomer
    71
    4
    Oct 19, 2015
    United States
    Yes, I booted sysNAND through Cakes and ran FBI in it. I even have the games on my sysNAND when there's no CFW on it.

    I installed the patch on NAND for both sysNAND and emuNAND and installed the games on SD for both. I even got so desperate after retrying so much that I eventually tried installing the games to the NAND as well, but no dice..

    Could it be possible that I need to install the ambassador certificate for these games? All the games I installed were GBA VC games that are exclusive to the Ambassador program, but I have no clue if they're linked to the thing itself.
     
  4. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    4,126
    1,181
    Jan 2, 2009
    Gambia, The
    the cfw should take care of any need to have that certificate...
    when you installed the patched agb_firm, did you make sure you installed the right one? theres one for 03ds and n3ds.
    and did you first uninstal the original agb_firm file?
     
  5. tomx86

    tomx86 GBAtemp Fan

    Member
    463
    65
    Jun 3, 2015
    Poland
    You need to use rxTools emunand.

    1.Install rxTools, then go to gateway emunand and install the gba vc .cia with DevMenu.3ds.
    2.Enter gateway menu go to gateway sysnand mode (press B, then A, and X to continue).
    3.In gateway sysnand mode install the gba vc .cia with DevMenu.3ds again.
    4.Now you can play the gba vc game, but only in rxTools emunand.

    If you exit the game by pressing the HOME button you will be send to sysnand.
    If you want to uninstall a gba vc .cia, you must remove it by the Data Management, in both emunand and gateway sysnand mode.
     
  6. wormdood

    wormdood pirate booty inspector

    Member
    3,532
    1,493
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    use bbm to install the .cias some (namely four swords) are not gba.cia (gba.cia must be installed to destination sd not nand) but instead dsiware.cia (dsiware needs to be installed to destination nand not sd)
    bbm auto assigns the .cia to destination nand or sd accordingly
     
  7. JokeTriple
    OP

    JokeTriple Advanced Member

    Newcomer
    71
    4
    Oct 19, 2015
    United States
    Is it possible/ to use rxtools when I already have cakes?
     
  8. tomx86

    tomx86 GBAtemp Fan

    Member
    463
    65
    Jun 3, 2015
    Poland
    Try and see, but first make a sysnand and emunand backup. RxTools is like a program you have to lunch it every time you need it and if you turn of the console, it turns off to, I use rxtools only to play gba vc games, but if Gateway finally adds support for gba vc, I won't need it anymore. Good luck!
    I use rxTools 3.0 Alpha 0.
     
    Last edited by tomx86, Jan 21, 2016