[NEED HELP] rxtools cia error on launch

Discussion in '3DS - Flashcards & Custom Firmwares' started by NicholasCullihal, Oct 31, 2015.

  1. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    whenever i launch a game i installed from cia i get a power down as an error ha occured screen
    any help on how to fix this is much appreciated
     
  2. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,226
    1,021
    Jun 13, 2015
    United States
    California
    That happens when your 3DS is in a lower firmware than what the game needs to boot. Ex: Game needs 9.4 but your emunand is 9.0

    Try updating your emunand to 10.2 if you are in o3DS, in New 3DS the maximum emunand is 9.5 so you'll have firmware spoof the cia to work.
     
    Last edited by Tony_93, Oct 31, 2015
  3. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    ok updated emunand to 10.2 same error
     
  4. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    745
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    Are you installing it to Sys or EmuNAND? Is the .cia installer you're using up to date? Does it happen with all cia's or a select few?
     
  5. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    i am installing this all to emunand. the cia installer i am using is the version of fbi that came with rxtools. all cia's, and i am running sysnand 7.1.0-16U
     
  6. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    745
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    Are your CIA's 3DS games or GBA/DSiware? If not then it might be an issue with the .cia file in question, however it does seem strange that all the cia's give an error, did you create the cia or did you download it?
     
  7. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    i downloded the asia81 gba pokemon collection from that iso site and ultimate nes remix eur from the same site.
    is rxtools region-free?
     
  8. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    745
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    CFW is indeed region-free so regions shouldn't matter, if you still want to make sure that the .cia will work on your system then try and find a .cia that has been patched to be region free.
    If your NAND's are linked then there shouldn't be an issue with the GBA games, but if your NAND's are unlinked then the cia's for the GBA games have to be installed to Sys & EmuNAND
     
  9. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    on rxpasta how do i install to sysnand
     
  10. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    745
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    What version of rxTools do you have? Also what entrypoint do you use to boot into your CFW?
     
  11. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    i am using rxpasta (modded rxtools2.6) with the browser entrypoint (7.1.0-xxU)

    — Posts automatically merged - Please don't double post! —

    i will try regular rxtools 2.6 now though and i will report back
     
  12. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    745
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    I suggest using rxTools 3.0 which can be found here: https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/
    I also suggest you ask about your issue there as it is the main hub of rxTools on this site. However I'll tag the OP of the thread here just in case he can help you here, therefore I summon you @samiam144 !
     
  13. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,226
    1,021
    Jun 13, 2015
    United States
    California
    GBA games need to be installed both to sysnand and emunand to be played if theybare unlinked, they won't work otherwise.

    Delete that modified rxTools and use one of the nightlies of you want proper help.
     
  14. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    i am using the one linked to two posts ago but it keeps asking for native_firm
     
  15. samiam144

    samiam144 RĂ©gulier

    Member
    2,872
    936
    Aug 19, 2007
    Canada
    Did you go into the Release/Tools folder from the rxtools 10-02-15 nightly download and run cdn_firm.py, and then put the firmware.bin in the SD:/rxtools/sys folder?
     
  16. NicholasCullihal
    OP

    NicholasCullihal GBAtemp Regular

    Member
    163
    19
    Jul 28, 2012
    yup to no luck
     
  17. justinkb

    justinkb GBAtemp Advanced Fan

    Member
    619
    210
    Oct 7, 2012
    Netherlands
    Don't you need agb_firm patched to play GBA games on rxTools, even in pasta mode?
     
  18. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,226
    1,021
    Jun 13, 2015
    United States
    California
    Not anymore (with nightlies).
     
  19. justinkb

    justinkb GBAtemp Advanced Fan

    Member
    619
    210
    Oct 7, 2012
    Netherlands
    Since what commit exactly?