N3DS 9.2 Problem with EmuNAND & CFG'S

Discussion in '3DS - Homebrew Development and Emulators' started by Cyrriou, Jan 14, 2017.

  1. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    Hey, 2 days ago i bought a N3DS and i changed the firmware from 9.6 to 9.2, it seems like it worked out, but for some reason i cant launch some apps on HBL, like Theme/Menuhacks etc.. work
    but when i try to create a EmuNAND my screen goes red, blink another time red and kick me back to the HBL. I tried to run it with a CF, but i cant get further then blackscreen.
    I tought it would be the SanDisk Ultra Card ( 64GB, Fat 32 ) and i changed it back to the 4GB, but i got the same problem with the 4 GB SD.
    I dont know what to do anymore, maybe someone can help me out.

    Greet Cyrriou
     
    Last edited by Cyrriou, Jan 14, 2017


  2. DrasticGray

    DrasticGray Member

    Newcomer
    39
    8
    Jan 3, 2017
    United States
    Ohio
    why are you using 9.2?
     
  3. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    I tought i needed the 9.2 for a CF on my sysNAND
     
  4. DrasticGray

    DrasticGray Member

    Newcomer
    39
    8
    Jan 3, 2017
    United States
    Ohio
    I don't think you can run menuhax properly on an emunand. You shouldn't need it anyway if you have a launcher in cia format.
     
  5. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    You don't need to downgrade to 9.2 anymore. You should be following 3ds.guide.
     
  6. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    well, i cant even create the Emunand
    Should i update to 11.2 ? maybe it will fix my problem. Well i tried a couple of Guides and the most of the tools i would need to acces the CF send me right to the black screen.
     
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    You have a partial downgrade, will probably be easiest to update to 11.2 and start the guide from the beginning.
     
  8. DrasticGray

    DrasticGray Member

    Newcomer
    39
    8
    Jan 3, 2017
    United States
    Ohio
    Do you have a NAND backup from before you downgraded?
     
  9. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    If he thought he had to downgrade then I'm assuming he didn't know he had arm9 access on 9.6.
     
  10. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    Yeah i got NAND saved.
    I actually didint know about Arm9 :/.

    What should i do now ? Update to 11.2 and Downgrade or should i stay on it and try to get Arm9 working on it ?
     
  11. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can probably just start the guide from where you are. If it doesn't work (maybe the partial downgrade affects it) then update to 11.2 and try from there. Restoring the backup probably won't help too much - if you can use Decrypt9 to restore the backup you can also probably use it for the guide.
     
  12. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    Well, i actually have the same problem with Decrypt9, screen gets red and blinks 1 time and it kicks me back to HBL. So imma not actually sure what am i suppose to do now.
     
  13. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    Are you following the guide? You have to run fasthax to get arm9 access then you can use Decrypt9. Otherwise Decrypt9 won't work over (a full) 9.2 firmware.

    Start at 3ds.guide/get-started
     
  14. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    "Fasthax" work but "Safehax" dont:

    Initializing SD card... failed
    Initialization : failed!
     
  15. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    *safehax for arm9. But decrypt9.3dsx works without it on 9.0-9.2
     
  16. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    Well, i still have the issue with the Red Screen if i run decrypt9 on my N3DS.
     
  17. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    I was just correcting that post.

    If you have hbl set up correctly: https://3ds.guide/homebrew-launcher-(soundhax)

    And add the latest decrypt9WIP 3dsx/smdh files to 3ds and it still doesn't load then its probably a partial downgrade as stated above, you could try a different otherapp payload, or update to 11.2 as above or if you can redo the downgrade [but I think you need d9 for that]
     
  18. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    ok thanks, so updating to 11.2 is the only way, should i downgrade again or stay with 11.2 ?
    And which Methode should i use, CFW or Arm9 ? Sorry, imma not up to date right now..
     
  19. Quantumcat

    Quantumcat Dead and alive

    Member
    11,117
    5,953
    Nov 23, 2014
    Australia
    Canberra, Australia
    Follow the guide, you don't need to worry about what to do if you just do what it says. And yeah updating to 11.2 first is your best bet so you don't have to worry about having a partial downgrade.
     
    HyperT likes this.
  20. Cyrriou
    OP

    Cyrriou Member

    Newcomer
    20
    1
    Nov 25, 2014
    Gambia, The
    Well i got still the same issue with Safehax on 11.2:

    Initializing SD card... failed
    Initialization : failed!

    Maybe my SD is fcked up ?