1. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    Hi, I need help, because my switch won't turn on anymore.
    I used the mod SX Pro switch with version 1.2 (it was the last when the fact happened), I thought it was a battery problem or battery charger, since when I tried to turn it on it gave me a symbol of low battery, but didn't tun on, so I sent the console in repair to the nintendo, since it was still under warranty, but they have me postponed with the reason: "disposizioni nintendo account bannato"(it's in italian because i'm italian and i don't know how they send this messages in english), when I used this mod I had prepared to ban , but I did not expect this, then I sent the console to some people who own a site called dedo shop, they changed the charging plug because it was broken, they told me that the console now is charging, can anyone help me?
    Thanks in advance.
     
  2. annson24

    annson24 The Patient One
    Member

    Joined:
    May 5, 2016
    Messages:
    1,185
    Country:
    Philippines
    Please do elaborate, your switch wasn't turning on because (according to this dedo shop) the charging port is broken. Since you said they fixed it already and now the console is charging, what seems to be the problem?
     
  3. antiNT

    antiNT a.k.a Johnny El Pollo Loco
    Member

    Joined:
    Sep 14, 2015
    Messages:
    573
    Country:
    Qatar
    Is the console charging now ? What happens when you try to power it on ? Can you enter RCM ?
     
  4. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    I think that the problem is that the console isn't charging, if i insert the sx pro dongle the led isn't turning on and the joycons are discharged.
    I can't enter the rcm mode.
     
  5. antiNT

    antiNT a.k.a Johnny El Pollo Loco
    Member

    Joined:
    Sep 14, 2015
    Messages:
    573
    Country:
    Qatar
    Attach the JoyCons to the console and let it charge (preferably with the official Nintendo Charger) for 24h then tell us if the JoyCons are charged after this.
     
  6. antiNT

    antiNT a.k.a Johnny El Pollo Loco
    Member

    Joined:
    Sep 14, 2015
    Messages:
    573
    Country:
    Qatar
    For how long has the console been charging ?
     
  7. antiNT
    This message by antiNT has been removed from public view by Quantumcat, Nov 12, 2018, Reason: Dupe.
    Oct 7, 2018
  8. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    it's days that the joy-con are attached to the console.

    — Posts automatically merged - Please don't double post! —

    For about 48 hours.
     
    Last edited by nickrock04, Oct 7, 2018
  9. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    i tried also to plug my switch to the pc with the jig, but tegraRCMgui doesn't see it.
     
  10. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
  11. annson24

    annson24 The Patient One
    Member

    Joined:
    May 5, 2016
    Messages:
    1,185
    Country:
    Philippines
    How sure are you that the charging port is fixed?
     
  12. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    I'm not sure.
     
    Last edited by nickrock04, Oct 7, 2018
  13. ken28

    ken28 GBAtemp Maniac
    Member

    Joined:
    Oct 21, 2010
    Messages:
    1,177
    Country:
    Germany
    no body asked the most important question?
    Did you install autorcm?
     
  14. mattytrog

    mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Bq24193 charging controller.

    Seen a few now that have gone faulty from having a damaged (even replaced) usb port.

    The damaged port is obviously causing damage to the bq24193. After replacement it USB port, the damaged bq24193 remains, as well as possibly other stuff. I'm half way through one at the moment for @Canna . Waiting for parts from the states...
     
    Last edited by mattytrog, Oct 7, 2018
  15. Straw

    Straw Member
    Newcomer

    Joined:
    Apr 14, 2018
    Messages:
    49
    Country:
    Philippines
    disposizioni nintendo account bannato = nintendo account banned by google translate

    I think you installed rcm before but that dedo shop broken your charging port
     
  16. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    Yes, but i uninstalled It in August, After about 2 days afert the installation

    — Posts automatically merged - Please don't double post! —

    What's that bq24193 ?
     
  17. bundat

    bundat ¿
    Member

    Joined:
    Jul 25, 2018
    Messages:
    455
    Country:
    Antarctica
  18. jahrs

    jahrs GBAtemp Regular
    Member

    Joined:
    Sep 14, 2009
    Messages:
    284
    Country:
    United States
    this happens to me from time to time its usually that the dongle has lost charge for me and the switch is stuck in autorcm mode. so i usually just use an external charger on the dongle and plug it in and boom it works. i also do a hard reboot/turnoff first to make sure it didnt freezr and is stuck on a black screen
     
  19. nickrock04

    OP nickrock04 Member
    Newcomer

    Joined:
    Mar 4, 2018
    Messages:
    13
    Country:
    Italy
    I tried, but It doesen't work.
     
  20. mattytrog

    mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    People have said the M92T36 could be fully too. I'm doubting this as the internal core (VCc-in) pin 5 is probably running well it seems with a stable voltage. Other things? PMIC on underside of board, or the multiplexer as I call it just above the USB port on the underside.

    Doubtful the buck regulators are faulty on the front of the board as it is just the charging that is faulty.
     
  21. jahrs

    jahrs GBAtemp Regular
    Member

    Joined:
    Sep 14, 2009
    Messages:
    284
    Country:
    United States
    Ah then must be a different issue. ill just tip my hat out of the topic cause i have no experience with any other switch issues.
     
  22. ken28

    ken28 GBAtemp Maniac
    Member

    Joined:
    Oct 21, 2010
    Messages:
    1,177
    Country:
    Germany
    tried to just leave it plugged in for a while? while unlikely it could be that autprcm is still active and discharged your switch to the point where it cant turn on anymore.
     
  23. mattytrog

    mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Fingers crossed thats all it is.

    But I`m doubting it.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - nintendo, switch,