Metroid Prime Bilogy - error 001?!

Discussion in 'Wii - Backup Loaders' started by Litrydow, Mar 30, 2010.

Mar 30, 2010
  1. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
    Hello, people. [​IMG]
    Please, read the whole post before you already go typing "google it", ok? [​IMG]

    I downloaded Metroid Prime Bilogy (the DVD5 version, without the 3rd game) some months ago, but just this week I decided to play it. I have an unknown modchip (probably a really old version of Wiinja), so the most of times I use Gamma Loader to load games instead of using the modchip. Metroid Prime Bilogy starts okay with it, but when I choose one of the 2 games to load, I get the 001 error. [​IMG]

    That's strange, since the other games with this stupid protection run very well on Gamma Loader (even Wii Sports Resort), so I really don't know what to do. [​IMG]

    So I'd like to know how to solve that, specially a way to do it without having to download and burn the game again. If there's no other way at all, is it possible to remove the 001 from main.dol using the Generic Patcher?

    Thanks. [​IMG]
     
  2. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    What's Metroid Prime Bilogy?
    To answer your question, load it through a not-outdated loader like Neogamma Loader R8 final.
     
  3. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    [​IMG]

    And most recent cIOSs should have proper 001 fix
     
  4. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I explain it over and over and nobody understands and/or spreads that info...

    The cIOS revision 14+ detect the disc type, SL or DL and restrict the loading to that. That's the 001 fix in the newer cIOS. But some old modchips interfere with that and the cIOS can't detect the disc type ==> 001 error. The cIOS rev8 - 13b use a main.dol patch to fix 001 error, but that won't work for new 001 games, because the code for 001 error has changed but not the concept for it.

    Bad modchip + new 001 game = most likely you need cIOSrev7(yes 7)

    And 001 error is only cIOS related, the loader (should) have nothing to do with that.
     
  5. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
    Sorry for taking so long to answer, I was traveling. [​IMG]

    The cIOS I'm using is the 14, and the NeoGamma is R8.

    Are you saying I should return the revision 14 to 7? [​IMG] That would make it work?

    And you say the code has changed for the new games, but I can play Wii Sports Resort without any errors. So why would Metroid not work? It was released only 1 month later... Also, shouldn't the error appear as soon as I loaded the game? Why do I get it only after I choose between Metroid 1 and 2? I really don't get all that... [​IMG]
     
  6. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    When you choose a game inside the game, it launches another .dol and that one checks for 001 error directly after it was booted. cIOSrev7 only works for SL discs, but in exchange it's compatible with all different 001 errors, modchip or not doesn't matter. So if cIOSrev13a doesn't help, you really may need rev7.
     
  7. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
    So all I have to do is download the rev7, put on the SD card and install it? Won't my Wii brick or loose some functions offered by rev14?
     
  8. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
    Anyone? [​IMG]
     
  9. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
  10. 9th_Sage

    Member 9th_Sage GBAtemp Maniac

    Joined:
    Apr 30, 2008
    Messages:
    1,481
    Country:
    United States
    To quote Wiipower:

    "cIOSrev7 only works for SL discs, but in exchange it's compatible with all different 001 errors, modchip or not doesn't matter."

    So it shouldn't work with dual layer discs, but besides that it may be worth a try if things aren't working for you.
     
  11. Litrydow
    OP

    Newcomer Litrydow Member

    Joined:
    Mar 17, 2008
    Messages:
    22
    Country:
    Brazil
    Well, I guess I'll have to try it then. But one question remains:
    Won't my Wii brick? I've heard that if you try to install an older version of the cIOS, the Wii brick
     
  12. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    You can't brick your Wii by messing with IOS249, which is where the cIOS installs
     

Share This Page