Messed up while downgrading MSET

Discussion in '3DS - Flashcards & Custom Firmwares' started by maximantus, Jan 27, 2016.

  1. maximantus
    OP

    maximantus Newbie

    Newcomer
    6
    0
    Jan 27, 2016
    Brazil
    Hi guys, i have an o3ds and i'm facing some problems.
    To downgrade the mset it's necessary to put msetdg.bin (according to 3ds region - this I did right) and code.bin in the root folder then go to rxtools and select downgrade mset. The thing is, I forgot to put code.bin and put only msetdg.bin, then selected the downgrade mset option in rxtools. The downgrade process showed no errors, but my firmware version is still 9.2 and the emunand firmware is rx3d 9.2. I guess this occured because I forgot to put the code.bin in the root folder.

    When I tried doing the trick to access rx through the nds profile, my system crashed (because it's 9.2 I think). The only way to access rxtools now is through browser.

    Now I tried doing the downgrade process again with code.bin inside root folder but the rxtools says that my version is already exploitable and doesn't do the downgrade.

    Is there a solution for that?
    Thanks and sorry for bad english.

    *I didn't do a backup of my sysnand or anything like that.
     
  2. Drew That Gamer

    Drew That Gamer weeb

    Member
    565
    134
    Dec 29, 2015
    United States
    Arlington, VA
    Use SafeSysUpdater to update your system using from 9.2.0 to 9.2.0. This will reset your MSET so your can redowngrade it.
     
    maximantus likes this.
  3. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    Or a easier way is to download and re install back your mset 9.2 , Youcan use your own (always make a backup before downgrade) or find it online somewhere
     
    maximantus likes this.
  4. Drew That Gamer

    Drew That Gamer weeb

    Member
    565
    134
    Dec 29, 2015
    United States
    Arlington, VA
    True, but what would he use to update it?
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,804
    4,991
    Mar 17, 2010
    Norway
    Alola
    Downgrading mset does not change your firmware version. I don't know where you got this code.bin from, I don't think it's needed for downgrading mset. Have you tried launching rxTools with the DS Profile exploit? In all likelihood it'll work just fine, as long as you have the mset ROP installed.

    Edit: Though, I am not sure why you want to downgrade your mset. It's not really useful anymore now that we have menuhax. Autobooting CFW is much nicer.
     
    Last edited by The Real Jdbye, Jan 27, 2016
    maximantus likes this.
  6. Drew That Gamer

    Drew That Gamer weeb

    Member
    565
    134
    Dec 29, 2015
    United States
    Arlington, VA
    Yeah, I was wondering about that code.bin file. Shouldn't it be in Rxtools/sys? You could always boot RxTools through menuhax. I do.
     
  7. maximantus
    OP

    maximantus Newbie

    Newcomer
    6
    0
    Jan 27, 2016
    Brazil
    I tried lauching rxTools with the DS Profile exploit and it crashes. I think it's because it requires the 4.x firmware and I have the 9.2.
    I didn't know about the menuhax trick, I'll try it.


    Thanks a lot for the help all of you guys! :)
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,804
    4,991
    Mar 17, 2010
    Norway
    Alola
    If it crashes, that means your mset is downgraded correctly. If you were still on 9.x mset nothing would happen.
     
  9. maximantus
    OP

    maximantus Newbie

    Newcomer
    6
    0
    Jan 27, 2016
    Brazil
    Hmm, interesting. Any ideas on why the profile trick causes crash then? I used the correct version of mset (USA 4.x).
     
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,804
    4,991
    Mar 17, 2010
    Norway
    Alola
    I'm not sure. Did you use rxinstaller.bin and this link to install the mset ROP?
    http://dukesrg.github.io/?mset/rxinstaller.bin
    Or did you use the .nds? I think the .nds is only valid for older rxTools versions.

    Edit: It appears it will install the 6.x ROP if you are on 6.x+ so you may need the 6.x mset.
     
    Last edited by The Real Jdbye, Jan 27, 2016
  11. maximantus
    OP

    maximantus Newbie

    Newcomer
    6
    0
    Jan 27, 2016
    Brazil
    Yeah, I used this link at first. But now I remembered one thing. After I opened this link in 3ds browser (that installs the trick for 4.x), I thought it woudn't work because my 3ds version was still 9.2. Then I opened another link (http://dukesrg.no-ip.org/3ds/rop/?LoadCode.dat) that installs the trick for 5.x, 6.x, 9.x, etc.
    Then I did the profile trick and it crashed. So I tried using the first link (http://dukesrg.no-ip.org/3ds/rop/?LoadCode4.dat&rxinstaller.bin) again, but it didn't seem to fix.
     
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,804
    4,991
    Mar 17, 2010
    Norway
    Alola
    It appears it will install the 6.x ROP if you are on 6.x+ so you may need the 6.x mset.
     
  13. maximantus
    OP

    maximantus Newbie

    Newcomer
    6
    0
    Jan 27, 2016
    Brazil
    Hmm, got it. Thanks for the help.
    I'll try the menuhax thing though, seems a lot more simple.
     
  14. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    So you have the rxtools.dat in the sd card? Mset loads that , not /sys/ folder