Kernel 2.0 question

Discussion in 'EZ-Flash' started by Zowayix, Jul 1, 2009.

Jul 1, 2009

Kernel 2.0 question by Zowayix at 7:07 PM (824 Views / 0 Likes) 5 replies

  1. Zowayix
    OP

    Member Zowayix GBAtemp Regular

    Joined:
    Dec 27, 2008
    Messages:
    149
    Country:
    United States
    I didn't find out about a new 2.0 kernel for the EZ Flash until about now, so:

    What are the main differences between 1.90 and 2.0 kernels?
     
  2. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,716
    Country:
    United Kingdom
    2.00 is still very much in development (lacking features and the odd bug cropping up) so be warned before diving in.

    It is mainly speed though, this kernel is far faster than anything that came before it. There are also a bunch of tweaks to the layout (nothing major) and the cheats/soft reset side of things has been largely rewritten (again bugs).

    My opinion: if you want games and basic homebrew and do not mind the odd cheat not working then dive right in. If you do mind then stick to the 1.86 or 1.9x line.
    Be warned that you may have to do some patching of your own as some fixes for newer games have not been backported to the 1.86 or 1.9x line (1.86 does not even have a proper GTA patch).
     
  3. triften

    Newcomer triften Advanced Member

    Joined:
    May 12, 2008
    Messages:
    72
    Country:
    United States
    If you have any interest in loading GBA roms natively, stay clear of the 2.0 kernel. It doesn't recognize them the way 1.90beta11 does...
     
  4. Zowayix
    OP

    Member Zowayix GBAtemp Regular

    Joined:
    Dec 27, 2008
    Messages:
    149
    Country:
    United States
    What does "loading GBA roms natively" mean?
     
  5. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,716
    Country:
    United Kingdom
    The EZ5 has support for the 3 in 1 built into the firmware (other cards recently gained similar abilities as well), triften is quite rightly suggesting that if you want to try and use 2.0RC3 or below to manage a 3 in 1 then expect serious issues with the 2.0 line compared to earlier kernel versions.
    You can however use one of the tools like GBA ExpLoader instead.
     
  6. Zowayix
    OP

    Member Zowayix GBAtemp Regular

    Joined:
    Dec 27, 2008
    Messages:
    149
    Country:
    United States
    I don't have an EZFlash 3in1 now, but I might get one soon.

    So if I'm using k2.0 now, can I switch back to k1.90 later, without problems?
     

Share This Page