jamais vu - a 1.0.0 TrustZone code execution exploit for the Nintendo Switch

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by SciresM, Jan 20, 2018.

  1. Waze0613

    Waze0613 Member

    Newcomer
    5
    Feb 5, 2018
    France
    Thus SciresM is planning to release code for 1.0.0 but not (yet ?) for upper firmwares ?
    Otherwise why advising people to stay on 1.0.0 ?
     
  2. Lower is always better.
     
  3. Sephirosu

    Sephirosu GBAtemp Regular

    Member
    4
    Jan 28, 2015
    Boca Raton, Florida
    Exactly, not yet because of what Mech said a post ago. Earlier versions will get it first. Later versions will get it later specially because a vulnerability thats used for versions higher than 1.0 hasn't been patched on newer versions.

    Unless you want to wait longer for 2.0's version, like me, or even longer for say 3.0.2 which is the latest known exploitable version why would you want to update?
     
    Waze0613 likes this.
  4. Waze0613

    Waze0613 Member

    Newcomer
    5
    Feb 5, 2018
    France
    Ok, got it, thanks.
     
  5. FliP0x

    FliP0x GBAtemp Regular

    Member
    3
    Aug 6, 2016
    Croatia
    SciresM just answered in another post that the exploit that allows TrustZone execution in 3.x is still present in 4.x, but cannot be triggered (yet). This should also make it clear for some why lower firmwares will get releases sooner. Just because they are hacked, it doesn't mean the hacks and exploits are consumer friendly yet.
     
  6. Waze0613

    Waze0613 Member

    Newcomer
    5
    Feb 5, 2018
    France
    Besides, SciresM said that he will release stuff only once CFW is out.
    Does it mean that he's waiting for Xecuter CFW ? Is anyone else working on a CFW currently ?
     
  7. FliP0x

    FliP0x GBAtemp Regular

    Member
    3
    Aug 6, 2016
    Croatia
    SciresM himself is working on a CFW.

    Source
     
    KiiWii and Waze0613 like this.
  8. Rauliki

    Rauliki GBAtemp Regular

    Member
    2
    Oct 24, 2016
    Poland
    If you read what the guy I commented wrote, he meant to upgrade to 2.3 or 3.0 after CFW for this firmware versions were available.
     
  9. tivu100

    tivu100 GBAtemp Addict

    Member
    6
    Jun 6, 2015
    United States
    I am confused? Was SciresM not saying 4.x still hae the same trustzone vulnerability, which is the the core of CFW? The problem with 4.x is the access to trustzone is complicated in laymen's term, right?
     
  10. Sephirosu

    Sephirosu GBAtemp Regular

    Member
    4
    Jan 28, 2015
    Boca Raton, Florida
    The entry point was patched. 4.x still Hass the same vulnerability yes but you can't use it if you can't access it. The Memory control module was patched iirc
     
    tivu100 likes this.
Loading...