I've ruined everything

Discussion in 'Wii - Backup Loaders' started by LieutenantPie, Jun 7, 2014.

  1. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    So I tried changing region settings on my wii so I could download a thing from the PAL shop channel and it worked totally fine, I switched everything back and I think something went wrong. I use USB Loader GX and have a 500GB external hard drive with one NTFS partition and a smaller FAT32 partition for the emuNAND. None of the VC/WiiWare games I put on that partition boot up anymore. They show up in USB Loader GX and show the channel preview and banner and everything but display a generic error when I launch them. Gamecube games don't seem to work either when I put the disc in and launch it from the disc channel.

    I don't think it's something wrong with the IOSs because it applies to all WiiWare, VC, and even GCN games, so it would have to be several of them with the same problem. I suppose it's not out of the question but then again I'm kind of dumb so

    In summary,
    • genuine, retail GCN games don't boot up anymore, but the disc channel does recognize it as a GCN game and allow me to press start
    • I've had that issue before I changed the region settings and stuff
    • everything worked fine in USB Loader GX before I changed the console/area/shop region to UK and then back to US, but now that I've changed it back it's not fine
    • .wbfs files still launch from USB Loader GX but all VC and WiiWare games don't
    • I tried updating/patching/replacing every IOS and that didn't work
    • the only other advice I've gotten was this
    • I tried using ModMii to replace everything but I don't know what else to do and this is becoming frustrating
    I can provide any additional information you need, any help would be greatly appreciated
     
  2. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    If you have DIOS MIOS installed, normal Gamecube games may not boot through the disc channel - you'll have to use DIOS MIOS BOOTER or another booting solution. Did you ever install that? USB Loader GX config files are on the SD card, delete those and you should be able to start fresh on a new, default config. Before you touch any IOS'es, post a SysCheck result so that we may see what's under the hood - randomly patching stuff can only make things worse. First and foremost though, don't panic - we're all here to help so take a breather and brew yourself a cup of tea, this might take a while. ;)
     
    LieutenantPie likes this.
  3. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    I totally forgot I had installed DIOS MIOS, I just uninstalled it and replaced it and now GCN games work, thanks for reminding me

    Also for some reason resetting USB Loader GX never really occurred to me as a thing I could do, I deleted the configuration files and it seems that everything works now with the exception of Castlevania The Adventure ReBirth, but if I remember correctly that's a problem with USB Loader GX

    Thank you very much for helping!
     
    Foxi4 likes this.
  4. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    I'm glad that I could help you resolve your issues. See? That wasn't so bad, was it? You didn't ruin anything. :P
     
  5. Plstic

    Plstic Guru Meditation Error

    Member
    680
    288
    Apr 21, 2010
    United States
    Milwaukee WI
    That's weird, I can boot GC discs fine with Dios Mios installed.
     
  6. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    For some reason it always invariably borks out for me as well ever since I've installed the latest DIOS MIOS revision - discs boot fine from DIOS MIOS Booter, but never from the Disc Channel. Seeing that Gamecube loading is managed solely by MIOS this has to have something to do with Dios Mios, I even verified that by re-installing the original MIOS to check. *Shrugs* Not that it bothers me, I have a Gamecube for all my Gamecube needs. :yay:
     
  7. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    Actually wait I lied sorry, virtual console games just give me a black screen. Just in case it's necessary, I'll post the syscheck results
    Code:
    sysCheck v1.6.2 by Erik Spyder
     
    Region: NTSC-U
    The system menu v513 is running under IOS58 (rev 6176)
    Hollywood v0x11
    Console ID: 113758188
    Boot2 v4
    Found 139 titles
    Found 48 IOS on this console
    Found 4 IOS Stubs on this console
     
  8. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    That's not the complete report - we'll need the list of all the installed IOS'es. It'd also be nice if you tested a few Virtual Console games to verify that you're not using bad dumps.
     
  9. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    That was all that showed up in the file, the virtual console games worked like 2 weeks ago and now they don't, same with the virtual console games. I tested everything in Dolphin before I moved them to the wii, and it all worked. Also apparently I was wrong and a lot of WiiWare games are still not working, I guess I got a bit too excited.

    Mega Man 9 and 10 now work again after doing the things you suggested, but games like Dr. Mario, Frogger Returns, and a vast majority of the games on the emuNAND still show that error upon launch.

    Here are some screenshots from Wii Mod showing the IOSs I have installed and any other information I thought would be useful

    Untitled 1.png Untitled 2.png Untitled 3.png Untitled 4.png
     
  10. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    SysCheck should save a report file to your SD card in the form of a .cvs file - they're openable in Notepad, Wordpad and whatnot.
     
  11. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    What I uploaded in that post actually was the .cvs file, that's all that was in it.
     
  12. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,671
    21,708
    Sep 13, 2009
    Poland
    Gaming Grotto
    Huh...

    http://gbatemp.net/threads/posting-a-system-check.300279/

    Try following this guide and using this version of SysCheck, yours is grossly incomplete for whatever reason - it doesn't list the actual IOS'es, just their total number. Your screen caps are appreciated but... y'know - hard to make judgements upon. :P
     
  13. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,346
    535
    Nov 6, 2002
    United Kingdom
    Wigan, land of the Pies
    You're running Wiiware/VC from an emunand by the sounds of it? (And since Castlevania Rebirth doesn't work it's a bog standard emunand?)
    By changing your region back and forth your real nand will have changed and so your emunand won't work (I'm not 100% sure of this but it's likely): I suspect it can be fixed using modmii somehow - can't help there as you haven't posted enough info like Foxi says, but the simplest (though most time consuming) fix would be to create a fresh emunand and reinstall your wiiware/VC on that. Should then work! ;)
     
  14. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,228
    2,864
    Jul 23, 2012
    United States
    Octo Canyon
    I think you need to reinstall your proper region's system menu via wad, then whatever your emunand is to match.
     
  15. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    EmuNAND from other region should work with USBLoaderGX. (but I didn't test it)
    Though, as USBLoaderGX is using cIOS redirection maybe there are incompatibility with loaded files from realNAND and EmuNAND. (maybe incorrect keys due to region change/reset keys?)

    cIOS method: Loader run on RealNAND > load cIOS from realNAND > redirect NAND path to SD/USB in real time, but Wii is still running in RealNAND mode (it's a hybrid/incomplete Emulation).
    neek2o method: Loader run on RealNAND > loader reboots to neek environment > neek Launches channel on EmuNAND as if it was the real Wii. Only EmuNAND is loaded, no RealNAND access is possible anymore.

    when using cIOS method, some games don't work (like Castlevania), because it's still trying to access realNAND files. (Maybe because of internal selective path feature in cIOS? when using emuNAND the paths with @ are not redirected)
    If you install games on both RealNAND and emuNAND, it works.


    What you can try is :
    USBLoaderGX > Features > Nand Dump > Syscheck only
    it will copy your current console settings (wiimote synch, etc.) to the emuNAND path.

    If it doesn't help, you can try to backup your savegames (with ShowMiiWads), recreate your EmuNAND using your current Wii NAND, restore savegames.



    for Gamecube games:
    If you have DIOS MIOS installed, you need a mountable FAT32 partition inserted in USB to boot the retail disc.
    If you have DIOS MIOS Lite installed, you need an SD card inserted.
    DM tries to mount the external device before reading the disc, so you need a compatible device connected to your Wii.
     
  16. LieutenantPie
    OP

    LieutenantPie Member

    Newcomer
    35
    5
    Nov 20, 2009
    United States
    Sorry for not responding sooner, it was finals week and stuff. I tried what you said and it didn't work, the syscheck app that Foxi4 suggested did work, here's the results
    Warning: Spoilers inside!