iTouchDS 2.0 firmware released.

Discussion in 'User Submitted News' started by g6team, Aug 20, 2008.

Aug 20, 2008

iTouchDS 2.0 firmware released. by g6team at 5:30 AM (2,072 Views / 0 Likes) 6 replies

  1. g6team
    OP

    Member g6team GBAtemp Advanced Fan

    Joined:
    Aug 30, 2007
    Messages:
    545
    Country:
    Hong Kong
    Change Log for 2.0: modified (update up to 2573)

    1. A Clock has been implemented on the top left corner of the bottom screen.

    2. Scrollbar has been added for better navigation.

    3. State restoration. Now applies to all the menu.

    4. Homebrews can now be run through iGame instead of recognizing it as a game.

    5. Default path for the cheat file has been fixed.

    6. Improve the game compatibility.

    7. Prompt before running a game has been removed.

    8. Fixed the saving problem of 2532.

    9. Added reset function for 2529,2548,2559,2565,2560,2561,1946(Chinese version).

    10.Fixed the hang-up problem when 'cheat Enable' is selected & no cheat item is selected

    11.Added reset function for 2482,2487,2492,2496,2506,2512,2524,2526,2527.



    http://www.simplepluseasy.com/
     
  2. Opium

    Former Staff Opium PogoShell it to me ™

    Joined:
    Dec 22, 2002
    Messages:
    8,185
    Location:
    Australia
    Country:
    Australia
    That is a very good update. The lack of a scrollbar was one of my main concerns, pluse igame being fixed up as well as the cheat file path.

    I'll give it a whirl and revisit my iTouchDS review if I think there's a big change.
     
  3. lilkerv90210

    lilkerv90210 Newbie

    ive been waiting for this
     
  4. Maikel Steneker

    Member Maikel Steneker M3 Fanboy

    Joined:
    May 16, 2007
    Messages:
    3,396
    Country:
    Netherlands
    That looks like a nice update! Now give us M3Sakura [​IMG]
     
  5. TaMs

    Member TaMs Randomizer

    Joined:
    Nov 15, 2006
    Messages:
    1,126
    Country:
    Finland
    Thanks for the info. Just received my itouch ds2 mins ago and i was wondering where could i get firmware [​IMG]
     
  6. TheWingless

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
    Wow! They're actually updating the firmware...AGAIN! Amazing... I'll have to wait for the triple loader version for my M3Real or for my iTouch to come here first so I can try it though...
     
  7. hiperbou

    Newcomer hiperbou Newbie

    Joined:
    Aug 12, 2008
    Messages:
    2
    Country:
    Spain
    Hello,
    My homebrew just freezes with this update.
    I'm using the SDL_mixer port, and it freezes at calling Mix_OpenAudio(SOUND_FREQ,MIX_DEFAULT_FORMAT, 2,1024*SOUND_FREQ/22050)
    It worked (and works) with 1.9 version, and also on all the other cards that I've tried.
    ¿This may be some kind of bug with this release?
     

Share This Page