Issue Updating from A9LH to B9S

Discussion in '3DS - Flashcards & Custom Firmwares' started by LuckySteves, Jul 29, 2017.

  1. LuckySteves
    OP

    LuckySteves Advanced Member

    Newcomer
    51
    6
    Jan 13, 2011
    Canada
    I'm having trouble making it past section one of the guide (https://3ds.guide/a9lh-to-b9s)
    Holding start on boot just boots into the normal menu, instead of the expected booting into the Luma3DS chainloader menu.

    Holding select on boot shows me the luma menu with version 7.1, and trying to update with luma updater "succeeds" but nothing actually changes. I'm on Sys 11.4.0-37U.

    I can access the homebrew launcher.

    Here's an image of my SD card, http://imgur.com/lWKqS0d

    I tried launching udsploit, but it always fails with a red screen and a freeze, last showing:
    0x00005544 0x00000FF0 (... a bunch of 0s)
    udsploit: IDS_Unbind
    C920181A

    Any suggestions would be appreciated.
     
  2. Pyra

    Pyra GBAtemp Fan

    Member
    306
    154
    May 7, 2017
    United States
    Ohio, USA
    udsploit was patched in 11.4 iirc

    from what you're saying/the pic of the root of the sd card, everything seems to have installed correctly

    do you have any ".firm" payloads in the /luma/payloads folder?

    Sent from my SM-G360T using Tapatalk
     
  3. LuckySteves
    OP

    LuckySteves Advanced Member

    Newcomer
    51
    6
    Jan 13, 2011
    Canada
  4. Pyra

    Pyra GBAtemp Fan

    Member
    306
    154
    May 7, 2017
    United States
    Ohio, USA
    hm, that's odd...

    try updating luma to the latest version

    Sent from my SM-G360T using Tapatalk
     
  5. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    663
    208
    May 27, 2011
    Canada
    Where exactly is it asking to run udsploit? I dont see it anywhere in the guide linked for updating a9lh to b9s
     
    Ricken likes this.
  6. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    Your post wasn't entirely clear, so I have a couple of questions:
    1. When you boot your 3DS, does it boot successfully?
    2. When you hold Select when turning the 3DS on, does it actually say Luma3DS 7.1 at the top of the configuration settings?
    If the answer is "yes" to both of these questions, then you already have an old version of B9S installed, which is why the .bin payload won't work. You should follow this guide instead to update B9S to 1.2 and Luma3DS to 8.1: https://3ds.guide/updating-b9s
     
    Last edited by Lacius, Jul 29, 2017
    Quantumcat, Pyra and Ricken like this.
  7. LuckySteves
    OP

    LuckySteves Advanced Member

    Newcomer
    51
    6
    Jan 13, 2011
    Canada
    Nowhere, udsploit was from my own messing around, hoping to find a way to launch SafeB9SInstaller.


    1. Yes
    2. Yes

    The steps seem to end up being the same, at least up until where I'm stuck. At the beginning of section 2, "Reboot holding (Start) during boot to launch the Luma3DS chainloader menu" just boots into the regular home menu.
     
  8. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    The steps aren't the same. You need to make sure you have the proper files in your payloads folder. Specifically, you need SafeB9SInstaller.firm, not SafeB9SInstaller.bin.
     
    Quantumcat likes this.
  9. LuckySteves
    OP

    LuckySteves Advanced Member

    Newcomer
    51
    6
    Jan 13, 2011
    Canada
    Mmhmm, and I do have the .firm file on my SD, located in /luma/payloads.
    http://imgur.com/QvITkSk

    Should I remove the .bin file?
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    Removing the .bin file won't help. Here's what I suggest as a matter of troubleshooting:
    1. Delete boot.firm and boot.firm.bak from the root of your SD card.
    2. Download Luma3DS 7.1 and put the boot.firm onto the root of your SD card.
    Edit: I just realized the date stamp on your boot.firm file is dated after the release of 8.1, which means your 3DS is loading the old 7.1 boot.firm on your CTRNAND. Following the steps above will fix your problem, because it needs to load the 7.1 boot.firm on your SD card to be able to load SD payloads.
     
    Last edited by Lacius, Jul 29, 2017
    LuckySteves and Quantumcat like this.
  11. LuckySteves
    OP

    LuckySteves Advanced Member

    Newcomer
    51
    6
    Jan 13, 2011
    Canada
    Aha, that did solve my problem! I was able to launch B9SInstaller after these. Thanks for the help, now back to the guide :)
     
    Lacius likes this.
  12. shanefromoz

    shanefromoz GBAtemp Advanced Fan

    Member
    980
    35
    Jun 18, 2007
    Try re installing Luma 7.1 manually.
    I have the same issue and after doing that it allowed me to update to v8xxxxx
     
  13. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    We already discovered the problem and fixed it.
     
    Zidapi likes this.
  14. shanefromoz

    shanefromoz GBAtemp Advanced Fan

    Member
    980
    35
    Jun 18, 2007
    Why dont you post how you did it here so if anyone else has the same issue they can then see how to fix it.
     
  15. Lacius

    Lacius GBAtemp Guru

    Member
    6,123
    2,450
    May 11, 2008
    United States
    We did post how we did it.
     
    Zidapi and HugaTheFox like this.