Hardware Is this a software or hardware issue?

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Hey there guys, I’m having trouble fixing this switch that was working fine a week ago. It is hacked and I was using it exclusively in emummc to play games I downloaded from tinfoil. The switch only turns on when I hold the power button for several seconds and turns off when the charging cable is unplugged. When the switch is on and I plug the charging cable in the charging notification appears on the top left and next to the battery but the switch isn’t actually charging the battery. Now this switch was bought with repairing it in mind. The only issue with it (at least what I thought was the only issue) was the battery was junk and I needed to replace it. Once replaced it started to work just fine except the switch wouldn’t turn off after long periods of no use. There are some low value caps around the MAX77 ic as well as one next to the BQ ic. Things I should try is to see if the switch is utilizing the quick charging mode via a ammeter and check for any other shorts (there were none around the M9 ic). Is this a hard ware issue or software issue? Any help and ideas will be greatly appreciated. If I need to clarify anything please let me know in the replies. I think one thing that’s interesting is that the switch turns off instantly when I unplug the charging cable. Oh, and appears on tegra
Run and boots into lock pick rcm but not with fusee or hekate, it boots into a black screen when using hekate or fusee
 
  • Like
Reactions: Donnie-Burger

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Here’s what an ammeter is showing.
 

Attachments

  • 2F953BF4-DAB6-4505-9DC9-934F4BD49DCC.jpeg
    2F953BF4-DAB6-4505-9DC9-934F4BD49DCC.jpeg
    3.4 MB · Views: 81

Donnie-Burger

Well-Known Member
Member
Joined
Oct 27, 2021
Messages
927
Trophies
0
Website
www.youtube.com
XP
1,764
Country
United States
Hey there guys, I’m having trouble fixing this switch that was working fine a week ago. It is hacked and I was using it exclusively in emummc to play games I downloaded from tinfoil. The switch only turns on when I hold the power button for several seconds and turns off when the charging cable is unplugged. When the switch is on and I plug the charging cable in the charging notification appears on the top left and next to the battery but the switch isn’t actually charging the battery. Now this switch was bought with repairing it in mind. The only issue with it (at least what I thought was the only issue) was the battery was junk and I needed to replace it. Once replaced it started to work just fine except the switch wouldn’t turn off after long periods of no use. There are some low value caps around the MAX77 ic as well as one next to the BQ ic. Things I should try is to see if the switch is utilizing the quick charging mode via a ammeter and check for any other shorts (there were none around the M9 ic). Is this a hard ware issue or software issue? Any help and ideas will be greatly appreciated. If I need to clarify anything please let me know in the replies. I think one thing that’s interesting is that the switch turns off instantly when I unplug the charging cable. Oh, and appears on tegra
Run and boots into lock pick rcm but not with fusee or hekate, it boots into a black screen when using hekate or fusee
Check for shorts
M9
Bq
P13
and any other ics that are related to power

Check fuse
Check coil
Can also be a good looking USB C port

M9s are notorious for blowing and sometimes replacing them a few times with new ones fixes power issues.
 

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Check for shorts
M9
Bq
P13
and any other ics that are related to power

Check fuse
Check coil
Can also be a good looking USB C port

M9s are notorious for blowing and sometimes replacing them a few times with new ones fixes power issues.
Ok, i'll double check again. Which ic do you think is most likely responsible
Check for shorts
M9
Bq
P13
and any other ics that are related to power

Check fuse
Check coil
Can also be a good looking USB C port

M9s are notorious for blowing and sometimes replacing them a few times with new ones fixes power issues.
Hey there, I ust checked all the caps surrounding the ICs and there wasn't a short on any of them. The fuse also is fine but Im not sure how I should check the coil. I assume its the big square in between the BQ ic and the charging port? I put my MM in continuity mode and put both ends on each side of the coil and had a ground "short", though i'm not sure if that's the function of the coil?
for the switch turning off once the power cord is unplugged?
 
  • Like
Reactions: Donnie-Burger

Donnie-Burger

Well-Known Member
Member
Joined
Oct 27, 2021
Messages
927
Trophies
0
Website
www.youtube.com
XP
1,764
Country
United States
Ok, i'll double check again. Which ic do you think is most likely responsible

Hey there, I ust checked all the caps surrounding the ICs and there wasn't a short on any of them. The fuse also is fine but Im not sure how I should check the coil. I assume its the big square in between the BQ ic and the charging port? I put my MM in continuity mode and put both ends on each side of the coil and had a ground "short", though i'm not sure if that's the function of the coil?
for the switch turning off once the power cord is unplugged?
Check same as fuse

Continuity mode and -+ on each side

Bad coil = black screen on boot like fuse

I'm doing a switch right now thats giving me a headache - Replaced, m9, bq, p13 and reballed 32gb module 2 times. Reball was good becaause 32gb wasnt being read in hekate and now I was able to dump 32gb - Now I get a nintendo logo then black screen. Just replaced m9 again as they come bad new a lot. Fingers croess.

To answer your question - For me the most common faults I get are USB C and M9 with p13 next then bq.
 

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Check same as fuse

Continuity mode and -+ on each side

Bad coil = black screen on boot like fuse

I'm doing a switch right now thats giving me a headache - Replaced, m9, bq, p13 and reballed 32gb module 2 times. Reball was good becaause 32gb wasnt being read in hekate and now I was able to dump 32gb - Now I get a nintendo logo then black screen. Just replaced m9 again as they come bad new a lot. Fingers croess.

To answer your question - For me the most common faults I get are USB C and M9 with p13 next then bq.
so both the fuse and coil are supposed to be read as grounded on the multimeter? If so, I think both the fuse and coil are fine.
 
  • Like
Reactions: Donnie-Burger

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Check same as fuse

Continuity mode and -+ on each side

Bad coil = black screen on boot like fuse

I'm doing a switch right now thats giving me a headache - Replaced, m9, bq, p13 and reballed 32gb module 2 times. Reball was good becaause 32gb wasnt being read in hekate and now I was able to dump 32gb - Now I get a nintendo logo then black screen. Just replaced m9 again as they come bad new a lot. Fingers croess.

To answer your question - For me the most common faults I get are USB C and M9 with p13 next then bq.
I just realized there's a slight beeping buzz noise coming from someone on the board. It goes away when I unplug the charger. I checked the amperage (I think that's what you refer to it as) on the batter before and after I left it charging and the values decreased. Almost as if the switch is pulling power from the batter but not charging it.
 
  • Like
Reactions: Donnie-Burger

Donnie-Burger

Well-Known Member
Member
Joined
Oct 27, 2021
Messages
927
Trophies
0
Website
www.youtube.com
XP
1,764
Country
United States
I just realized there's a slight beeping buzz noise coming from someone on the board. It goes away when I unplug the charger. I checked the amperage (I think that's what you refer to it as) on the batter before and after I left it charging and the values decreased. Almost as if the switch is pulling power from the batter but not charging it.
Replaced m9 again and same thing. Tough one.
 

Donnie-Burger

Well-Known Member
Member
Joined
Oct 27, 2021
Messages
927
Trophies
0
Website
www.youtube.com
XP
1,764
Country
United States
I just realized there's a slight beeping buzz noise coming from someone on the board. It goes away when I unplug the charger. I checked the amperage (I think that's what you refer to it as) on the batter before and after I left it charging and the values decreased. Almost as if the switch is pulling power from the batter but not charging it.
Well im in atmos.
Was hardware issue and once reballed 32gb emmc and replaced a shorted p13usb had software issue. OG side black screen and mod side ok. Most likely a failed downgrade since I see remnants of tx from customer.
 
Last edited by Donnie-Burger,

OhItsSlick

Well-Known Member
OP
Newcomer
Joined
Sep 17, 2021
Messages
85
Trophies
0
Age
21
XP
635
Country
United States
Well im in atmos.
Was hardware issue and once reballed 32gb emmc and replaced a shorted p13usb had software issue. OG side black screen and mod side ok. Most likely a failed downgrade since I see remnants of tx from customer.
Hey there again, i just replaced the BQ ic and the low value shorts are now gone but now Im need geting a value reading on the non ground side of the caps so I think It's not making a good connection with the pads (the BQ ic itself)? What do you think? The battery is now charging so thats a good sign, gonna wait for it to reach 3.7 amps before I proceed.
 
  • Like
Reactions: Donnie-Burger

Donnie-Burger

Well-Known Member
Member
Joined
Oct 27, 2021
Messages
927
Trophies
0
Website
www.youtube.com
XP
1,764
Country
United States
Hey there again, i just replaced the BQ ic and the low value shorts are now gone but now Im need geting a value reading on the non ground side of the caps so I think It's not making a good connection with the pads (the BQ ic itself)? What do you think? The battery is now charging so thats a good sign, gonna wait for it to reach 3.7 amps before I proceed.
Let it charge and test. If no go then make sure BQ is nice and tight. Always good to press slightly down on the ics at time of liquification.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • Sicklyboy @ Sicklyboy:
    This perspective is all linux oriented fwiw. I believe there's an sshfs driver for Windows, but I haven't used it yet. and no idea for MacOS
  • K3Nv2 @ K3Nv2:
    Ftp is life if not on wifi
  • wolffangalchemist @ wolffangalchemist:
    yeah ftp and occasionally samba at the house.
  • impeeza @ impeeza:
    By the way under Windows you can use Total Commander to access so many sources as drives, SFTP, FTP, WebDav, Cloud shares, etc.
    +1
  • Veho @ Veho:
    Total Commander rules.
  • Xdqwerty @ Xdqwerty:
    I think i can't sleep
  • BakerMan @ BakerMan:
    jailbreaking windows and android is op
  • Xdqwerty @ Xdqwerty:
    Wut
  • BakerMan @ BakerMan:
    i thought that's what they were talking about
  • Xdqwerty @ Xdqwerty:
    Ohkay
  • HiradeGirl @ HiradeGirl:
    Funny.
  • Xdqwerty @ Xdqwerty:
    I heard the first súper meat boy game is better
  • HiradeGirl @ HiradeGirl:
    Free is good.
  • Xdqwerty @ Xdqwerty:
    I almost never use steam, just gonna pirate it
  • Xdqwerty @ Xdqwerty:
    And I heard the steam client makes your pc go slow
  • Xdqwerty @ Xdqwerty:
    Oh and it stopped working with Windows 8.1
  • HiradeGirl @ HiradeGirl:
    That's fair.
  • HiradeGirl @ HiradeGirl:
    I don't know if the epic games store still works in Windows 8 or not
  • Xdqwerty @ Xdqwerty:
    I heard epic is worse
  • K3Nv2 @ K3Nv2:
    Epics given more free shit out than my mom and people still want to bitch about them
    +1
  • wolffangalchemist @ wolffangalchemist:
    i probably n
    eed to make a epic games account, just have never been arsed too, i have as steam backlog that is pretty endless, on top of other games on my consoles.
  • BigOnYa @ BigOnYa:
    @K3Nv2 Nuh your mums been giving that out to everyone, alot more than Epic gives out.
    BigOnYa @ BigOnYa: @K3Nv2 Nuh your mums been giving that out to everyone, alot more than Epic gives out.