Ios missing on Usb Loader Gx

Discussion in 'Wii - Hacking' started by filipe_m, Sep 4, 2018.

  1. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Hi...

    I have a WiU and i had hack the vWii a few years ago...


    Now i have a Wii from a friend to hack and what i find is a very big mess...


    The wii had been hacking before and i was able to install Usb Loader Gx but when it loads i get: cIOS 222, 245 and 250 are missing!

    I try to acess to hackmii (already installed) to install those cIOS but i get a black screen and a text about scam....

    The Homebrew version is v418 (1.0.1) (already installed)

    Please can someone point me the write direction to fix this and get a working Usb Loader Gx?

    Thanks
    !!
     
    Last edited by filipe_m, Sep 4, 2018
  2. SSorin

    SSorin Member

    Newcomer
    1
    Sep 4, 2018
    Romania
    Romania
    "Pimp my wii" should help you with that,and also update your Usb Loader GX,don't use a forwader channel,use it via homebrew
     
    filipe_m likes this.
  3. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    3
    Feb 13, 2017
    United States
    1. Don't use Pimp My Wii
    2. Yea, update it.
    3. If the fowarder works, then you can use it, though if you want to be safe, then just load GX through HBC.
     
    filipe_m likes this.
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    USBLoaderGX is not developped to tell you that. there's no code or function to even write this text on screen.
    I don't know which program you are using.

    So much bad advice here.

    what you need is so simple, why make it so complicated ?
    1. get d2x v8 final base57 in slot 249. that's all ! you need ONE and only one cIOS.
    2. get latest version of USBLoaderGX and copy on SD card.
    3. install the forwarder !

    that's all you need.

    Don't listen to people who tell you to not use it, because it's part of the loader! without it you'll have black screen and freezes.
    never use pimpMyWii, unless you want a real mess and a non working console.
    don't "just update" without knowing what you should update. latest version is not always the better ! (that's why pimpMyWii is bad)
    You get a black screen when trying to update Homebrew Channel because previous user used PimpMyWii too ! hackmii installer don't work anymore. You can't update HBC !

    The problem is you need HBC at least 1.0.7, or no homebrew will work.
    You'll need to do something specific to fix your console ! don't try random thing, wait for me to tell you.




    Once you have HBC1.0.7 or newer, you can continue.

    1. follow this guide :
    https://gbatemp.net/posts/5812338

    2. and 3. .. well, all is explained on that link.
     
    Last edited by Cyan, Sep 4, 2018
    rommy667, ry755 and filipe_m like this.
  5. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Thanks for your help...

    I can launch Usb loader gx from homebrew but not from forwarder. I believe I am using is last version.

    It loads completely but when it is starting shows the info about missing cIOS...

    After that does not recognize my USB pen (sandisk 16gb). I know I should use a hard drive instead a pendrive but the hard drive from my vwii is 3.0 and my friend old Wii is not compatible.

    So at this point my question is: the missing cIOS with a working hard drive are not a problem and my only problem is the pendrive? Or without that cIOS USBloader gx won't work even with a recognised hard drive?
     
    Last edited by filipe_m, Sep 4, 2018
  6. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Thanks...

    I saw your answer after my previous post...

    I will see careful your recommendation and try it...

    About the pen: could be a formation problem? Like a cluster size issue? Or it will never be recognize... I can't get a hard drive to test this...
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    wait a little, I'm still writing the guide.

    because your console is a mess.

    you clearly don't have latest version then. latest version don't tell you about missing cIOS.

    what do you mean ? WiiU is also not compatible with USB3.0 drives !
    Wii and WiiU are using USB2.0 ! even if you plug a USB3.0 drive, you use usb2.0 cable.


    your real problem is : the console is a mess, and outdated !

    like I said above : don't touch it anymore until I tell you. don't make things worse.
     
    Last edited by Cyan, Sep 4, 2018
  8. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    3
    Feb 13, 2017
    United States
    No, usually if a fowarder doesn't work. Then the folder containing the dol or elf is named wrong.
    Try renaming the folder that has the USB Loader GX dol to usbloader_gx.
     
    Last edited by FancyNintendoGamer567, Sep 4, 2018
    SSorin likes this.
  9. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Thanks... I will wait...

    No doubt: it is a mess and outdate...

    About the harddrive: works ok on my vwii but on my friend Wii USBloader gx don't recognize it... It says "waiting for hdd" or something like that..
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    because your friend's wii is not properly setup.
    you need to change a setting.
     
  11. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    3
    Feb 13, 2017
    United States
  12. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Yes... Same result...
     
  13. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    It's more frequent that the forwarder doesn't work because it is requesting an IOS that isn't installed (like 58.)

    Is it an actual physical HDD or a flash drive?
     
    filipe_m likes this.
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    @FIX94, is the OHBC wad working on both Wii and vWii ?
    https://github.com/FIX94/hbc/releases

    did you update your nand booter (the one you made and we use in vWii forwarders) to work on both consoles? I would use it to update USBLoaderGX forwarder if we can have the same wad for both consoles now.


    @JoostinOnline or @XFlak:
    maybe you see something I don't. I might think on one way to fix it, but there are probably other method, modmii probably has a guide for that too.
    or maybe it's a lot easier and I don't have all my mind into it tonight.
    to me, this console is a little stuck because of this:
    hackmii installer don't work, he probably don't have any more vulnerable IOS (pympmywii? xCorp?), so I think installing OHBC wad could be a solution to bypass the scam screen.
    He is using an old HBC without AHB access. I don't remember if 1.0.1 already had the old ahb tag. (<no_ios_reload/>), we could try with syscheck or yawmm?




    Filipe : still wait for confirmation and steps.
    you can also listen to fix94, joostin, greywolf, xflax, rycardo (not sure he'd know for this situation). sorry for other capable users I forgot :P
     
    Last edited by Cyan, Sep 4, 2018
    filipe_m likes this.
  15. FIX94

    FIX94 Global Moderator

    Global Moderator
    20
    Dec 3, 2009
    Germany
    ???
    yep, it works on both, and no its not using my nand loader, theirs just seems to work on both for some reason, never looked into how.
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    okay, thanks.
    I suppose we could use theirs to build a dummy channels, and inject forwarder dol into it to use with the usbloaders. not sure changing the titleID with a tool wouldn't mess the wii/vWii dual compatibility.
    I'll try to create the ohbc wad file to see if I have all the needed dependencies and make a proper UNEO forwarder.



    so, Filipe, get these file :
    most up to date Homebrew channel : https://github.com/FIX94/hbc/releases/download/1.1.4-1/Homebrew.Channel.-.OHBC.wad and copy to SD card (in sd:/wad/ folder)
    most up to date wad manager : https://github.com/FIX94/Some-YAWMM-Mod/releases/download/v1.0/some-yawmm-mod-v1.0.zip and extract to your SD card.

    Maybe wait for one other member to confirm the steps. I don't want to let you do something wrong.

    WAIT : I forgot one very important thing ! you need IOS58 first !
    run your HBC, and press home button. It will probably tell you "IOS62", which is not good for next step.

    don't follow the guide yet. wait for someone to help you get proper IOS58 on your console first, or verify you already have it. maybe you have it if previous user uses pimpmywii, but it would have updated hbc too I suppose, so it's very old and IOS58 didn't even exist.
    I will also leave and continue help you tomorrow. remember who can help you and knows wii very well.

    Warning: Spoilers inside!

    if HBC 1.1.4-1 is properly installed, you will end with 2 HBC channel, it's not a problem. just be sure to launch the newest version from now on.
    then you can follow the guide to install USBLoaderGX.
    I would also recommend following modmii anyway to fix all your other system files.
     
    Last edited by Cyan, Sep 4, 2018
    filipe_m likes this.
  17. filipe_m
    OP

    filipe_m Advanced Member

    Newcomer
    2
    Jul 20, 2014
    Portugal
    Thanks to all for your concern and help...

    It is a physical Hdd...

    I will wait for your instructions @Cyan...

    My understanding about Wii system is zero... I hacked my vwii and my WiiU with help and tutorials from this forum.. but without understanding anything about it.

    Thanks again!!


    Edit:

    I saw your answer now... Tomorrow at the end of the day I will try it and give feedback...

    I understand I don't need to change anything already install on Wii or on SD card first, correct?
     
    Last edited by filipe_m, Sep 4, 2018
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    no, don't change anything on SD or USB.
    except if you have a folder 00000001 on SD, delete it.
     
    filipe_m likes this.
  19. SSorin

    SSorin Member

    Newcomer
    1
    Sep 4, 2018
    Romania
    Romania
    You made my life easier,some friends told me that forwader channels don't work on my wii because it's unstable,i discovered now they were only lies.
     
  20. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    the forwarder being unstable could be because you don't use SD card, and your homebrew to load on USB is on a device which has a detection/initialization issue.
    some drive need more time to wake up and mount the partition, it's usually fixed by launching the forwarder a second time after returning to the wii menu (the drive did the init at the same time).

    if USBLoaderGX also has issue with detecting drive, you need to set the Loader's IOS to 58 instead of 249.
    I made some changes in current beta, maybe you/your friend can test it one day to see if it helps (1269 in my signature, replace the boot.dol in loader's folder). not sure it's working fine, but it's (trying) using 58 by default now.
     
    SSorin likes this.
Loading...