Installing Legit Game CIA's? 9.2.0

Discussion in '3DS - Homebrew Development and Emulators' started by ShinyMK, Jan 5, 2016.

  1. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    So im on 9.2.0-20E on CFW (rxTools).

    I got myself a download of Animal Crossing Happy Home Designer and its v2.0 update also as a .cia.

    How can I install these to be playable?
     


  2. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    o3ds or n3ds? EDIT: nvm read sig
    (Assuming you have an emuNAND set up)
    Use the FBI Injection to inject FBI into the H&S app
    1.) Check the version of the H&S app by going to rxTools -> Advanced -> FBI Injection -> emuNand -> Press B (write down the number next to 'TMD:')
    2.) In the rxTools archive go to : release/Tools/fbi_injection/<your region>/<that number you wrote down>/ and copy those files to the root of your sd card.
    3.) Go back to the FBI Injection in rxTools and select emuNAND and press Y.
    4.) It should tell you if it succeeded or not, if it did, continue.
    5.) Reboot into emuNAND and open FBI
    6.) Install the Cias
     
    Last edited by JershXL, Jan 5, 2016
  3. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    I did that and installed BigBlueMenu and FBI and I tried installing with both of them AND installed the update for the game but when I open the game I just get an error saying to trun off the ds and retry.
    The game is Animal crossing Happy Home Designer gotten from Dat Iso Site.
     
  4. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    Hmm.. I don't know much about how CIA's need to be prepared. It might have to be firmware spoofed/cryptofixed/etc..
     
  5. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    I saw on the place I got it saying the uplaoder didnt do any firmware spoofing so ill look around on that.
     
  6. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    I would imagine since HHD is pretty new it would require a semi-up-to-date firmware (I don't know what version your emuNAND is)
     
  7. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Its the same 9.2.0-20E i dont know much so I didnt update it. If I update it wouldnt I be screwed? Would I still be able to install cias and do that stuff etc?
     
  8. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    I'm no expert, but I believe since it's an o3DS you could update your emuNAND all the way to 10.3 (I would recommend backing up your emuNAND just in case I'm dead wrong). I know the max emuNAND version for n3DS is 9.5 though.
     
  9. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    I can update it yes but if I update it wouldnt I be screwed and not be able to install cias etc?
     
  10. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    From what I've been reading, you can't install CIA's on the higher firmwares (but again I'd be happy to be proven wrong)
    EDIT: If you have FBI already installed as a CIA, you might be able to update to 10.3 (but don't use eshop, use sysUpdater and update files from dat iso site.
    LINK: https://gbatemp.net/threads/cia-installer-for-emunand-10-3.408038/
     
    Last edited by JershXL, Jan 5, 2016
  11. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Hmm Are you able to run Game CIA's on ur Emunand?
     
  12. JershXL

    JershXL Advanced Member

    Newcomer
    78
    10
    Dec 6, 2015
    United States
    emuNAND
    So far, I've got SmileBASIC and Pilotwings Resort working. I tried Terraria, but that did not work.
    (But seriously, before you try anything, BACKUP YOUR EMUNAND)
     
    Last edited by JershXL, Jan 5, 2016
    DesuIsSparta likes this.
  13. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    hmm we need a pro to come in on this thread lmao we need guadance rn
     
  14. jaksy

    jaksy GBAtemp Advanced Fan

    Member
    551
    197
    Jun 10, 2014
    United States
    It's as @JershXL says, Happy Home Designer requires a much newer FW to boot.
    Or you can find a FW spoofed version.

    You can safely update your emunand to 10.3 through system settings if you do this carefully and properly after booting emunand with unlinked nands.
     
    Last edited by jaksy, Jan 5, 2016
  15. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Do you know if theres one on dat iso site? Btw @JershXL im literally dumping it right now but it failed :/
     
  16. jaksy

    jaksy GBAtemp Advanced Fan

    Member
    551
    197
    Jun 10, 2014
    United States
    You can find out just as easily as I can.
     
  17. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Not rlly xD Im looking on he iso site but I cant seem to know where to look
     
  18. jaksy

    jaksy GBAtemp Advanced Fan

    Member
    551
    197
    Jun 10, 2014
    United States
    Then you're probably better off unlinking your nands and updating your emunand to 10.3 so you don't have to worry about FW spoofing.
     
    JershXL likes this.
  19. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    I already unlinked but when I update the emunand wouldnt I be blocked from installing more cia's?
     
  20. jaksy

    jaksy GBAtemp Advanced Fan

    Member
    551
    197
    Jun 10, 2014
    United States
    No because you are still launching the emunand through RXtools which disables the signature check.

    If you updated your sysnand above 9.2 you'd be locked out.
    That's the main reason for unlinking nands, to prevent updating your emunand from updating your sysnand aswell.
     
    Last edited by jaksy, Jan 5, 2016
    Ammako and ShinyMK like this.