Installing CIAs Help

Discussion in '3DS - Homebrew Development and Emulators' started by Dylan Scott, Jul 2, 2015.

  1. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    Hi, so I am getting a Sky3DS and will be able to emulate Cubic Ninja for use with the NINJHAX exploit. This is only assuming it ends up working with Firmware 9.8 after he updates it.

    My question is how installing and playing user made GBA CIAs works? Do I need to do anything special to the file? Or do I need to be running a CFW for it to work? Or can I simply launch FBI through the Hombrew Launcher and then install the GBA CIA on my sysNAND and play it like normal?

    Im sorry, I'm just a little confused as to how the CIAs work. Any advice on how installing DLC and the likes would be nice too. Thanks in advance.
     
  2. Adeka

    Adeka Beta Tester

    Member
    4,127
    1,284
    Mar 19, 2013
    United States
    No hacks unless your on 9.2 or below. Your stuck with cart emulation.
     
  3. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    I already know all of the information behind that. If you would have read what I posted, I said "assuming the exploit works on 9.8 AFTER he updates it"
     
  4. Adeka

    Adeka Beta Tester

    Member
    4,127
    1,284
    Mar 19, 2013
    United States
    If you upgrade to 9.8 then your screwed no matter what.

    You need to create emunand and update that.

    I don't know why you bought sky3ds. You can run rxtools on 9.2 and below without any game cart!
     
  5. Melon__Bread

    Melon__Bread ~It's A Magik~

    Member
    710
    400
    Dec 9, 2013
    United States
    Congrats!
    Still we will not know until it is released, and what can and cannot be ported to 9.8
     
  6. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    Because I'm already on 9.8.

    So GBA CIAs only work on an emuNAND or CFW because of their ability to run unsigned CIAs for current exploits right?
     
  7. Adeka

    Adeka Beta Tester

    Member
    4,127
    1,284
    Mar 19, 2013
    United States
    if your on 9.8 official firmware then cia games wont work at all
     
  8. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    I know this. It has been established. I knew this before you told me, considering their are no exploits for 9.8 released yet.

    I am asking, hypothetically, if the update allows support for pretty much the same things that the current 9.2 exploit allows, then what exactly is needed for the installation of the CIAs?

    Would I (Hypothetically) have to be running inside of a CFW, or would I just be able to install the GBA CIA from FBI on my sysNAND and play it like normal?
     
  9. Melon__Bread

    Melon__Bread ~It's A Magik~

    Member
    710
    400
    Dec 9, 2013
    United States
    1. Cubic Ninja + PastaCFW (Works for N3DS & O3DS)
    2. rxTools (Works for O3DS)
     
  10. Adeka

    Adeka Beta Tester

    Member
    4,127
    1,284
    Mar 19, 2013
    United States
    It wont happen because custom firmware requires arm11 and arm9

    Ninjhax only uses one (can't remember which one it was)
     
  11. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    I am simply talking about intalling the CIAs via FBI in the Homebrew Launcher started through the NINJHAX exploit.

    Ok, now is a CFW required in ALL cases to run custom CIAs?

    So my question is: To install CIAs, would I NEED to be on a CFW?
    So my question is: CIAs wont work unless you are running a CFW (i.e. Pasta/rxTools)?
     
  12. dnuch

    dnuch Member

    Newcomer
    15
    1
    Apr 17, 2015
    United States
    sorry, but i have a problem myself. So i have 4.2 linked sysnand and emunand with 9.8 using rxtools and I installed a cia file on sysnand with cubic ninja. The cia file does not show on the emunand like it does with sysnand, but is read in the data management with an x on it. How do i fix this?
     
  13. Adeka

    Adeka Beta Tester

    Member
    4,127
    1,284
    Mar 19, 2013
    United States
    You MUST be in cfw to run any kind of cia unless they were factory installed on any 3ds (like this 3ds had mario and luigi dream team factory installed)
     
  14. Dylan Scott
    OP

    Dylan Scott Member

    Newcomer
    12
    0
    Jul 2, 2015
    United States
    Ok. Thank you very much for clearing up my confusion. I will stick to my Sky3DS until they release an exploit to run CFW on 9.8 so that I can run other kinds of Homebrew and games.
     
  15. Melon__Bread

    Melon__Bread ~It's A Magik~

    Member
    710
    400
    Dec 9, 2013
    United States