i'm in panic mode - please help. can't mount microSD

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
hi,
i've using SXOS since forever and yesterday i tried to change it to Atmosphere
i was using emuNAND from SXOS located in sysNAND (not in hidden partition on SD Card)

download the CFW, copy into microSD and i can boot into CFW
but it still using the old OFW in sysNAND (5.1)

i tried asking Atmosphere to load into the SXOS's emuNAND however i follow the wrong guide and set the location of emuNAND in hidden partition on SD Card
(i forgot the guide, but it used "emummc" folder and emummc.ini with enabled=1 etcetc)

however the 1st time i'm booting with the wrong emummc, it says error "unable to mount the SD Card"
after this, i can't even boot into SXOX which is fine before migration (i'm using 2 SD Card, 1 for SXOX, 1 for Atmosphere)
SXOS keep showing "BOOT.DAT?" screen

from here, i read about microSD slot might be the problem, but i boot into OFW, the microSD is mounted correctly.

then i boot into hekate, and it shows that my microSD is in 1-bit mode

dang!
then i opened the Switch and can confirm the slot on the motherboard is missing 2 pin

okay, from here on is my questions :
1. does Atmosphere need full speed to load the CFW?
2. does emummc settings changed something in sysNAND (BOOT0, BOOT1, or somewhere?) because i can't load into any CFW right now. i want to know the culprit is the lower speed microSD or emummc messed something in my NAND?
3. what should i do now?

i don't mind slower loading time but at least i want to boot into CFW

Thank you and please help!
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
hi,
i've using SXOS since forever and yesterday i tried to change it to Atmosphere
i was using emuNAND from SXOS located in sysNAND (not in hidden partition on SD Card)

download the CFW, copy into microSD and i can boot into CFW
but it still using the old OFW in sysNAND (5.1)

i tried asking Atmosphere to load into the SXOS's emuNAND however i follow the wrong guide and set the location of emuNAND in hidden partition on SD Card
(i forgot the guide, but it used "emummc" folder and emummc.ini with enabled=1 etcetc)

however the 1st time i'm booting with the wrong emummc, it says error "unable to mount the SD Card"
after this, i can't even boot into SXOX which is fine before migration (i'm using 2 SD Card, 1 for SXOX, 1 for Atmosphere)
SXOS keep showing "BOOT.DAT?" screen

from here, i read about microSD slot might be the problem, but i boot into OFW, the microSD is mounted correctly.

then i boot into hekate, and it shows that my microSD is in 1-bit mode

dang!
then i opened the Switch and can confirm the slot on the motherboard is missing 2 pin

okay, from here on is my questions :
1. does Atmosphere need full speed to load the CFW?
2. does emummc settings changed something in sysNAND (BOOT0, BOOT1, or somewhere?) because i can't load into any CFW right now. i want to know the culprit is the lower speed microSD or emummc messed something in my NAND?
3. what should i do now?

i don't mind slower loading time but at least i want to boot into CFW

Thank you and please help!

take a look here: https://github.com/CTCaer/hekate/issues/467

You can run CFW on Emmumc but it will run like crap. You need to fix your SD card reader. Any cellphone/electronics repair shop should be able to quickly solder in a new connector on your mob.

as for what might have happened on your card, can you mount in on your PC and see things like your boot.dat and license.dat?
 
  • Like
Reactions: impeeza and ils

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
hi,

thank you for the reply
yes, i'm aware of the slow loading time

however i need to know if the emummc setting messed with NAND in any way or the "fail to mount microSD card" is due to slow loading speed?

in the link you gave me :
CTCaer did confirm "You can still use CFW and OFW. But the sd performance will be a mere 5MB/s until you repair that."

however all i have is black screen with error mount microSD card in the end -> i want to know how to fix this, or this is due to slow loading speed?

also, yes, my microSD contain boot.dat and license.dat (tried copy several times also)
both worked before the emummc "incident"

thank you
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
hi,

thank you for the reply
yes, i'm aware of the slow loading time

however i need to know if the emummc setting messed with NAND in any way or the "fail to mount microSD card" is due to slow loading speed?

in the link you gave me :
CTCaer did confirm "You can still use CFW and OFW. But the sd performance will be a mere 5MB/s until you repair that."

however all i have is black screen with error mount microSD card in the end -> i want to know how to fix this, or this is due to slow loading speed?

thank you

To help determine that I need to know if you can mount your sd card in your computer and see if you can see your files such as boot.dat and license.dat.
 

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
To help determine that I need to know if you can mount your sd card in your computer and see if you can see your files such as boot.dat and license.dat.
yeah sorry, i just edit my reply above

yes, my microSD contain boot.dat and license.dat (tried copy several times for boot.dat too from my PC)
both worked before the emummc "incident"
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
yeah sorry, i just edit my reply above

yes, my microSD contain boot.dat and license.dat (tried copy several times for boot.dat too from my PC)
both worked before the emummc "incident"

Great! please send a screenshot of the root level directory structure of your SD card from your computer.
 

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
microSD-atm.JPG


here is my microSD card
i've deleted the emummc folder because i thought i would inflict more problem :(
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
View attachment 301824

here is my microSD card
i've deleted the emummc folder because i thought i would inflict more problem :(
Would have been nice to see where Atmosphere was writing but no worries. The good news is you can mount the card. From the sounds of it you might have overwritten part of your SXOS emunand.

before we do anything:

1) I would recommend taking a backup of your sd card.
2) It would be good to work on a different sd card altogether if you have one available.

There are a couple paths forward depending upon what you want to achieve.

Do you want to:

a) format the card and install Atmosphere?
b) migrate what you have to Atmosphere?
c) just get back to where you were with SXOS?
d) something else I didn’t think of?
 

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
yeah, i don't need anything from my old system
option A is good enough but i also need to erase the SXOS emuNAND (in the sysNAND) or can i re-use it for my next emuNAND for Atmosphere? (because my microSD is too slow now)
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
yeah, i don't need anything from my old system
option A is good enough but i also need to erase the SXOS emuNAND (in the sysNAND) or can i re-use it for my next emuNAND for Atmosphere? (because my microSD is too slow now)

Option A is easier so that’s good news. (Still recommend the backup but that’s up to you.)

you can attempt to save some time by converting you SXOS emunand to Atmosphere. It’s a fast conversion. If that fails we will simply have to suffer through the slow speed of the card. I’ve never dealt with the 1bit speed so I don’t know how bad it really is.

I’ve used this in the past to migrate emunands around between hidden/files and Atmos/SXOS. Read through this in detail before you make any changes to your card.

https://gbatemp.net/threads/emutool...r-sd-switch-emu-type-on-sxos-and-more.550756/

I suspect we’ll find out pretty quickly if you can tolerate 1bit mode…
 

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
alright thank you
i'll try later at home

however i don't think the tools can migrate the SXOS emuNAND located on the sysNAND ?
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,586
Trophies
2
XP
1,801
Country
United States
alright thank you
i'll try later at home

however i don't think the tools can migrate the SXOS emuNAND located on the sysNAND ?

if you just want to copy your sysnand to a new emunand you can do that through Hekate. 30G at 5MB/s can’t be THAT slow.

Do you have a backup of your sysnand? If so you can do this completely outside of the Switch using nxnand manager: https://github.com/eliboa/NxNandManager

being creative here…trying to stay off of that slow sd card reader.
 
Last edited by binkinator,
  • Like
Reactions: ils

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
if you just want to copy your sysnand to a new emunand you can do that through Hekate. 30G at 5MB/s can’t be THAT slow.

Do you have a backup of your sysnand? If so yiu can do this completely outside of the Switch using nxnand manager: https://github.com/eliboa/NxNandManager
fortunately yes, i've taken my BOOT0, BOOT1 and rawnand.bin before
but i kinda afraid to flash the sysnand lol

it seems sthetix has a video about this problem

but for me, hekate still can see the card
only Atmosphere and SXOS can't
 

fvig2001

Well-Known Member
Member
Joined
Aug 21, 2006
Messages
705
Trophies
0
XP
2,094
Country
Philippines
Oof I had this issue before and I'll answer your questions

1. does Atmosphere need full speed to load the CFW?
In theory no but last time I checked sciresM hasn't fixed a bug related to this. Like his exploit does not run on 1 bit mode on 10.0 (last time I tried). He basically asked me to ask help from CTCaer.

He gave me a tool to bypass the part that hanged but the SD card could not be changed (it writes info on the first bytes) and if Nintendo changes the keys again, you would need CTCaer's help.

2. does emummc settings changed something in sysNAND (BOOT0, BOOT1, or somewhere?) because i can't load into any CFW right now. i want to know the culprit is the lower speed microSD or emummc messed something in my NAND?

For hekate, no. I'm not sure about sxOS. Hekate uses the same files/partitions as NAND. It sounds like Atmosphere still does not support 1 bit mode. He really should fix it since normal switches work on 1 bit mode.


3. what should i do now?

I would try:
1. Loading atmosphere through hekate to boot into normal nand.

If it doesn't work, contact CTCaer (Join one of his discords and ask him there) and hope he can help fix your problem on the current firmware. He gave me a tool to migrate EKS (I think that was the term) and it bypassed the part that sciresM hasn't fixed.

Once you can get it to boot, I would:

1. Find someone to fix the switch
2. If not, invest in a 256gb eMMC and use that. emunand will be too slow for you. You can have smaller games on your SD card but bigger games take a longer time to load. Otherwise, you can play games of eMMC at full speeds.
3. If you do #2, expect homebrew apps that use atmosphere's exploit to be broken. I had to use weird tools to actually resize my eMMC and I ended up making a tutorial for it.

I ended up just giving that switch to my brother but I haven't updated it in a year.

If you do #2, can you inform me if you had issues and can you pm me the tool just in case my brother wants to upgrade the switch.

thanks
 
Last edited by fvig2001,
  • Like
Reactions: ils and binkinator

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
Oof I had this issue before and I'll answer your questions

1. does Atmosphere need full speed to load the CFW?
In theory no but last time I checked sciresM hasn't fixed a bug related to this. Like his exploit does not run on 1 bit mode on 10.0 (last time I tried). He basically asked me to ask help from CTCaer.

He gave me a tool to bypass the part that hanged but the SD card could not be changed (it writes info on the first bytes) and if Nintendo changes the keys again, you would need CTCaer's help.

2. does emummc settings changed something in sysNAND (BOOT0, BOOT1, or somewhere?) because i can't load into any CFW right now. i want to know the culprit is the lower speed microSD or emummc messed something in my NAND?

For hekate, no. I'm not sure about sxOS. Hekate uses the same files/partitions as NAND. It sounds like Atmosphere still does not support 1 bit mode. He really should fix it since normal switches work on 1 bit mode.


3. what should i do now?

I would try:
1. Loading atmosphere through hekate to boot into normal nand.

If it doesn't work, contact CTCaer (Join one of his discords and ask him there) and hope he can help fix your problem on the current firmware. He gave me a tool to migrate EKS (I think that was the term) and it bypassed the part that sciresM hasn't fixed.

Once you can get it to boot, I would:

1. Find someone to fix the switch
2. If not, invest in a 256gb eMMC and use that. emunand will be too slow for you. You can have smaller games on your SD card but bigger games take a longer time to load. Otherwise, you can play games of eMMC at full speeds.
3. If you do #2, expect homebrew apps that use atmosphere's exploit to be broken. I had to use weird tools to actually resize my eMMC and I ended up making a tutorial for it.

I ended up just giving that switch to my brother but I haven't updated it in a year.

If you do #2, can you inform me if you had issues and can you pm me the tool just in case my brother wants to upgrade the switch.

thanks
wow a lot of information here :)
it seems like the ideal way is to fix the switch

i'll try asking local shop here, they should be able to fix this for a price
but i rarely use this device anymore, my last resort would be use OFW only since it didn't use the SD card much.
luckily my games are all physical, only DLC like XC2 Torna uses microSD

thank you all, i'll try a few things later tonight.
hopefully at least i can boot into atmosphere but i don't want to get my hopes up
 

fvig2001

Well-Known Member
Member
Joined
Aug 21, 2006
Messages
705
Trophies
0
XP
2,094
Country
Philippines
Hope you can get it fixed. The people that fixes phones were either stupid or didn't want to follow the diagrams/pinouts/schematics that I gave. I ended up just deciding to buy a new switch and give the older one to my brother (It broke after I upgrade to 256gb).
 

ils

Well-Known Member
OP
Newcomer
Joined
Mar 8, 2008
Messages
83
Trophies
0
XP
398
Country
Indonesia
1 bit mode means there's a problem with the connection between the SD card reader and the 16 pin connector.

Either it's loose, some pins are broken or the SD card reader is faulty.
yeah, there's 2 missing pin on the motherboard port.

before I do something, is there any benefit to stay in lower FW now? my OFW is 5.1.0.

or should I upgrade to the latest?

thank you all
 

Hayato213

..
Member
Joined
Dec 26, 2015
Messages
11,922
Trophies
1
Location
Aionios
XP
7,448
Country
United States
(i'm using 2 SD Card, 1 for SXOX, 1 for Atmosphere)

Well here is your problem, from switching between two SD card, that how you killed your slot, you have few options here, first you can try a replacement sd card flex, if that doesn't work you might have to solder a wire from connection on the board to pin on the flex.

9uveru1xho051.jpg
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    DEMONGreninjaPG @ DEMONGreninjaPG: gross