[Idea] 9.2 "downgrade" pack

Discussion in '3DS - Flashcards & Custom Firmwares' started by MassExplosion213, Sep 7, 2015.

  1. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    Could we make a 9.2 "downgrade" pack to use with gateway to avoid having to use sysUpdater?
     
  2. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    GW launcher checks hash values. So you are thinking about creating packs for current GW launcher, I'd say it is not possible.
     
  3. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    Maybe a modified launcher?
     
  4. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    There has been no modified GW launcher yet, AFAIK...
     
  5. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    If we can modify GW launcher, there would not be reinand-like cfws.
    That is not as easy as you think.
     
  6. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    How so?
     
  7. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    Obfuscation
     
  8. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    But it's already been partially decrypted.
     
    Zidapi likes this.
  9. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    Then ask reisyukaku why he made a cfw from scratch.
     
  10. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    I won't lie, the cfw part is completely understandable. But why not the downgrade part?
     
  11. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    I think you don't understand
     
  12. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    We already know how the downgrade function works. How could we not make something to upgrade using that?
     
  13. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    Because we don't know yet how that works. All we know that GW's emuNAND is same as all CFW as that is unmodified (exact copy as sysNAND but just a first bit placed differently).
    GW launcher code is highly obfuscated (google the term if you not sure exactly what that means), which is why nobody bothers to decrypt it when we already have other open sourced launchers available.
     
  14. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    I know what obfuscation is. But how the downgrade function works is known.
     
  15. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    You can make one.
    I am sure developers capable of making these are not interested in it since sysupdater does its job perfectly.
     
  16. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    So do we have dg packs other than GW's? Does it function exactly as it is? Does it perform FIRM upgrade procedure (as we already know that just copying/overwriting system titles will not make it work, there needs to send additional command or it will just brick)
     
  17. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    We have the tools to make them. I actually have them on my PC. And idk. Haven't tested.
     
  18. Dean_

    Dean_ GBAtemp Advanced Fan

    Member
    651
    374
    Sep 11, 2014
    Making DG packs(a piece of cake) and programming downgrader is a whole other story..
     
  19. MassExplosion213
    OP

    MassExplosion213 .

    Member
    1,433
    961
    Feb 15, 2015
    United States
    I'll try. Idk how it'll work, but I'll try.

    EDIT: Or better yet, include the update CIAs in a copy of sysUpdater.
     
    Dean_ likes this.
  20. zoogie

    zoogie simple pimp tool

    Member
    6,516
    8,388
    Nov 30, 2014
    United States
    First versions of ntr cfw were modified GW loaders. And the clones, don't forget about them.